summaryrefslogtreecommitdiff
path: root/python-admesh.spec
diff options
context:
space:
mode:
authorCoprDistGit <copr-devel@lists.fedorahosted.org>2023-03-07 13:05:41 +0000
committerCoprDistGit <copr-devel@lists.fedorahosted.org>2023-03-07 13:05:41 +0000
commitbac2a403e257f85b56d2e335f8c5e376f66125fb (patch)
treee51379bd7a75d46375f9c15e02d09d4254a750e8 /python-admesh.spec
parentcb5ead47d5ddedf6bc695983819055dc79d256c7 (diff)
automatic import of python-admesh
Diffstat (limited to 'python-admesh.spec')
-rw-r--r--python-admesh.spec72
1 files changed, 72 insertions, 0 deletions
diff --git a/python-admesh.spec b/python-admesh.spec
new file mode 100644
index 0000000..8582f61
--- /dev/null
+++ b/python-admesh.spec
@@ -0,0 +1,72 @@
+%global _empty_manifest_terminate_build 0
+Name: python-admesh
+Version: 0.98.9
+Release: 1
+Summary: Python bindings for ADMesh, STL maipulation library
+License: GPLv2+
+URL: https://github.com/admesh/python-admesh
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/be/18/65160f0b5c6b2e08627ea96dc6f1b65a99898b9caddd8f97f47b338491a8/admesh-0.98.9.tar.gz
+BuildArch: noarch
+
+
+%description
+This module provides bindings for the `ADMesh <https://github.com/admesh/admesh>`_ library. It lets you manipulate 3D models in binary or ASCII STL format and partially repair them if necessary.
+
+%package -n python3-admesh
+Summary: Python bindings for ADMesh, STL maipulation library
+Provides: python-admesh
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-admesh
+This module provides bindings for the `ADMesh <https://github.com/admesh/admesh>`_ library. It lets you manipulate 3D models in binary or ASCII STL format and partially repair them if necessary.
+
+%package help
+Summary: Development documents and examples for admesh
+Provides: python3-admesh-doc
+%description help
+This module provides bindings for the `ADMesh <https://github.com/admesh/admesh>`_ library. It lets you manipulate 3D models in binary or ASCII STL format and partially repair them if necessary.
+
+%prep
+%autosetup -n admesh-0.98.9
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-admesh -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Mar 07 2023 Python_Bot <Python_Bot@openeuler.org> - 0.98.9-1
+- Package Spec generated