summaryrefslogtreecommitdiff
path: root/python-adsmsg.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-adsmsg.spec')
-rw-r--r--python-adsmsg.spec75
1 files changed, 75 insertions, 0 deletions
diff --git a/python-adsmsg.spec b/python-adsmsg.spec
new file mode 100644
index 0000000..8926487
--- /dev/null
+++ b/python-adsmsg.spec
@@ -0,0 +1,75 @@
+%global _empty_manifest_terminate_build 0
+Name: python-adsmsg
+Version: 1.3.3
+Release: 1
+Summary: Interpipeline communication messages
+License: MIT
+URL: http://github.com/adsabs/flask-discoverer/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/70/65/4fbeeedd47d61819ec4b601658316d71f01bbdb7c32b20a3a22977bef514/adsmsg-1.3.3.tar.gz
+BuildArch: noarch
+
+Requires: python3-protobuf
+Requires: python3-future
+Requires: python3-simplejson
+
+%description
+Interpipeline communication messages
+
+%package -n python3-adsmsg
+Summary: Interpipeline communication messages
+Provides: python-adsmsg
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-adsmsg
+Interpipeline communication messages
+
+%package help
+Summary: Development documents and examples for adsmsg
+Provides: python3-adsmsg-doc
+%description help
+Interpipeline communication messages
+
+%prep
+%autosetup -n adsmsg-1.3.3
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-adsmsg -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Thu May 18 2023 Python_Bot <Python_Bot@openeuler.org> - 1.3.3-1
+- Package Spec generated