summaryrefslogtreecommitdiff
path: root/python-adutils.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-10 07:10:59 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-10 07:10:59 +0000
commitf8da19d9ecdb11a38e2fbbd3a85c055cf0b3ab3d (patch)
tree60e135c5a1ec9f670ee3afbeacce08e578fe83a5 /python-adutils.spec
parent12e8cf9ed07ba3e4eda8572771b549e3eb1a56be (diff)
automatic import of python-adutils
Diffstat (limited to 'python-adutils.spec')
-rw-r--r--python-adutils.spec126
1 files changed, 126 insertions, 0 deletions
diff --git a/python-adutils.spec b/python-adutils.spec
new file mode 100644
index 0000000..a4011ec
--- /dev/null
+++ b/python-adutils.spec
@@ -0,0 +1,126 @@
+%global _empty_manifest_terminate_build 0
+Name: python-adutils
+Version: 0.6.2
+Release: 1
+Summary: Helper and utilities for AppDaemon apps.
+License: MIT
+URL: https://github.com/benleb/adutils
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/e4/91/dfa7ccd31cb3712a74eaa7866c993e8fc4a3bca0d539c283de4c4bb16851/adutils-0.6.2.tar.gz
+BuildArch: noarch
+
+
+%description
+# adutils
+
+[![PyPI](https://img.shields.io/pypi/v/adutils)](https://pypi.org/project/adutils/) [![PyPI - Python Version](https://img.shields.io/pypi/pyversions/adutils)](https://pypi.org/project/adutils/) [![PyPI - Downloads](https://img.shields.io/pypi/dm/adutils)](https://pypi.org/project/adutils/)
+
+Helper functions for AppDaemon apps. Currently there is just code, no documentation. Sorry ¯\\_(ツ)_/¯
+
+## Install
+
+```bash
+pip install adutils
+```
+
+## Apps using **adutils**
+
+* [AutoMoLi](https://github.com/benleb/ad-automoli)
+* [EnCh](https://github.com/benleb/ad-ench)
+* [Notifreeze](https://github.com/benleb/ad-notifreeze)
+* [Healthcheck](https://github.com/benleb/ad-healthcheck)
+
+
+%package -n python3-adutils
+Summary: Helper and utilities for AppDaemon apps.
+Provides: python-adutils
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-adutils
+# adutils
+
+[![PyPI](https://img.shields.io/pypi/v/adutils)](https://pypi.org/project/adutils/) [![PyPI - Python Version](https://img.shields.io/pypi/pyversions/adutils)](https://pypi.org/project/adutils/) [![PyPI - Downloads](https://img.shields.io/pypi/dm/adutils)](https://pypi.org/project/adutils/)
+
+Helper functions for AppDaemon apps. Currently there is just code, no documentation. Sorry ¯\\_(ツ)_/¯
+
+## Install
+
+```bash
+pip install adutils
+```
+
+## Apps using **adutils**
+
+* [AutoMoLi](https://github.com/benleb/ad-automoli)
+* [EnCh](https://github.com/benleb/ad-ench)
+* [Notifreeze](https://github.com/benleb/ad-notifreeze)
+* [Healthcheck](https://github.com/benleb/ad-healthcheck)
+
+
+%package help
+Summary: Development documents and examples for adutils
+Provides: python3-adutils-doc
+%description help
+# adutils
+
+[![PyPI](https://img.shields.io/pypi/v/adutils)](https://pypi.org/project/adutils/) [![PyPI - Python Version](https://img.shields.io/pypi/pyversions/adutils)](https://pypi.org/project/adutils/) [![PyPI - Downloads](https://img.shields.io/pypi/dm/adutils)](https://pypi.org/project/adutils/)
+
+Helper functions for AppDaemon apps. Currently there is just code, no documentation. Sorry ¯\\_(ツ)_/¯
+
+## Install
+
+```bash
+pip install adutils
+```
+
+## Apps using **adutils**
+
+* [AutoMoLi](https://github.com/benleb/ad-automoli)
+* [EnCh](https://github.com/benleb/ad-ench)
+* [Notifreeze](https://github.com/benleb/ad-notifreeze)
+* [Healthcheck](https://github.com/benleb/ad-healthcheck)
+
+
+%prep
+%autosetup -n adutils-0.6.2
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-adutils -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 0.6.2-1
+- Package Spec generated