summaryrefslogtreecommitdiff
path: root/python-aepp.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-aepp.spec')
-rw-r--r--python-aepp.spec357
1 files changed, 357 insertions, 0 deletions
diff --git a/python-aepp.spec b/python-aepp.spec
new file mode 100644
index 0000000..5348a92
--- /dev/null
+++ b/python-aepp.spec
@@ -0,0 +1,357 @@
+%global _empty_manifest_terminate_build 0
+Name: python-aepp
+Version: 0.2.11
+Release: 1
+Summary: Package to manage AEP API endpoint and some helper functions
+License: GNU General Public License v3 (GPLv3)
+URL: https://github.com/pitchmuc/aep
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/6f/8f/61a957e6f035c1a030ba018203a5c37ba6eb044e6c4f599395ce6ac22f26/aepp-0.2.11.tar.gz
+BuildArch: noarch
+
+Requires: python3-pandas
+Requires: python3-requests
+Requires: python3-PyJWT
+Requires: python3-pathlib2
+Requires: python3-pathlib
+Requires: python3-PyJWT[crypto]
+
+%description
+# Adobe Experience Platform API made for humans
+
+This repository will document the AEP wrapper on python.
+It is focusing on helping accessing the different endpoints of Adobe Experience Platform API.
+Documentation on the different endpoints can be found here : [AEP API doc](https://www.adobe.io/apis/experienceplatform/home/api-reference.html)
+The wrapper is currently named **aepp**, it stands for Adobe Experience Platform Python.
+
+## Installation
+
+You can install the module directly from a pypi command:
+
+```shell
+pip install aepp
+```
+
+The version of the wrapper can be seen by the following command (once loaded):
+
+```python
+import aepp
+aepp.__version__
+
+```
+
+**Consider upgrading regulary**
+
+```shell
+pip install aepp --upgrade
+```
+
+**NOTE TO PYTHON 3.10.X**
+
+At the moment, not all packages are supported on python 3.10.X, therefore, please use this module with a python 3.9.X version.\
+You can use pyenv to generate a local environment if required.
+
+## Getting Started
+
+In order to get started, I have compile a guide to help you initialize this module and what is required.
+You can find this documentation [here](./docs/getting-started.md)
+
+## AEPP docs
+
+At the moment the current wrapper is containing the following sub modules:
+
+* [schema](./docs/schema.md)
+* [queryservice](./docs/queryservice.md) (see note below)
+* [identity](./docs/identity.md)
+* [sandboxes](./docs/sandboxes.md)
+* [dataaccess](./docs/dataaccess.md)
+* [catalog](./docs/catalog.md)
+* [customerprofile](./docs/customerprofile.md)
+* [segmentation](./docs/segmentation.md)
+* [dataprep](./docs/dataprep.md)
+* [flowservice](./docs/flowservice.md)
+* [policy](./docs/policy.md)
+* [datasets](./docs/datasets.md)
+* [ingestion](./docs/ingestion.md)
+* [destination Authoring](./docs/destination.md)
+* [destination Instance](./docs/destinationinstanceservice.md)
+* [observability](./docs/observability.md)
+* accesscontrol
+* sensei
+* [privacyservice](./docs/privacyservice.md) (see 2nd note below)
+
+Last but not least, the core methods are described here: [main](./docs/main.md)
+
+## queryservice module
+
+The queryservice Module contains 2 classes:
+
+### QueryService class
+
+The QueryService class is the wrapper around the AEP Query Service API.\
+It provides access to the different endpoints available from the API.
+
+Use-Case example : At the moment the capability to scheduled query is only accessible from the API.
+
+[Detail documentation](./docs/queryservice.md)
+
+#### InteractiveQuery and InteractiveQuery2 classes
+
+These classes are based on the pyGreSQL and psycopg2 module for python.\
+It provides you the capability to realize query directly from your local Jupyter notebook and returns a dataframe.
+In order to use these classes, you would need to install these module and a PSQL server.
+On top of that, you would need to the psql server accessible in the environment path.
+
+## PrivacyService module
+
+The privacy service module is part of the AEP python wrapper but requires a different JWT connection in console.adobe.io.
+Be careful that your JWT connection has the correct setup to access this API endpoints.
+
+## Releases
+
+Release notes are accessible [here](./docs/releases.md).
+
+
+%package -n python3-aepp
+Summary: Package to manage AEP API endpoint and some helper functions
+Provides: python-aepp
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-aepp
+# Adobe Experience Platform API made for humans
+
+This repository will document the AEP wrapper on python.
+It is focusing on helping accessing the different endpoints of Adobe Experience Platform API.
+Documentation on the different endpoints can be found here : [AEP API doc](https://www.adobe.io/apis/experienceplatform/home/api-reference.html)
+The wrapper is currently named **aepp**, it stands for Adobe Experience Platform Python.
+
+## Installation
+
+You can install the module directly from a pypi command:
+
+```shell
+pip install aepp
+```
+
+The version of the wrapper can be seen by the following command (once loaded):
+
+```python
+import aepp
+aepp.__version__
+
+```
+
+**Consider upgrading regulary**
+
+```shell
+pip install aepp --upgrade
+```
+
+**NOTE TO PYTHON 3.10.X**
+
+At the moment, not all packages are supported on python 3.10.X, therefore, please use this module with a python 3.9.X version.\
+You can use pyenv to generate a local environment if required.
+
+## Getting Started
+
+In order to get started, I have compile a guide to help you initialize this module and what is required.
+You can find this documentation [here](./docs/getting-started.md)
+
+## AEPP docs
+
+At the moment the current wrapper is containing the following sub modules:
+
+* [schema](./docs/schema.md)
+* [queryservice](./docs/queryservice.md) (see note below)
+* [identity](./docs/identity.md)
+* [sandboxes](./docs/sandboxes.md)
+* [dataaccess](./docs/dataaccess.md)
+* [catalog](./docs/catalog.md)
+* [customerprofile](./docs/customerprofile.md)
+* [segmentation](./docs/segmentation.md)
+* [dataprep](./docs/dataprep.md)
+* [flowservice](./docs/flowservice.md)
+* [policy](./docs/policy.md)
+* [datasets](./docs/datasets.md)
+* [ingestion](./docs/ingestion.md)
+* [destination Authoring](./docs/destination.md)
+* [destination Instance](./docs/destinationinstanceservice.md)
+* [observability](./docs/observability.md)
+* accesscontrol
+* sensei
+* [privacyservice](./docs/privacyservice.md) (see 2nd note below)
+
+Last but not least, the core methods are described here: [main](./docs/main.md)
+
+## queryservice module
+
+The queryservice Module contains 2 classes:
+
+### QueryService class
+
+The QueryService class is the wrapper around the AEP Query Service API.\
+It provides access to the different endpoints available from the API.
+
+Use-Case example : At the moment the capability to scheduled query is only accessible from the API.
+
+[Detail documentation](./docs/queryservice.md)
+
+#### InteractiveQuery and InteractiveQuery2 classes
+
+These classes are based on the pyGreSQL and psycopg2 module for python.\
+It provides you the capability to realize query directly from your local Jupyter notebook and returns a dataframe.
+In order to use these classes, you would need to install these module and a PSQL server.
+On top of that, you would need to the psql server accessible in the environment path.
+
+## PrivacyService module
+
+The privacy service module is part of the AEP python wrapper but requires a different JWT connection in console.adobe.io.
+Be careful that your JWT connection has the correct setup to access this API endpoints.
+
+## Releases
+
+Release notes are accessible [here](./docs/releases.md).
+
+
+%package help
+Summary: Development documents and examples for aepp
+Provides: python3-aepp-doc
+%description help
+# Adobe Experience Platform API made for humans
+
+This repository will document the AEP wrapper on python.
+It is focusing on helping accessing the different endpoints of Adobe Experience Platform API.
+Documentation on the different endpoints can be found here : [AEP API doc](https://www.adobe.io/apis/experienceplatform/home/api-reference.html)
+The wrapper is currently named **aepp**, it stands for Adobe Experience Platform Python.
+
+## Installation
+
+You can install the module directly from a pypi command:
+
+```shell
+pip install aepp
+```
+
+The version of the wrapper can be seen by the following command (once loaded):
+
+```python
+import aepp
+aepp.__version__
+
+```
+
+**Consider upgrading regulary**
+
+```shell
+pip install aepp --upgrade
+```
+
+**NOTE TO PYTHON 3.10.X**
+
+At the moment, not all packages are supported on python 3.10.X, therefore, please use this module with a python 3.9.X version.\
+You can use pyenv to generate a local environment if required.
+
+## Getting Started
+
+In order to get started, I have compile a guide to help you initialize this module and what is required.
+You can find this documentation [here](./docs/getting-started.md)
+
+## AEPP docs
+
+At the moment the current wrapper is containing the following sub modules:
+
+* [schema](./docs/schema.md)
+* [queryservice](./docs/queryservice.md) (see note below)
+* [identity](./docs/identity.md)
+* [sandboxes](./docs/sandboxes.md)
+* [dataaccess](./docs/dataaccess.md)
+* [catalog](./docs/catalog.md)
+* [customerprofile](./docs/customerprofile.md)
+* [segmentation](./docs/segmentation.md)
+* [dataprep](./docs/dataprep.md)
+* [flowservice](./docs/flowservice.md)
+* [policy](./docs/policy.md)
+* [datasets](./docs/datasets.md)
+* [ingestion](./docs/ingestion.md)
+* [destination Authoring](./docs/destination.md)
+* [destination Instance](./docs/destinationinstanceservice.md)
+* [observability](./docs/observability.md)
+* accesscontrol
+* sensei
+* [privacyservice](./docs/privacyservice.md) (see 2nd note below)
+
+Last but not least, the core methods are described here: [main](./docs/main.md)
+
+## queryservice module
+
+The queryservice Module contains 2 classes:
+
+### QueryService class
+
+The QueryService class is the wrapper around the AEP Query Service API.\
+It provides access to the different endpoints available from the API.
+
+Use-Case example : At the moment the capability to scheduled query is only accessible from the API.
+
+[Detail documentation](./docs/queryservice.md)
+
+#### InteractiveQuery and InteractiveQuery2 classes
+
+These classes are based on the pyGreSQL and psycopg2 module for python.\
+It provides you the capability to realize query directly from your local Jupyter notebook and returns a dataframe.
+In order to use these classes, you would need to install these module and a PSQL server.
+On top of that, you would need to the psql server accessible in the environment path.
+
+## PrivacyService module
+
+The privacy service module is part of the AEP python wrapper but requires a different JWT connection in console.adobe.io.
+Be careful that your JWT connection has the correct setup to access this API endpoints.
+
+## Releases
+
+Release notes are accessible [here](./docs/releases.md).
+
+
+%prep
+%autosetup -n aepp-0.2.11
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-aepp -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 0.2.11-1
+- Package Spec generated