summaryrefslogtreecommitdiff
path: root/python-affirmations.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-10 08:30:49 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-10 08:30:49 +0000
commitdd033ffa99dba3a65b90eef40e6e7198ba33480c (patch)
tree6d7c2440d61f5df3f3cb7b03ce3901ca0b6b58a3 /python-affirmations.spec
parentccea522f7434c600f13e86a97b43b865adaeab57 (diff)
automatic import of python-affirmations
Diffstat (limited to 'python-affirmations.spec')
-rw-r--r--python-affirmations.spec180
1 files changed, 180 insertions, 0 deletions
diff --git a/python-affirmations.spec b/python-affirmations.spec
new file mode 100644
index 0000000..73a2220
--- /dev/null
+++ b/python-affirmations.spec
@@ -0,0 +1,180 @@
+%global _empty_manifest_terminate_build 0
+Name: python-Affirmations
+Version: 0.0.10
+Release: 1
+Summary: Randomly adds affirming print statements to functions.
+License: MIT License
+URL: https://github.com/TimNicholsonShaw/affirmation
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/ca/ca/b4e701f17671b63b24a4f90c36f54ae83d576b324f41620d4c3b20666b8b/Affirmations-0.0.10.tar.gz
+BuildArch: noarch
+
+
+%description
+# Affirmations
+
+A module that gives you a little bump of encouragement.
+
+## Requirements
+- A positive attitude
+- A can-do spirit
+
+## Installation
+
+```bash
+pip install Affirmations
+```
+
+## Usage
+
+Decorate any function to get a random affirmation printed to stdout every time that function is run
+
+```
+from Affirmations import affirm
+
+@affirm() # prints an affirmation to stdout 100% of the time this function is run
+def hello_world():
+ print("hello")
+
+@affirm(0.2) # prints an affirmation to stdout 20% of the time this function is run
+def hello_world2():
+ print("hello")
+
+hello_world()
+```
+```bash
+hello
+You are awesome!
+```
+
+
+
+%package -n python3-Affirmations
+Summary: Randomly adds affirming print statements to functions.
+Provides: python-Affirmations
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-Affirmations
+# Affirmations
+
+A module that gives you a little bump of encouragement.
+
+## Requirements
+- A positive attitude
+- A can-do spirit
+
+## Installation
+
+```bash
+pip install Affirmations
+```
+
+## Usage
+
+Decorate any function to get a random affirmation printed to stdout every time that function is run
+
+```
+from Affirmations import affirm
+
+@affirm() # prints an affirmation to stdout 100% of the time this function is run
+def hello_world():
+ print("hello")
+
+@affirm(0.2) # prints an affirmation to stdout 20% of the time this function is run
+def hello_world2():
+ print("hello")
+
+hello_world()
+```
+```bash
+hello
+You are awesome!
+```
+
+
+
+%package help
+Summary: Development documents and examples for Affirmations
+Provides: python3-Affirmations-doc
+%description help
+# Affirmations
+
+A module that gives you a little bump of encouragement.
+
+## Requirements
+- A positive attitude
+- A can-do spirit
+
+## Installation
+
+```bash
+pip install Affirmations
+```
+
+## Usage
+
+Decorate any function to get a random affirmation printed to stdout every time that function is run
+
+```
+from Affirmations import affirm
+
+@affirm() # prints an affirmation to stdout 100% of the time this function is run
+def hello_world():
+ print("hello")
+
+@affirm(0.2) # prints an affirmation to stdout 20% of the time this function is run
+def hello_world2():
+ print("hello")
+
+hello_world()
+```
+```bash
+hello
+You are awesome!
+```
+
+
+
+%prep
+%autosetup -n Affirmations-0.0.10
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-Affirmations -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 0.0.10-1
+- Package Spec generated