summaryrefslogtreecommitdiff
path: root/python-agate-excel.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-agate-excel.spec')
-rw-r--r--python-agate-excel.spec170
1 files changed, 170 insertions, 0 deletions
diff --git a/python-agate-excel.spec b/python-agate-excel.spec
new file mode 100644
index 0000000..0245313
--- /dev/null
+++ b/python-agate-excel.spec
@@ -0,0 +1,170 @@
+%global _empty_manifest_terminate_build 0
+Name: python-agate-excel
+Version: 0.2.5
+Release: 1
+Summary: agate-excel adds read support for Excel files (xls and xlsx) to agate.
+License: MIT
+URL: http://agate-excel.readthedocs.org/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/7c/85/f74ba95d9b4d53ffab0e17a1133d5e5f8c1910f4b48f9f7c116f3bf0c1c8/agate-excel-0.2.5.tar.gz
+BuildArch: noarch
+
+Requires: python3-agate
+Requires: python3-olefile
+Requires: python3-openpyxl
+Requires: python3-six
+Requires: python3-xlrd
+Requires: python3-Sphinx
+Requires: python3-sphinx-rtd-theme
+Requires: python3-nose
+
+%description
+.. image:: https://github.com/wireservice/agate-excel/workflows/CI/badge.svg
+ :target: https://github.com/wireservice/agate-excel/actions
+ :alt: Build status
+
+.. image:: https://img.shields.io/pypi/dm/agate-excel.svg
+ :target: https://pypi.python.org/pypi/agate-excel
+ :alt: PyPI downloads
+
+.. image:: https://img.shields.io/pypi/v/agate-excel.svg
+ :target: https://pypi.python.org/pypi/agate-excel
+ :alt: Version
+
+.. image:: https://img.shields.io/pypi/l/agate-excel.svg
+ :target: https://pypi.python.org/pypi/agate-excel
+ :alt: License
+
+.. image:: https://img.shields.io/pypi/pyversions/agate-excel.svg
+ :target: https://pypi.python.org/pypi/agate-excel
+ :alt: Support Python versions
+
+agate-excel adds read support for Excel files (xls and xlsx) to `agate <https://github.com/wireservice/agate>`_.
+
+Important links:
+
+* agate http://agate.rtfd.org
+* Documentation: http://agate-excel.rtfd.org
+* Repository: https://github.com/wireservice/agate-excel
+* Issues: https://github.com/wireservice/agate-excel/issues
+
+
+
+
+%package -n python3-agate-excel
+Summary: agate-excel adds read support for Excel files (xls and xlsx) to agate.
+Provides: python-agate-excel
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-agate-excel
+.. image:: https://github.com/wireservice/agate-excel/workflows/CI/badge.svg
+ :target: https://github.com/wireservice/agate-excel/actions
+ :alt: Build status
+
+.. image:: https://img.shields.io/pypi/dm/agate-excel.svg
+ :target: https://pypi.python.org/pypi/agate-excel
+ :alt: PyPI downloads
+
+.. image:: https://img.shields.io/pypi/v/agate-excel.svg
+ :target: https://pypi.python.org/pypi/agate-excel
+ :alt: Version
+
+.. image:: https://img.shields.io/pypi/l/agate-excel.svg
+ :target: https://pypi.python.org/pypi/agate-excel
+ :alt: License
+
+.. image:: https://img.shields.io/pypi/pyversions/agate-excel.svg
+ :target: https://pypi.python.org/pypi/agate-excel
+ :alt: Support Python versions
+
+agate-excel adds read support for Excel files (xls and xlsx) to `agate <https://github.com/wireservice/agate>`_.
+
+Important links:
+
+* agate http://agate.rtfd.org
+* Documentation: http://agate-excel.rtfd.org
+* Repository: https://github.com/wireservice/agate-excel
+* Issues: https://github.com/wireservice/agate-excel/issues
+
+
+
+
+%package help
+Summary: Development documents and examples for agate-excel
+Provides: python3-agate-excel-doc
+%description help
+.. image:: https://github.com/wireservice/agate-excel/workflows/CI/badge.svg
+ :target: https://github.com/wireservice/agate-excel/actions
+ :alt: Build status
+
+.. image:: https://img.shields.io/pypi/dm/agate-excel.svg
+ :target: https://pypi.python.org/pypi/agate-excel
+ :alt: PyPI downloads
+
+.. image:: https://img.shields.io/pypi/v/agate-excel.svg
+ :target: https://pypi.python.org/pypi/agate-excel
+ :alt: Version
+
+.. image:: https://img.shields.io/pypi/l/agate-excel.svg
+ :target: https://pypi.python.org/pypi/agate-excel
+ :alt: License
+
+.. image:: https://img.shields.io/pypi/pyversions/agate-excel.svg
+ :target: https://pypi.python.org/pypi/agate-excel
+ :alt: Support Python versions
+
+agate-excel adds read support for Excel files (xls and xlsx) to `agate <https://github.com/wireservice/agate>`_.
+
+Important links:
+
+* agate http://agate.rtfd.org
+* Documentation: http://agate-excel.rtfd.org
+* Repository: https://github.com/wireservice/agate-excel
+* Issues: https://github.com/wireservice/agate-excel/issues
+
+
+
+
+%prep
+%autosetup -n agate-excel-0.2.5
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-agate-excel -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Mar 07 2023 Python_Bot <Python_Bot@openeuler.org> - 0.2.5-1
+- Package Spec generated