summaryrefslogtreecommitdiff
path: root/python-agate-sql.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-agate-sql.spec')
-rw-r--r--python-agate-sql.spec170
1 files changed, 170 insertions, 0 deletions
diff --git a/python-agate-sql.spec b/python-agate-sql.spec
new file mode 100644
index 0000000..e768687
--- /dev/null
+++ b/python-agate-sql.spec
@@ -0,0 +1,170 @@
+%global _empty_manifest_terminate_build 0
+Name: python-agate-sql
+Version: 0.5.9
+Release: 1
+Summary: agate-sql adds SQL read/write support to agate.
+License: MIT
+URL: http://agate-sql.readthedocs.org/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/b6/94/d67d4f01cebb56ab0eb728af6903904b252bc2a85b01838fda7e065279bd/agate-sql-0.5.9.tar.gz
+BuildArch: noarch
+
+Requires: python3-agate
+Requires: python3-sqlalchemy
+Requires: python3-Sphinx
+Requires: python3-sphinx-rtd-theme
+Requires: python3-crate
+Requires: python3-geojson
+Requires: python3-pytest
+Requires: python3-pytest-cov
+
+%description
+.. image:: https://github.com/wireservice/agate-sql/workflows/CI/badge.svg
+ :target: https://github.com/wireservice/agate-sql/actions
+ :alt: Build status
+
+.. image:: https://img.shields.io/pypi/dm/agate-sql.svg
+ :target: https://pypi.python.org/pypi/agate-sql
+ :alt: PyPI downloads
+
+.. image:: https://img.shields.io/pypi/v/agate-sql.svg
+ :target: https://pypi.python.org/pypi/agate-sql
+ :alt: Version
+
+.. image:: https://img.shields.io/pypi/l/agate-sql.svg
+ :target: https://pypi.python.org/pypi/agate-sql
+ :alt: License
+
+.. image:: https://img.shields.io/pypi/pyversions/agate-sql.svg
+ :target: https://pypi.python.org/pypi/agate-sql
+ :alt: Support Python versions
+
+agate-sql adds SQL read/write support to `agate <https://github.com/wireservice/agate>`_.
+
+Important links:
+
+* agate http://agate.rtfd.org
+* Documentation: http://agate-sql.rtfd.org
+* Repository: https://github.com/wireservice/agate-sql
+* Issues: https://github.com/wireservice/agate-sql/issues
+
+
+
+
+%package -n python3-agate-sql
+Summary: agate-sql adds SQL read/write support to agate.
+Provides: python-agate-sql
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-agate-sql
+.. image:: https://github.com/wireservice/agate-sql/workflows/CI/badge.svg
+ :target: https://github.com/wireservice/agate-sql/actions
+ :alt: Build status
+
+.. image:: https://img.shields.io/pypi/dm/agate-sql.svg
+ :target: https://pypi.python.org/pypi/agate-sql
+ :alt: PyPI downloads
+
+.. image:: https://img.shields.io/pypi/v/agate-sql.svg
+ :target: https://pypi.python.org/pypi/agate-sql
+ :alt: Version
+
+.. image:: https://img.shields.io/pypi/l/agate-sql.svg
+ :target: https://pypi.python.org/pypi/agate-sql
+ :alt: License
+
+.. image:: https://img.shields.io/pypi/pyversions/agate-sql.svg
+ :target: https://pypi.python.org/pypi/agate-sql
+ :alt: Support Python versions
+
+agate-sql adds SQL read/write support to `agate <https://github.com/wireservice/agate>`_.
+
+Important links:
+
+* agate http://agate.rtfd.org
+* Documentation: http://agate-sql.rtfd.org
+* Repository: https://github.com/wireservice/agate-sql
+* Issues: https://github.com/wireservice/agate-sql/issues
+
+
+
+
+%package help
+Summary: Development documents and examples for agate-sql
+Provides: python3-agate-sql-doc
+%description help
+.. image:: https://github.com/wireservice/agate-sql/workflows/CI/badge.svg
+ :target: https://github.com/wireservice/agate-sql/actions
+ :alt: Build status
+
+.. image:: https://img.shields.io/pypi/dm/agate-sql.svg
+ :target: https://pypi.python.org/pypi/agate-sql
+ :alt: PyPI downloads
+
+.. image:: https://img.shields.io/pypi/v/agate-sql.svg
+ :target: https://pypi.python.org/pypi/agate-sql
+ :alt: Version
+
+.. image:: https://img.shields.io/pypi/l/agate-sql.svg
+ :target: https://pypi.python.org/pypi/agate-sql
+ :alt: License
+
+.. image:: https://img.shields.io/pypi/pyversions/agate-sql.svg
+ :target: https://pypi.python.org/pypi/agate-sql
+ :alt: Support Python versions
+
+agate-sql adds SQL read/write support to `agate <https://github.com/wireservice/agate>`_.
+
+Important links:
+
+* agate http://agate.rtfd.org
+* Documentation: http://agate-sql.rtfd.org
+* Repository: https://github.com/wireservice/agate-sql
+* Issues: https://github.com/wireservice/agate-sql/issues
+
+
+
+
+%prep
+%autosetup -n agate-sql-0.5.9
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-agate-sql -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Mar 07 2023 Python_Bot <Python_Bot@openeuler.org> - 0.5.9-1
+- Package Spec generated