summaryrefslogtreecommitdiff
path: root/python-aiodocker.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-aiodocker.spec')
-rw-r--r--python-aiodocker.spec74
1 files changed, 74 insertions, 0 deletions
diff --git a/python-aiodocker.spec b/python-aiodocker.spec
new file mode 100644
index 0000000..137f593
--- /dev/null
+++ b/python-aiodocker.spec
@@ -0,0 +1,74 @@
+%global _empty_manifest_terminate_build 0
+Name: python-aiodocker
+Version: 0.21.0
+Release: 1
+Summary: Docker API client for asyncio
+License: Apache 2
+URL: https://github.com/aio-libs/aiodocker
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/6f/f5/5fb3a17fcdd31d3cce9afa82c306da869e2b36c5ca1477224396e5e1f31b/aiodocker-0.21.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-aiohttp
+Requires: python3-typing-extensions
+
+%description
+
+
+%package -n python3-aiodocker
+Summary: Docker API client for asyncio
+Provides: python-aiodocker
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-aiodocker
+
+
+%package help
+Summary: Development documents and examples for aiodocker
+Provides: python3-aiodocker-doc
+%description help
+
+
+%prep
+%autosetup -n aiodocker-0.21.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-aiodocker -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 0.21.0-1
+- Package Spec generated