summaryrefslogtreecommitdiff
path: root/python-aioguardian.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-aioguardian.spec')
-rw-r--r--python-aioguardian.spec231
1 files changed, 231 insertions, 0 deletions
diff --git a/python-aioguardian.spec b/python-aioguardian.spec
new file mode 100644
index 0000000..b55a2af
--- /dev/null
+++ b/python-aioguardian.spec
@@ -0,0 +1,231 @@
+%global _empty_manifest_terminate_build 0
+Name: python-aioguardian
+Version: 2022.10.0
+Release: 1
+Summary: A Python3 library for Elexa Guardian water valves and sensors
+License: MIT
+URL: https://github.com/bachya/aioguardian
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/30/c4/7ed7d373c8f41060f7b6770cea2c9979783e2893c0b3d9cf1b942c4de921/aioguardian-2022.10.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-aiohttp
+Requires: python3-asyncio_dgram
+Requires: python3-voluptuous
+
+%description
+# 🚰 aioguardian: A Python3 library for Elexa Guardian devices
+
+[![CI](https://github.com/bachya/aioguardian/workflows/CI/badge.svg)](https://github.com/bachya/aioguardian/actions)
+[![PyPi](https://img.shields.io/pypi/v/aioguardian.svg)](https://pypi.python.org/pypi/aioguardian)
+[![Version](https://img.shields.io/pypi/pyversions/aioguardian.svg)](https://pypi.python.org/pypi/aioguardian)
+[![License](https://img.shields.io/pypi/l/aioguardian.svg)](https://github.com/bachya/aioguardian/blob/main/LICENSE)
+[![Code Coverage](https://codecov.io/gh/bachya/aioguardian/branch/dev/graph/badge.svg)](https://codecov.io/gh/bachya/aioguardian)
+[![Maintainability](https://api.codeclimate.com/v1/badges/a03c9e96f19a3dc37f98/maintainability)](https://codeclimate.com/github/bachya/aioguardian/maintainability)
+[![Say Thanks](https://img.shields.io/badge/SayThanks-!-1EAEDB.svg)](https://saythanks.io/to/bachya)
+
+<a href="https://www.buymeacoffee.com/bachya1208P" target="_blank"><img src="https://cdn.buymeacoffee.com/buttons/default-orange.png" alt="Buy Me A Coffee" height="41" width="174"></a>
+
+`aioguardian` is a Python3, `asyncio`-focused library for interacting with
+[the Guardian line of water valves and sensors from Elexa](http://getguardian.com).
+
+- [Installation](#installation)
+- [Python Versions](#python-versions)
+- [Documentation](#documentation)
+- [Contributing](#contributing)
+
+# Installation
+
+```bash
+pip install aioguardian
+```
+
+# Python Versions
+
+`aioguardian` is currently supported on:
+
+- Python 3.9
+- Python 3.10
+- Python 3.11
+
+# Documentation
+
+Complete documentation can be found here: http://aioguardian.readthedocs.io
+
+# Contributing
+
+1. [Check for open features/bugs](https://github.com/bachya/aioguardian/issues)
+ or [initiate a discussion on one](https://github.com/bachya/aioguardian/issues/new).
+2. [Fork the repository](https://github.com/bachya/aioguardian/fork).
+3. (_optional, but highly recommended_) Create a virtual environment: `python3 -m venv .venv`
+4. (_optional, but highly recommended_) Enter the virtual environment: `source ./.venv/bin/activate`
+5. Install the dev environment: `script/setup`
+6. Code your new feature or bug fix.
+7. Write tests that cover your new functionality.
+8. Run tests and ensure 100% code coverage: `poetry run pytest --cov aioguardian tests`
+9. Update `README.md` with any new documentation.
+10. Add yourself to `AUTHORS.md`.
+11. Submit a pull request!
+
+
+%package -n python3-aioguardian
+Summary: A Python3 library for Elexa Guardian water valves and sensors
+Provides: python-aioguardian
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-aioguardian
+# 🚰 aioguardian: A Python3 library for Elexa Guardian devices
+
+[![CI](https://github.com/bachya/aioguardian/workflows/CI/badge.svg)](https://github.com/bachya/aioguardian/actions)
+[![PyPi](https://img.shields.io/pypi/v/aioguardian.svg)](https://pypi.python.org/pypi/aioguardian)
+[![Version](https://img.shields.io/pypi/pyversions/aioguardian.svg)](https://pypi.python.org/pypi/aioguardian)
+[![License](https://img.shields.io/pypi/l/aioguardian.svg)](https://github.com/bachya/aioguardian/blob/main/LICENSE)
+[![Code Coverage](https://codecov.io/gh/bachya/aioguardian/branch/dev/graph/badge.svg)](https://codecov.io/gh/bachya/aioguardian)
+[![Maintainability](https://api.codeclimate.com/v1/badges/a03c9e96f19a3dc37f98/maintainability)](https://codeclimate.com/github/bachya/aioguardian/maintainability)
+[![Say Thanks](https://img.shields.io/badge/SayThanks-!-1EAEDB.svg)](https://saythanks.io/to/bachya)
+
+<a href="https://www.buymeacoffee.com/bachya1208P" target="_blank"><img src="https://cdn.buymeacoffee.com/buttons/default-orange.png" alt="Buy Me A Coffee" height="41" width="174"></a>
+
+`aioguardian` is a Python3, `asyncio`-focused library for interacting with
+[the Guardian line of water valves and sensors from Elexa](http://getguardian.com).
+
+- [Installation](#installation)
+- [Python Versions](#python-versions)
+- [Documentation](#documentation)
+- [Contributing](#contributing)
+
+# Installation
+
+```bash
+pip install aioguardian
+```
+
+# Python Versions
+
+`aioguardian` is currently supported on:
+
+- Python 3.9
+- Python 3.10
+- Python 3.11
+
+# Documentation
+
+Complete documentation can be found here: http://aioguardian.readthedocs.io
+
+# Contributing
+
+1. [Check for open features/bugs](https://github.com/bachya/aioguardian/issues)
+ or [initiate a discussion on one](https://github.com/bachya/aioguardian/issues/new).
+2. [Fork the repository](https://github.com/bachya/aioguardian/fork).
+3. (_optional, but highly recommended_) Create a virtual environment: `python3 -m venv .venv`
+4. (_optional, but highly recommended_) Enter the virtual environment: `source ./.venv/bin/activate`
+5. Install the dev environment: `script/setup`
+6. Code your new feature or bug fix.
+7. Write tests that cover your new functionality.
+8. Run tests and ensure 100% code coverage: `poetry run pytest --cov aioguardian tests`
+9. Update `README.md` with any new documentation.
+10. Add yourself to `AUTHORS.md`.
+11. Submit a pull request!
+
+
+%package help
+Summary: Development documents and examples for aioguardian
+Provides: python3-aioguardian-doc
+%description help
+# 🚰 aioguardian: A Python3 library for Elexa Guardian devices
+
+[![CI](https://github.com/bachya/aioguardian/workflows/CI/badge.svg)](https://github.com/bachya/aioguardian/actions)
+[![PyPi](https://img.shields.io/pypi/v/aioguardian.svg)](https://pypi.python.org/pypi/aioguardian)
+[![Version](https://img.shields.io/pypi/pyversions/aioguardian.svg)](https://pypi.python.org/pypi/aioguardian)
+[![License](https://img.shields.io/pypi/l/aioguardian.svg)](https://github.com/bachya/aioguardian/blob/main/LICENSE)
+[![Code Coverage](https://codecov.io/gh/bachya/aioguardian/branch/dev/graph/badge.svg)](https://codecov.io/gh/bachya/aioguardian)
+[![Maintainability](https://api.codeclimate.com/v1/badges/a03c9e96f19a3dc37f98/maintainability)](https://codeclimate.com/github/bachya/aioguardian/maintainability)
+[![Say Thanks](https://img.shields.io/badge/SayThanks-!-1EAEDB.svg)](https://saythanks.io/to/bachya)
+
+<a href="https://www.buymeacoffee.com/bachya1208P" target="_blank"><img src="https://cdn.buymeacoffee.com/buttons/default-orange.png" alt="Buy Me A Coffee" height="41" width="174"></a>
+
+`aioguardian` is a Python3, `asyncio`-focused library for interacting with
+[the Guardian line of water valves and sensors from Elexa](http://getguardian.com).
+
+- [Installation](#installation)
+- [Python Versions](#python-versions)
+- [Documentation](#documentation)
+- [Contributing](#contributing)
+
+# Installation
+
+```bash
+pip install aioguardian
+```
+
+# Python Versions
+
+`aioguardian` is currently supported on:
+
+- Python 3.9
+- Python 3.10
+- Python 3.11
+
+# Documentation
+
+Complete documentation can be found here: http://aioguardian.readthedocs.io
+
+# Contributing
+
+1. [Check for open features/bugs](https://github.com/bachya/aioguardian/issues)
+ or [initiate a discussion on one](https://github.com/bachya/aioguardian/issues/new).
+2. [Fork the repository](https://github.com/bachya/aioguardian/fork).
+3. (_optional, but highly recommended_) Create a virtual environment: `python3 -m venv .venv`
+4. (_optional, but highly recommended_) Enter the virtual environment: `source ./.venv/bin/activate`
+5. Install the dev environment: `script/setup`
+6. Code your new feature or bug fix.
+7. Write tests that cover your new functionality.
+8. Run tests and ensure 100% code coverage: `poetry run pytest --cov aioguardian tests`
+9. Update `README.md` with any new documentation.
+10. Add yourself to `AUTHORS.md`.
+11. Submit a pull request!
+
+
+%prep
+%autosetup -n aioguardian-2022.10.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-aioguardian -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Mar 07 2023 Python_Bot <Python_Bot@openeuler.org> - 2022.10.0-1
+- Package Spec generated