summaryrefslogtreecommitdiff
path: root/python-aiohttp-negotiate.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-aiohttp-negotiate.spec')
-rw-r--r--python-aiohttp-negotiate.spec72
1 files changed, 72 insertions, 0 deletions
diff --git a/python-aiohttp-negotiate.spec b/python-aiohttp-negotiate.spec
new file mode 100644
index 0000000..a1101aa
--- /dev/null
+++ b/python-aiohttp-negotiate.spec
@@ -0,0 +1,72 @@
+%global _empty_manifest_terminate_build 0
+Name: python-aiohttp-negotiate
+Version: 0.10.2
+Release: 1
+Summary: Mixin for Negotiate authentication for aiohttp
+License: BSD
+URL: https://github.com/ox-it/aiohttp-negotiate
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/80/2a/c792280f8e02a58bd8e57e8c906af9ea7f051cd8b27f77851aabfe28d32a/aiohttp-negotiate-0.10.2.tar.gz
+BuildArch: noarch
+
+
+%description
+A mixin for supporting Negotiate authentication with aiohttp.
+
+%package -n python3-aiohttp-negotiate
+Summary: Mixin for Negotiate authentication for aiohttp
+Provides: python-aiohttp-negotiate
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-aiohttp-negotiate
+A mixin for supporting Negotiate authentication with aiohttp.
+
+%package help
+Summary: Development documents and examples for aiohttp-negotiate
+Provides: python3-aiohttp-negotiate-doc
+%description help
+A mixin for supporting Negotiate authentication with aiohttp.
+
+%prep
+%autosetup -n aiohttp-negotiate-0.10.2
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-aiohttp-negotiate -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Mar 07 2023 Python_Bot <Python_Bot@openeuler.org> - 0.10.2-1
+- Package Spec generated