summaryrefslogtreecommitdiff
path: root/python-aiohttp-sse-client.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-aiohttp-sse-client.spec')
-rw-r--r--python-aiohttp-sse-client.spec76
1 files changed, 76 insertions, 0 deletions
diff --git a/python-aiohttp-sse-client.spec b/python-aiohttp-sse-client.spec
new file mode 100644
index 0000000..b4cf631
--- /dev/null
+++ b/python-aiohttp-sse-client.spec
@@ -0,0 +1,76 @@
+%global _empty_manifest_terminate_build 0
+Name: python-aiohttp-sse-client
+Version: 0.2.1
+Release: 1
+Summary: A Server-Sent Event python client base on aiohttp
+License: Apache License 2.0
+URL: https://github.com/rtfol/aiohttp-sse-client
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/71/c3/4825c5f37909a70c8018924b3d521847dd7acf1fce7e1054574bafed2271/aiohttp-sse-client-0.2.1.tar.gz
+BuildArch: noarch
+
+Requires: python3-aiohttp
+Requires: python3-attrs
+Requires: python3-multidict
+Requires: python3-yarl
+
+%description
+
+
+%package -n python3-aiohttp-sse-client
+Summary: A Server-Sent Event python client base on aiohttp
+Provides: python-aiohttp-sse-client
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-aiohttp-sse-client
+
+
+%package help
+Summary: Development documents and examples for aiohttp-sse-client
+Provides: python3-aiohttp-sse-client-doc
+%description help
+
+
+%prep
+%autosetup -n aiohttp-sse-client-0.2.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-aiohttp-sse-client -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Mar 07 2023 Python_Bot <Python_Bot@openeuler.org> - 0.2.1-1
+- Package Spec generated