From 9c28f8049d8057512bfe1b9be056e723aa5fd942 Mon Sep 17 00:00:00 2001
From: CoprDistGit <copr-devel@lists.fedorahosted.org>
Date: Tue, 7 Mar 2023 13:16:28 +0000
Subject: automatic import of python-aiozmq

---
 python-aiozmq.spec | 104 +++++++++++++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 104 insertions(+)
 create mode 100644 python-aiozmq.spec

(limited to 'python-aiozmq.spec')

diff --git a/python-aiozmq.spec b/python-aiozmq.spec
new file mode 100644
index 0000000..d3d35d7
--- /dev/null
+++ b/python-aiozmq.spec
@@ -0,0 +1,104 @@
+%global _empty_manifest_terminate_build 0
+Name:		python-aiozmq
+Version:	1.0.0
+Release:	1
+Summary:	ZeroMQ integration with asyncio.
+License:	BSD
+URL:		http://aiozmq.readthedocs.org
+Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/f6/1a/02537050681c6bf52a815f37e9c9087e031b09b44cd9ac885d87770fe87a/aiozmq-1.0.0.tar.gz
+BuildArch:	noarch
+
+Requires:	python3-pyzmq
+Requires:	python3-msgpack
+
+%description
+asyncio (PEP 3156) support for ZeroMQ.
+The difference between ``aiozmq`` and vanilla ``pyzmq`` (``zmq.asyncio``) is:
+``zmq.asyncio`` works only by replacing the *base event loop* with a custom one.
+This approach works but has two disadvantages:
+1. ``zmq.asyncio.ZMQEventLoop`` cannot be combined with
+   other loop implementations (most notable is the ultra fast ``uvloop``).
+2. It uses the internal ZMQ Poller which has fast ZMQ Sockets support
+   but isn't intended to work fast with many (thousands) regular TCP sockets.
+   In practice it means that ``zmq.asyncio`` is not recommended to be used with
+   web servers like ``aiohttp``.
+   See also https://github.com/zeromq/pyzmq/issues/894
+
+%package -n python3-aiozmq
+Summary:	ZeroMQ integration with asyncio.
+Provides:	python-aiozmq
+BuildRequires:	python3-devel
+BuildRequires:	python3-setuptools
+BuildRequires:	python3-pip
+%description -n python3-aiozmq
+asyncio (PEP 3156) support for ZeroMQ.
+The difference between ``aiozmq`` and vanilla ``pyzmq`` (``zmq.asyncio``) is:
+``zmq.asyncio`` works only by replacing the *base event loop* with a custom one.
+This approach works but has two disadvantages:
+1. ``zmq.asyncio.ZMQEventLoop`` cannot be combined with
+   other loop implementations (most notable is the ultra fast ``uvloop``).
+2. It uses the internal ZMQ Poller which has fast ZMQ Sockets support
+   but isn't intended to work fast with many (thousands) regular TCP sockets.
+   In practice it means that ``zmq.asyncio`` is not recommended to be used with
+   web servers like ``aiohttp``.
+   See also https://github.com/zeromq/pyzmq/issues/894
+
+%package help
+Summary:	Development documents and examples for aiozmq
+Provides:	python3-aiozmq-doc
+%description help
+asyncio (PEP 3156) support for ZeroMQ.
+The difference between ``aiozmq`` and vanilla ``pyzmq`` (``zmq.asyncio``) is:
+``zmq.asyncio`` works only by replacing the *base event loop* with a custom one.
+This approach works but has two disadvantages:
+1. ``zmq.asyncio.ZMQEventLoop`` cannot be combined with
+   other loop implementations (most notable is the ultra fast ``uvloop``).
+2. It uses the internal ZMQ Poller which has fast ZMQ Sockets support
+   but isn't intended to work fast with many (thousands) regular TCP sockets.
+   In practice it means that ``zmq.asyncio`` is not recommended to be used with
+   web servers like ``aiohttp``.
+   See also https://github.com/zeromq/pyzmq/issues/894
+
+%prep
+%autosetup -n aiozmq-1.0.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-aiozmq -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Mar 07 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.0-1
+- Package Spec generated
-- 
cgit v1.2.3