summaryrefslogtreecommitdiff
path: root/python-aircot.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-aircot.spec')
-rw-r--r--python-aircot.spec84
1 files changed, 84 insertions, 0 deletions
diff --git a/python-aircot.spec b/python-aircot.spec
new file mode 100644
index 0000000..f8992ee
--- /dev/null
+++ b/python-aircot.spec
@@ -0,0 +1,84 @@
+%global _empty_manifest_terminate_build 0
+Name: python-aircot
+Version: 1.2.0
+Release: 1
+Summary: Cursor on Target (COT) Aircraft Classifier
+License: Apache License, Version 2.0
+URL: https://github.com/ampledata/aircot
+Source0: https://mirrors.aliyun.com/pypi/web/packages/c0/f1/f5856bd0fc1e9128585e5abbf16e48440a54bfef653e1401aa2d406e1f07/aircot-1.2.0.tar.gz
+BuildArch: noarch
+
+
+%description
+**Tech Support**: Email support@undef.net or Signal/WhatsApp: +1-310-621-9598
+This tool has been developed for the Disaster Response, Public Safety and
+Frontline Healthcare community. This software is currently provided at no-cost
+to users. Any contribution you can make to further this project's development
+efforts is greatly appreciated.
+
+%package -n python3-aircot
+Summary: Cursor on Target (COT) Aircraft Classifier
+Provides: python-aircot
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-aircot
+**Tech Support**: Email support@undef.net or Signal/WhatsApp: +1-310-621-9598
+This tool has been developed for the Disaster Response, Public Safety and
+Frontline Healthcare community. This software is currently provided at no-cost
+to users. Any contribution you can make to further this project's development
+efforts is greatly appreciated.
+
+%package help
+Summary: Development documents and examples for aircot
+Provides: python3-aircot-doc
+%description help
+**Tech Support**: Email support@undef.net or Signal/WhatsApp: +1-310-621-9598
+This tool has been developed for the Disaster Response, Public Safety and
+Frontline Healthcare community. This software is currently provided at no-cost
+to users. Any contribution you can make to further this project's development
+efforts is greatly appreciated.
+
+%prep
+%autosetup -n aircot-1.2.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-aircot -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Jun 20 2023 Python_Bot <Python_Bot@openeuler.org> - 1.2.0-1
+- Package Spec generated