summaryrefslogtreecommitdiff
path: root/python-airspeed.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-airspeed.spec')
-rw-r--r--python-airspeed.spec72
1 files changed, 72 insertions, 0 deletions
diff --git a/python-airspeed.spec b/python-airspeed.spec
new file mode 100644
index 0000000..da28113
--- /dev/null
+++ b/python-airspeed.spec
@@ -0,0 +1,72 @@
+%global _empty_manifest_terminate_build 0
+Name: python-airspeed
+Version: 0.5.20
+Release: 1
+Summary: Airspeed is a powerful and easy-to-use templating engine for Python that aims for a high level of compatibility with the popular Velocity library for Java.
+License: BSD
+URL: https://github.com/purcell/airspeed/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/b3/23/812b8ffea500acfa38463c291e85e78f7270e80be9d669fd79055ff2606b/airspeed-0.5.20.tar.gz
+BuildArch: noarch
+
+
+%description
+
+
+%package -n python3-airspeed
+Summary: Airspeed is a powerful and easy-to-use templating engine for Python that aims for a high level of compatibility with the popular Velocity library for Java.
+Provides: python-airspeed
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-airspeed
+
+
+%package help
+Summary: Development documents and examples for airspeed
+Provides: python3-airspeed-doc
+%description help
+
+
+%prep
+%autosetup -n airspeed-0.5.20
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-airspeed -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Mar 07 2023 Python_Bot <Python_Bot@openeuler.org> - 0.5.20-1
+- Package Spec generated