summaryrefslogtreecommitdiff
path: root/python-algoliasearch.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-10 17:31:50 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-10 17:31:50 +0000
commit0e5770465ce9524f88f80b68db24537e4cd08294 (patch)
tree31ba431b22862f08cb9d8e8e5008d5acf90b8edd /python-algoliasearch.spec
parentdb2a964a4e5d1158cb1960f158b4dc06fb9a9085 (diff)
automatic import of python-algoliasearch
Diffstat (limited to 'python-algoliasearch.spec')
-rw-r--r--python-algoliasearch.spec278
1 files changed, 278 insertions, 0 deletions
diff --git a/python-algoliasearch.spec b/python-algoliasearch.spec
new file mode 100644
index 0000000..597e5b1
--- /dev/null
+++ b/python-algoliasearch.spec
@@ -0,0 +1,278 @@
+%global _empty_manifest_terminate_build 0
+Name: python-algoliasearch
+Version: 3.0.0
+Release: 1
+Summary: Algolia Search API Client for Python.
+License: MIT
+URL: https://github.com/algolia/algoliasearch-client-python
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/c3/3a/68b9136bab8d04f837c5b1893be1de2d6403f9cb5f18961194a168e90917/algoliasearch-3.0.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-requests
+Requires: python3-typing
+
+%description
+<p align="center">
+ <a href="https://www.algolia.com">
+ <img alt="Algolia for Python" src="https://raw.githubusercontent.com/algolia/algoliasearch-client-common/master/banners/python.png" >
+ </a>
+
+ <h4 align="center">The perfect starting point to integrate <a href="https://algolia.com" target="_blank">Algolia</a> within your Python project</h4>
+
+ <p align="center">
+ <a href="https://pypi.org/project/algoliasearch"><img src="https://img.shields.io/pypi/v/algoliasearch.svg" alt="PyPI"></img></a>
+ <a href="https://pypi.org/project/algoliasearch"><img src="https://img.shields.io/pypi/pyversions/ansicolortags.svg" alt="Python versions"></img></a>
+ <a href="https://pypi.org/project/algoliasearch"><img src="https://img.shields.io/pypi/l/ansicolortags.svg" alt="License"></a>
+ </p>
+</p>
+
+<p align="center">
+ <a href="https://www.algolia.com/doc/api-client/getting-started/install/python/" target="_blank">Documentation</a> •
+ <a href="https://github.com/algolia/algoliasearch-django" target="_blank">Django</a> •
+ <a href="https://discourse.algolia.com" target="_blank">Community Forum</a> •
+ <a href="http://stackoverflow.com/questions/tagged/algolia" target="_blank">Stack Overflow</a> •
+ <a href="https://github.com/algolia/algoliasearch-client-python/issues" target="_blank">Report a bug</a> •
+ <a href="https://www.algolia.com/doc/api-client/troubleshooting/faq/python/" target="_blank">FAQ</a> •
+ <a href="https://www.algolia.com/support" target="_blank">Support</a>
+</p>
+
+## ✨ Features
+
+- Thin & minimal low-level HTTP client to interact with Algolia's API
+- Supports Python from `3.4` to `3.11`
+- Contains blazing-fast asynchronous methods built on top of the [Asyncio](https://docs.python.org/3/library/asyncio.html)
+
+## 💡 Getting Started
+
+First, install Algolia Python API Client via the [pip](https://pip.pypa.io/en/stable/installing) package manager:
+
+```bash
+pip install --upgrade 'algoliasearch>=3.0,<4.0'
+```
+
+Then, create objects on your index:
+
+```py
+from algoliasearch.search_client import SearchClient
+
+client = SearchClient.create('YourApplicationID', 'YourAPIKey')
+index = client.init_index('your_index_name')
+
+index.save_objects([{'objectID': 1, 'name': 'Foo'}])
+```
+
+Finally, you may begin searching a object using the `search` method:
+
+```py
+objects = index.search('Fo')
+```
+
+For full documentation, visit the **[Algolia Python API Client](https://www.algolia.com/doc/api-client/getting-started/install/python/)**.
+
+## ❓ Troubleshooting
+
+Encountering an issue? Before reaching out to support, we recommend heading to our [FAQ](https://www.algolia.com/doc/api-client/troubleshooting/faq/python/) where you will find answers for the most common issues and gotchas with the client.
+
+## Use the Dockerfile
+
+If you want to contribute to this project without installing all its dependencies, you can use our Docker image. Please check our [dedicated guide](DOCKER_README.MD) to learn more.
+
+## 📄 License
+
+Algolia Python API Client is an open-sourced software licensed under the [MIT license](LICENSE.md).
+
+
+%package -n python3-algoliasearch
+Summary: Algolia Search API Client for Python.
+Provides: python-algoliasearch
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-algoliasearch
+<p align="center">
+ <a href="https://www.algolia.com">
+ <img alt="Algolia for Python" src="https://raw.githubusercontent.com/algolia/algoliasearch-client-common/master/banners/python.png" >
+ </a>
+
+ <h4 align="center">The perfect starting point to integrate <a href="https://algolia.com" target="_blank">Algolia</a> within your Python project</h4>
+
+ <p align="center">
+ <a href="https://pypi.org/project/algoliasearch"><img src="https://img.shields.io/pypi/v/algoliasearch.svg" alt="PyPI"></img></a>
+ <a href="https://pypi.org/project/algoliasearch"><img src="https://img.shields.io/pypi/pyversions/ansicolortags.svg" alt="Python versions"></img></a>
+ <a href="https://pypi.org/project/algoliasearch"><img src="https://img.shields.io/pypi/l/ansicolortags.svg" alt="License"></a>
+ </p>
+</p>
+
+<p align="center">
+ <a href="https://www.algolia.com/doc/api-client/getting-started/install/python/" target="_blank">Documentation</a> •
+ <a href="https://github.com/algolia/algoliasearch-django" target="_blank">Django</a> •
+ <a href="https://discourse.algolia.com" target="_blank">Community Forum</a> •
+ <a href="http://stackoverflow.com/questions/tagged/algolia" target="_blank">Stack Overflow</a> •
+ <a href="https://github.com/algolia/algoliasearch-client-python/issues" target="_blank">Report a bug</a> •
+ <a href="https://www.algolia.com/doc/api-client/troubleshooting/faq/python/" target="_blank">FAQ</a> •
+ <a href="https://www.algolia.com/support" target="_blank">Support</a>
+</p>
+
+## ✨ Features
+
+- Thin & minimal low-level HTTP client to interact with Algolia's API
+- Supports Python from `3.4` to `3.11`
+- Contains blazing-fast asynchronous methods built on top of the [Asyncio](https://docs.python.org/3/library/asyncio.html)
+
+## 💡 Getting Started
+
+First, install Algolia Python API Client via the [pip](https://pip.pypa.io/en/stable/installing) package manager:
+
+```bash
+pip install --upgrade 'algoliasearch>=3.0,<4.0'
+```
+
+Then, create objects on your index:
+
+```py
+from algoliasearch.search_client import SearchClient
+
+client = SearchClient.create('YourApplicationID', 'YourAPIKey')
+index = client.init_index('your_index_name')
+
+index.save_objects([{'objectID': 1, 'name': 'Foo'}])
+```
+
+Finally, you may begin searching a object using the `search` method:
+
+```py
+objects = index.search('Fo')
+```
+
+For full documentation, visit the **[Algolia Python API Client](https://www.algolia.com/doc/api-client/getting-started/install/python/)**.
+
+## ❓ Troubleshooting
+
+Encountering an issue? Before reaching out to support, we recommend heading to our [FAQ](https://www.algolia.com/doc/api-client/troubleshooting/faq/python/) where you will find answers for the most common issues and gotchas with the client.
+
+## Use the Dockerfile
+
+If you want to contribute to this project without installing all its dependencies, you can use our Docker image. Please check our [dedicated guide](DOCKER_README.MD) to learn more.
+
+## 📄 License
+
+Algolia Python API Client is an open-sourced software licensed under the [MIT license](LICENSE.md).
+
+
+%package help
+Summary: Development documents and examples for algoliasearch
+Provides: python3-algoliasearch-doc
+%description help
+<p align="center">
+ <a href="https://www.algolia.com">
+ <img alt="Algolia for Python" src="https://raw.githubusercontent.com/algolia/algoliasearch-client-common/master/banners/python.png" >
+ </a>
+
+ <h4 align="center">The perfect starting point to integrate <a href="https://algolia.com" target="_blank">Algolia</a> within your Python project</h4>
+
+ <p align="center">
+ <a href="https://pypi.org/project/algoliasearch"><img src="https://img.shields.io/pypi/v/algoliasearch.svg" alt="PyPI"></img></a>
+ <a href="https://pypi.org/project/algoliasearch"><img src="https://img.shields.io/pypi/pyversions/ansicolortags.svg" alt="Python versions"></img></a>
+ <a href="https://pypi.org/project/algoliasearch"><img src="https://img.shields.io/pypi/l/ansicolortags.svg" alt="License"></a>
+ </p>
+</p>
+
+<p align="center">
+ <a href="https://www.algolia.com/doc/api-client/getting-started/install/python/" target="_blank">Documentation</a> •
+ <a href="https://github.com/algolia/algoliasearch-django" target="_blank">Django</a> •
+ <a href="https://discourse.algolia.com" target="_blank">Community Forum</a> •
+ <a href="http://stackoverflow.com/questions/tagged/algolia" target="_blank">Stack Overflow</a> •
+ <a href="https://github.com/algolia/algoliasearch-client-python/issues" target="_blank">Report a bug</a> •
+ <a href="https://www.algolia.com/doc/api-client/troubleshooting/faq/python/" target="_blank">FAQ</a> •
+ <a href="https://www.algolia.com/support" target="_blank">Support</a>
+</p>
+
+## ✨ Features
+
+- Thin & minimal low-level HTTP client to interact with Algolia's API
+- Supports Python from `3.4` to `3.11`
+- Contains blazing-fast asynchronous methods built on top of the [Asyncio](https://docs.python.org/3/library/asyncio.html)
+
+## 💡 Getting Started
+
+First, install Algolia Python API Client via the [pip](https://pip.pypa.io/en/stable/installing) package manager:
+
+```bash
+pip install --upgrade 'algoliasearch>=3.0,<4.0'
+```
+
+Then, create objects on your index:
+
+```py
+from algoliasearch.search_client import SearchClient
+
+client = SearchClient.create('YourApplicationID', 'YourAPIKey')
+index = client.init_index('your_index_name')
+
+index.save_objects([{'objectID': 1, 'name': 'Foo'}])
+```
+
+Finally, you may begin searching a object using the `search` method:
+
+```py
+objects = index.search('Fo')
+```
+
+For full documentation, visit the **[Algolia Python API Client](https://www.algolia.com/doc/api-client/getting-started/install/python/)**.
+
+## ❓ Troubleshooting
+
+Encountering an issue? Before reaching out to support, we recommend heading to our [FAQ](https://www.algolia.com/doc/api-client/troubleshooting/faq/python/) where you will find answers for the most common issues and gotchas with the client.
+
+## Use the Dockerfile
+
+If you want to contribute to this project without installing all its dependencies, you can use our Docker image. Please check our [dedicated guide](DOCKER_README.MD) to learn more.
+
+## 📄 License
+
+Algolia Python API Client is an open-sourced software licensed under the [MIT license](LICENSE.md).
+
+
+%prep
+%autosetup -n algoliasearch-3.0.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-algoliasearch -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 3.0.0-1
+- Package Spec generated