summaryrefslogtreecommitdiff
path: root/python-alibabacloud-endpoint-util.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-alibabacloud-endpoint-util.spec')
-rw-r--r--python-alibabacloud-endpoint-util.spec153
1 files changed, 153 insertions, 0 deletions
diff --git a/python-alibabacloud-endpoint-util.spec b/python-alibabacloud-endpoint-util.spec
new file mode 100644
index 0000000..1063277
--- /dev/null
+++ b/python-alibabacloud-endpoint-util.spec
@@ -0,0 +1,153 @@
+%global _empty_manifest_terminate_build 0
+Name: python-alibabacloud-endpoint-util
+Version: 0.0.3
+Release: 1
+Summary: The endpoint-util module of alibabaCloud Python SDK.
+License: Apache License 2.0
+URL: https://github.com/aliyun/endpoint-util/tree/master/python
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/24/54/56736a0f224b3f2b65bb9c9ff9e20fa390351a7587c99f19ca1f8d596ae1/alibabacloud_endpoint_util-0.0.3.tar.gz
+BuildArch: noarch
+
+
+%description
+English | [简体中文](README-CN.md)
+![](https://aliyunsdk-pages.alicdn.com/icons/AlibabaCloud.svg)
+
+## Alibaba Cloud Endpoint for Python
+
+## Installation
+- **Install with pip**
+
+Python SDK uses a common package management tool named `pip`. If pip is not installed, see the [pip user guide](https://pip.pypa.io/en/stable/installing/ "pip User Guide") to install pip.
+
+```bash
+# Install the endpoint-util
+pip install alibabacloud_endpoint_util
+```
+
+## Issues
+[Opening an Issue](https://github.com/aliyun/endpoint-util/issues/new), Issues not conforming to the guidelines may be closed immediately.
+
+## Changelog
+Detailed changes for each release are documented in the [release notes](./ChangeLog.md).
+
+## References
+* [Latest Release](https://github.com/aliyun/endpoint-util/tree/master/python)
+
+## License
+[Apache-2.0](http://www.apache.org/licenses/LICENSE-2.0)
+
+Copyright (c) 2009-present, Alibaba Cloud All rights reserved.
+
+%package -n python3-alibabacloud-endpoint-util
+Summary: The endpoint-util module of alibabaCloud Python SDK.
+Provides: python-alibabacloud-endpoint-util
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-alibabacloud-endpoint-util
+English | [简体中文](README-CN.md)
+![](https://aliyunsdk-pages.alicdn.com/icons/AlibabaCloud.svg)
+
+## Alibaba Cloud Endpoint for Python
+
+## Installation
+- **Install with pip**
+
+Python SDK uses a common package management tool named `pip`. If pip is not installed, see the [pip user guide](https://pip.pypa.io/en/stable/installing/ "pip User Guide") to install pip.
+
+```bash
+# Install the endpoint-util
+pip install alibabacloud_endpoint_util
+```
+
+## Issues
+[Opening an Issue](https://github.com/aliyun/endpoint-util/issues/new), Issues not conforming to the guidelines may be closed immediately.
+
+## Changelog
+Detailed changes for each release are documented in the [release notes](./ChangeLog.md).
+
+## References
+* [Latest Release](https://github.com/aliyun/endpoint-util/tree/master/python)
+
+## License
+[Apache-2.0](http://www.apache.org/licenses/LICENSE-2.0)
+
+Copyright (c) 2009-present, Alibaba Cloud All rights reserved.
+
+%package help
+Summary: Development documents and examples for alibabacloud-endpoint-util
+Provides: python3-alibabacloud-endpoint-util-doc
+%description help
+English | [简体中文](README-CN.md)
+![](https://aliyunsdk-pages.alicdn.com/icons/AlibabaCloud.svg)
+
+## Alibaba Cloud Endpoint for Python
+
+## Installation
+- **Install with pip**
+
+Python SDK uses a common package management tool named `pip`. If pip is not installed, see the [pip user guide](https://pip.pypa.io/en/stable/installing/ "pip User Guide") to install pip.
+
+```bash
+# Install the endpoint-util
+pip install alibabacloud_endpoint_util
+```
+
+## Issues
+[Opening an Issue](https://github.com/aliyun/endpoint-util/issues/new), Issues not conforming to the guidelines may be closed immediately.
+
+## Changelog
+Detailed changes for each release are documented in the [release notes](./ChangeLog.md).
+
+## References
+* [Latest Release](https://github.com/aliyun/endpoint-util/tree/master/python)
+
+## License
+[Apache-2.0](http://www.apache.org/licenses/LICENSE-2.0)
+
+Copyright (c) 2009-present, Alibaba Cloud All rights reserved.
+
+%prep
+%autosetup -n alibabacloud-endpoint-util-0.0.3
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-alibabacloud-endpoint-util -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 0.0.3-1
+- Package Spec generated