summaryrefslogtreecommitdiff
path: root/python-alibabacloud-ice20201109.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-alibabacloud-ice20201109.spec')
-rw-r--r--python-alibabacloud-ice20201109.spec205
1 files changed, 205 insertions, 0 deletions
diff --git a/python-alibabacloud-ice20201109.spec b/python-alibabacloud-ice20201109.spec
new file mode 100644
index 0000000..fafacad
--- /dev/null
+++ b/python-alibabacloud-ice20201109.spec
@@ -0,0 +1,205 @@
+%global _empty_manifest_terminate_build 0
+Name: python-alibabacloud-ice20201109
+Version: 1.3.12
+Release: 1
+Summary: Alibaba Cloud ICE (20201109) SDK Library for Python
+License: Apache License 2.0
+URL: https://github.com/aliyun/alibabacloud-python-sdk
+Source0: https://mirrors.aliyun.com/pypi/web/packages/fb/11/613ce18eae0c364d2447fd05e78f51392aa0a6d5a94d62d9401ae2c0a95b/alibabacloud_ice20201109-1.3.12.tar.gz
+BuildArch: noarch
+
+Requires: python3-alibabacloud-tea-util
+Requires: python3-alibabacloud-tea-openapi
+Requires: python3-alibabacloud-openapi-util
+Requires: python3-alibabacloud-endpoint-util
+
+%description
+English | [简体中文](README-CN.md)
+![](https://aliyunsdk-pages.alicdn.com/icons/AlibabaCloud.svg)
+
+## Alibaba Cloud ICE SDK for Python
+
+## Requirements
+
+- Python >= 3.6
+
+## Installation
+
+- **Install with pip**
+
+Python SDK uses a common package management tool named `pip`. If pip is not installed, see the [pip user guide](https://pip.pypa.io/en/stable/installing/ "pip User Guide") to install pip.
+
+```bash
+# Install the alibabacloud_ice20201109
+pip install alibabacloud_ice20201109
+```
+
+## Issues
+
+[Opening an Issue](https://github.com/aliyun/alibabacloud-sdk/issues/new), Issues not conforming to the guidelines may be closed immediately.
+
+## Usage
+
+[Quick Examples](https://github.com/aliyun/alibabacloud-python-sdk/blob/master/docs/0-Usage-EN.md#quick-examples)
+
+## Changelog
+
+Detailed changes for each release are documented in the [release notes](./ChangeLog.md).
+
+## References
+
+- [Latest Release](https://github.com/aliyun/alibabacloud-sdk/tree/master/python)
+
+## License
+
+[Apache-2.0](http://www.apache.org/licenses/LICENSE-2.0)
+
+Copyright (c) 2009-present, Alibaba Cloud All rights reserved.
+
+
+
+
+%package -n python3-alibabacloud-ice20201109
+Summary: Alibaba Cloud ICE (20201109) SDK Library for Python
+Provides: python-alibabacloud-ice20201109
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-alibabacloud-ice20201109
+English | [简体中文](README-CN.md)
+![](https://aliyunsdk-pages.alicdn.com/icons/AlibabaCloud.svg)
+
+## Alibaba Cloud ICE SDK for Python
+
+## Requirements
+
+- Python >= 3.6
+
+## Installation
+
+- **Install with pip**
+
+Python SDK uses a common package management tool named `pip`. If pip is not installed, see the [pip user guide](https://pip.pypa.io/en/stable/installing/ "pip User Guide") to install pip.
+
+```bash
+# Install the alibabacloud_ice20201109
+pip install alibabacloud_ice20201109
+```
+
+## Issues
+
+[Opening an Issue](https://github.com/aliyun/alibabacloud-sdk/issues/new), Issues not conforming to the guidelines may be closed immediately.
+
+## Usage
+
+[Quick Examples](https://github.com/aliyun/alibabacloud-python-sdk/blob/master/docs/0-Usage-EN.md#quick-examples)
+
+## Changelog
+
+Detailed changes for each release are documented in the [release notes](./ChangeLog.md).
+
+## References
+
+- [Latest Release](https://github.com/aliyun/alibabacloud-sdk/tree/master/python)
+
+## License
+
+[Apache-2.0](http://www.apache.org/licenses/LICENSE-2.0)
+
+Copyright (c) 2009-present, Alibaba Cloud All rights reserved.
+
+
+
+
+%package help
+Summary: Development documents and examples for alibabacloud-ice20201109
+Provides: python3-alibabacloud-ice20201109-doc
+%description help
+English | [简体中文](README-CN.md)
+![](https://aliyunsdk-pages.alicdn.com/icons/AlibabaCloud.svg)
+
+## Alibaba Cloud ICE SDK for Python
+
+## Requirements
+
+- Python >= 3.6
+
+## Installation
+
+- **Install with pip**
+
+Python SDK uses a common package management tool named `pip`. If pip is not installed, see the [pip user guide](https://pip.pypa.io/en/stable/installing/ "pip User Guide") to install pip.
+
+```bash
+# Install the alibabacloud_ice20201109
+pip install alibabacloud_ice20201109
+```
+
+## Issues
+
+[Opening an Issue](https://github.com/aliyun/alibabacloud-sdk/issues/new), Issues not conforming to the guidelines may be closed immediately.
+
+## Usage
+
+[Quick Examples](https://github.com/aliyun/alibabacloud-python-sdk/blob/master/docs/0-Usage-EN.md#quick-examples)
+
+## Changelog
+
+Detailed changes for each release are documented in the [release notes](./ChangeLog.md).
+
+## References
+
+- [Latest Release](https://github.com/aliyun/alibabacloud-sdk/tree/master/python)
+
+## License
+
+[Apache-2.0](http://www.apache.org/licenses/LICENSE-2.0)
+
+Copyright (c) 2009-present, Alibaba Cloud All rights reserved.
+
+
+
+
+%prep
+%autosetup -n alibabacloud_ice20201109-1.3.12
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-alibabacloud-ice20201109 -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri Jun 09 2023 Python_Bot <Python_Bot@openeuler.org> - 1.3.12-1
+- Package Spec generated