summaryrefslogtreecommitdiff
path: root/python-anyio.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-anyio.spec')
-rw-r--r--python-anyio.spec90
1 files changed, 90 insertions, 0 deletions
diff --git a/python-anyio.spec b/python-anyio.spec
new file mode 100644
index 0000000..eeb2102
--- /dev/null
+++ b/python-anyio.spec
@@ -0,0 +1,90 @@
+%global _empty_manifest_terminate_build 0
+Name: python-anyio
+Version: 3.6.2
+Release: 1
+Summary: High level compatibility layer for multiple asynchronous event loop implementations
+License: MIT
+URL: https://pypi.org/project/anyio/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/8b/94/6928d4345f2bc1beecbff03325cad43d320717f51ab74ab5a571324f4f5a/anyio-3.6.2.tar.gz
+BuildArch: noarch
+
+Requires: python3-idna
+Requires: python3-sniffio
+Requires: python3-contextvars
+Requires: python3-dataclasses
+Requires: python3-typing-extensions
+Requires: python3-packaging
+Requires: python3-sphinx-rtd-theme
+Requires: python3-sphinx-autodoc-typehints
+Requires: python3-coverage[toml]
+Requires: python3-hypothesis
+Requires: python3-pytest
+Requires: python3-pytest-mock
+Requires: python3-trustme
+Requires: python3-contextlib2
+Requires: python3-uvloop
+Requires: python3-mock
+Requires: python3-uvloop
+Requires: python3-trio
+
+%description
+View full documentation at: https://anyio.readthedocs.io/
+
+%package -n python3-anyio
+Summary: High level compatibility layer for multiple asynchronous event loop implementations
+Provides: python-anyio
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-anyio
+View full documentation at: https://anyio.readthedocs.io/
+
+%package help
+Summary: Development documents and examples for anyio
+Provides: python3-anyio-doc
+%description help
+View full documentation at: https://anyio.readthedocs.io/
+
+%prep
+%autosetup -n anyio-3.6.2
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-anyio -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Mar 07 2023 Python_Bot <Python_Bot@openeuler.org> - 3.6.2-1
+- Package Spec generated