summaryrefslogtreecommitdiff
path: root/python-apache-airflow-providers-zendesk.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-apache-airflow-providers-zendesk.spec')
-rw-r--r--python-apache-airflow-providers-zendesk.spec83
1 files changed, 83 insertions, 0 deletions
diff --git a/python-apache-airflow-providers-zendesk.spec b/python-apache-airflow-providers-zendesk.spec
new file mode 100644
index 0000000..2e85dcb
--- /dev/null
+++ b/python-apache-airflow-providers-zendesk.spec
@@ -0,0 +1,83 @@
+%global _empty_manifest_terminate_build 0
+Name: python-apache-airflow-providers-zendesk
+Version: 4.2.0
+Release: 1
+Summary: Provider for Apache Airflow. Implements apache-airflow-providers-zendesk package
+License: Apache License 2.0
+URL: https://airflow.apache.org/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/06/57/e6a759f8a00127bd0b109e6d1ecb99c2cf1f05ec03e0f09c15a412a1b896/apache-airflow-providers-zendesk-4.2.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-apache-airflow
+Requires: python3-zenpy
+
+%description
+This is a provider package for ``zendesk`` provider. All classes for this provider package
+are in ``airflow.providers.zendesk`` python package.
+You can find package information and changelog for the provider
+in the `documentation <https://airflow.apache.org/docs/apache-airflow-providers-zendesk/4.2.0/>`_.
+
+%package -n python3-apache-airflow-providers-zendesk
+Summary: Provider for Apache Airflow. Implements apache-airflow-providers-zendesk package
+Provides: python-apache-airflow-providers-zendesk
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-apache-airflow-providers-zendesk
+This is a provider package for ``zendesk`` provider. All classes for this provider package
+are in ``airflow.providers.zendesk`` python package.
+You can find package information and changelog for the provider
+in the `documentation <https://airflow.apache.org/docs/apache-airflow-providers-zendesk/4.2.0/>`_.
+
+%package help
+Summary: Development documents and examples for apache-airflow-providers-zendesk
+Provides: python3-apache-airflow-providers-zendesk-doc
+%description help
+This is a provider package for ``zendesk`` provider. All classes for this provider package
+are in ``airflow.providers.zendesk`` python package.
+You can find package information and changelog for the provider
+in the `documentation <https://airflow.apache.org/docs/apache-airflow-providers-zendesk/4.2.0/>`_.
+
+%prep
+%autosetup -n apache-airflow-providers-zendesk-4.2.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-apache-airflow-providers-zendesk -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 4.2.0-1
+- Package Spec generated