summaryrefslogtreecommitdiff
path: root/python-aqequil.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-11 18:52:38 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-11 18:52:38 +0000
commit0e30be846b33cea92eab60f647846683b2676366 (patch)
tree8a3f2969cf446edf3a5b36417b38a506c92d9866 /python-aqequil.spec
parent85169f4b0dc5e7376667a5df5191cbd3df9dd9df (diff)
automatic import of python-aqequil
Diffstat (limited to 'python-aqequil.spec')
-rw-r--r--python-aqequil.spec234
1 files changed, 234 insertions, 0 deletions
diff --git a/python-aqequil.spec b/python-aqequil.spec
new file mode 100644
index 0000000..0b60c70
--- /dev/null
+++ b/python-aqequil.spec
@@ -0,0 +1,234 @@
+%global _empty_manifest_terminate_build 0
+Name: python-AqEquil
+Version: 0.16.7
+Release: 1
+Summary: Python tools for aqueous chemical speciation.
+License: MIT License
+URL: https://pypi.org/project/AqEquil/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/5a/24/f56ea2c7128d6ae990547de69f0103efa190b3b55f797a4d7d914cbab4ae/AqEquil-0.16.7.tar.gz
+BuildArch: noarch
+
+Requires: python3-rpy2
+Requires: python3-pandas
+Requires: python3-numpy
+Requires: python3-matplotlib
+Requires: python3-plotly
+Requires: python3-ipython
+Requires: python3-chemparse
+Requires: python3-dill
+Requires: python3-periodictable
+
+%description
+# AqEquil
+
+[![DOI](https://zenodo.org/badge/DOI/10.5281/zenodo.7601102.svg)](https://doi.org/10.5281/zenodo.7601102)
+
+Boyer, G., Robare, J., Ely, T., Shock, E.L.
+
+## About
+
+AqEquil is a Python 3 package that enables users to rapidly perform aqueous speciation calculations of water chemistry data for multiple samples by interfacing with [geochemical speciation software EQ3/6](https://github.com/LLNL/EQ3_6) (Wolery 2013, [Wolery 1979](https://inis.iaea.org/collection/NCLCollectionStore/_Public/10/474/10474294.pdf)).
+
+Water sample data in CSV format is automatically converted to a format readable by EQ3 and then speciated. Distributions of aqueous species, mineral saturation indices, oxidation reduction potentials, and more are data-mined and returned as Pandas tables and interactive Plotly visualizations.
+
+Speciated fluids can be further reacted with minerals in mass transfer calculations to produce tables and interactive diagrams of reaction paths and composition changes as a function of reaction progress.
+
+## Requirements
+
+AqEquil has only been tested with Ubuntu LTS 20.04.
+
+This installation requires the Linux version of EQ3/6 v8.0a, which can downloaded [here](https://github.com/LLNL/EQ3_6). Installation instructions are provided there.
+
+AqEquil must be installed into an environment with an R installation. See [these instructions](https://docs.anaconda.com/anaconda/user-guide/tasks/using-r-language/) for installing R with Anaconda.
+
+Additionally, the CHNOSZ package must be installed in R (see instructions below).
+
+## Installation
+
+### Installing EQ3/6 for Linux
+
+Installation instructions are packaged along with the Linux distribution of [EQ3/6 v8.0a](https://www-gs.llnl.gov/energy-homeland-security/geochemistry).
+
+Set the environment variable EQ36DA to the EQ3/6 database directory containing data1 files (the 'db' folder by default). Likewise, set EQ36CO to the directory with the eq3 executable (the 'bin' folder by default).
+
+### Installing CHNOSZ
+
+Open an R session. Install the CHNOSZ package with:
+
+```install.packages("CHNOSZ")```
+
+Once CHNOSZ is installed you can quit the R session.
+
+### Installing AqEquil
+
+Install AqEquil using pip:
+
+```pip install AqEquil```
+
+### Usage
+
+See this [demo notebook](https://nbviewer.jupyter.org/github/worm-portal/WORM-Library/blob/master/3-Aqueous-Speciation/1-Introduction-to-Aq-Speciation/2-Intro-to-Multi-Aq-Speciation.ipynb) for usage examples.
+
+
+
+
+%package -n python3-AqEquil
+Summary: Python tools for aqueous chemical speciation.
+Provides: python-AqEquil
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-AqEquil
+# AqEquil
+
+[![DOI](https://zenodo.org/badge/DOI/10.5281/zenodo.7601102.svg)](https://doi.org/10.5281/zenodo.7601102)
+
+Boyer, G., Robare, J., Ely, T., Shock, E.L.
+
+## About
+
+AqEquil is a Python 3 package that enables users to rapidly perform aqueous speciation calculations of water chemistry data for multiple samples by interfacing with [geochemical speciation software EQ3/6](https://github.com/LLNL/EQ3_6) (Wolery 2013, [Wolery 1979](https://inis.iaea.org/collection/NCLCollectionStore/_Public/10/474/10474294.pdf)).
+
+Water sample data in CSV format is automatically converted to a format readable by EQ3 and then speciated. Distributions of aqueous species, mineral saturation indices, oxidation reduction potentials, and more are data-mined and returned as Pandas tables and interactive Plotly visualizations.
+
+Speciated fluids can be further reacted with minerals in mass transfer calculations to produce tables and interactive diagrams of reaction paths and composition changes as a function of reaction progress.
+
+## Requirements
+
+AqEquil has only been tested with Ubuntu LTS 20.04.
+
+This installation requires the Linux version of EQ3/6 v8.0a, which can downloaded [here](https://github.com/LLNL/EQ3_6). Installation instructions are provided there.
+
+AqEquil must be installed into an environment with an R installation. See [these instructions](https://docs.anaconda.com/anaconda/user-guide/tasks/using-r-language/) for installing R with Anaconda.
+
+Additionally, the CHNOSZ package must be installed in R (see instructions below).
+
+## Installation
+
+### Installing EQ3/6 for Linux
+
+Installation instructions are packaged along with the Linux distribution of [EQ3/6 v8.0a](https://www-gs.llnl.gov/energy-homeland-security/geochemistry).
+
+Set the environment variable EQ36DA to the EQ3/6 database directory containing data1 files (the 'db' folder by default). Likewise, set EQ36CO to the directory with the eq3 executable (the 'bin' folder by default).
+
+### Installing CHNOSZ
+
+Open an R session. Install the CHNOSZ package with:
+
+```install.packages("CHNOSZ")```
+
+Once CHNOSZ is installed you can quit the R session.
+
+### Installing AqEquil
+
+Install AqEquil using pip:
+
+```pip install AqEquil```
+
+### Usage
+
+See this [demo notebook](https://nbviewer.jupyter.org/github/worm-portal/WORM-Library/blob/master/3-Aqueous-Speciation/1-Introduction-to-Aq-Speciation/2-Intro-to-Multi-Aq-Speciation.ipynb) for usage examples.
+
+
+
+
+%package help
+Summary: Development documents and examples for AqEquil
+Provides: python3-AqEquil-doc
+%description help
+# AqEquil
+
+[![DOI](https://zenodo.org/badge/DOI/10.5281/zenodo.7601102.svg)](https://doi.org/10.5281/zenodo.7601102)
+
+Boyer, G., Robare, J., Ely, T., Shock, E.L.
+
+## About
+
+AqEquil is a Python 3 package that enables users to rapidly perform aqueous speciation calculations of water chemistry data for multiple samples by interfacing with [geochemical speciation software EQ3/6](https://github.com/LLNL/EQ3_6) (Wolery 2013, [Wolery 1979](https://inis.iaea.org/collection/NCLCollectionStore/_Public/10/474/10474294.pdf)).
+
+Water sample data in CSV format is automatically converted to a format readable by EQ3 and then speciated. Distributions of aqueous species, mineral saturation indices, oxidation reduction potentials, and more are data-mined and returned as Pandas tables and interactive Plotly visualizations.
+
+Speciated fluids can be further reacted with minerals in mass transfer calculations to produce tables and interactive diagrams of reaction paths and composition changes as a function of reaction progress.
+
+## Requirements
+
+AqEquil has only been tested with Ubuntu LTS 20.04.
+
+This installation requires the Linux version of EQ3/6 v8.0a, which can downloaded [here](https://github.com/LLNL/EQ3_6). Installation instructions are provided there.
+
+AqEquil must be installed into an environment with an R installation. See [these instructions](https://docs.anaconda.com/anaconda/user-guide/tasks/using-r-language/) for installing R with Anaconda.
+
+Additionally, the CHNOSZ package must be installed in R (see instructions below).
+
+## Installation
+
+### Installing EQ3/6 for Linux
+
+Installation instructions are packaged along with the Linux distribution of [EQ3/6 v8.0a](https://www-gs.llnl.gov/energy-homeland-security/geochemistry).
+
+Set the environment variable EQ36DA to the EQ3/6 database directory containing data1 files (the 'db' folder by default). Likewise, set EQ36CO to the directory with the eq3 executable (the 'bin' folder by default).
+
+### Installing CHNOSZ
+
+Open an R session. Install the CHNOSZ package with:
+
+```install.packages("CHNOSZ")```
+
+Once CHNOSZ is installed you can quit the R session.
+
+### Installing AqEquil
+
+Install AqEquil using pip:
+
+```pip install AqEquil```
+
+### Usage
+
+See this [demo notebook](https://nbviewer.jupyter.org/github/worm-portal/WORM-Library/blob/master/3-Aqueous-Speciation/1-Introduction-to-Aq-Speciation/2-Intro-to-Multi-Aq-Speciation.ipynb) for usage examples.
+
+
+
+
+%prep
+%autosetup -n AqEquil-0.16.7
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-AqEquil -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 0.16.7-1
+- Package Spec generated