summaryrefslogtreecommitdiff
path: root/python-arcanum-newspaper-segmentation-client.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-31 06:32:39 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-31 06:32:39 +0000
commit73ebdf8dd793e94daa6c2b2348ab1bb0c14eb078 (patch)
treeee4bdf884d32509b51d4bd778662b442fe38146a /python-arcanum-newspaper-segmentation-client.spec
parentf1eb77a87ecee08c48d52780c94c2c30a061146a (diff)
automatic import of python-arcanum-newspaper-segmentation-client
Diffstat (limited to 'python-arcanum-newspaper-segmentation-client.spec')
-rw-r--r--python-arcanum-newspaper-segmentation-client.spec89
1 files changed, 89 insertions, 0 deletions
diff --git a/python-arcanum-newspaper-segmentation-client.spec b/python-arcanum-newspaper-segmentation-client.spec
new file mode 100644
index 0000000..c15de3f
--- /dev/null
+++ b/python-arcanum-newspaper-segmentation-client.spec
@@ -0,0 +1,89 @@
+%global _empty_manifest_terminate_build 0
+Name: python-arcanum-newspaper-segmentation-client
+Version: 1.6.6
+Release: 1
+Summary: Client for Arcanum's Newspaper Segmentation API
+License: MIT License
+URL: https://www.arcanum.com/en/newspaper-segmentation/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/dc/b4/be204cb678e3bb2f4433a29928148705d7eefee8cc2f9dcd4062dabd6425/arcanum-newspaper-segmentation-client-1.6.6.tar.gz
+BuildArch: noarch
+
+Requires: python3-pillow
+Requires: python3-boto3
+Requires: python3-requests
+Requires: python3-numpy
+Requires: python3-pymupdf
+
+%description
+# Arcanum Newspaper Segmentation client
+
+Client for Arcanum Newspaper Segmentation API.
+[Read more](https://www.arcanum.com/en/newspaper-segmentation/)
+
+
+%package -n python3-arcanum-newspaper-segmentation-client
+Summary: Client for Arcanum's Newspaper Segmentation API
+Provides: python-arcanum-newspaper-segmentation-client
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-arcanum-newspaper-segmentation-client
+# Arcanum Newspaper Segmentation client
+
+Client for Arcanum Newspaper Segmentation API.
+[Read more](https://www.arcanum.com/en/newspaper-segmentation/)
+
+
+%package help
+Summary: Development documents and examples for arcanum-newspaper-segmentation-client
+Provides: python3-arcanum-newspaper-segmentation-client-doc
+%description help
+# Arcanum Newspaper Segmentation client
+
+Client for Arcanum Newspaper Segmentation API.
+[Read more](https://www.arcanum.com/en/newspaper-segmentation/)
+
+
+%prep
+%autosetup -n arcanum-newspaper-segmentation-client-1.6.6
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-arcanum-newspaper-segmentation-client -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 31 2023 Python_Bot <Python_Bot@openeuler.org> - 1.6.6-1
+- Package Spec generated