summaryrefslogtreecommitdiff
path: root/python-aries-cloudcontroller.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-aries-cloudcontroller.spec')
-rw-r--r--python-aries-cloudcontroller.spec29
1 files changed, 17 insertions, 12 deletions
diff --git a/python-aries-cloudcontroller.spec b/python-aries-cloudcontroller.spec
index 7df9e19..3abe107 100644
--- a/python-aries-cloudcontroller.spec
+++ b/python-aries-cloudcontroller.spec
@@ -1,15 +1,17 @@
%global _empty_manifest_terminate_build 0
Name: python-aries-cloudcontroller
-Version: 0.7.0
+Version: 0.8.0
Release: 1
Summary: A simple python package for controlling an aries agent through the admin-api interface
License: Apache Software License
URL: https://github.com/didx-xyz/aries-cloudcontroller-python/tree/main/aries_cloudcontroller
-Source0: https://mirrors.nju.edu.cn/pypi/web/packages/55/ff/9f861447a672abec578d2a1bb314c58a43f4987313a3cfc12b36cf2bf80c/aries_cloudcontroller-0.7.0.tar.gz
+Source0: https://mirrors.aliyun.com/pypi/web/packages/a9/60/f0def77781300f89e9d9f04e8f3f0f2ce6a23b31267092a317efbe21ff39/aries_cloudcontroller-0.8.0.tar.gz
BuildArch: noarch
Requires: python3-aiohttp
Requires: python3-uplink[aiohttp,pydantic]
+Requires: python3-typing-extensions
+Requires: python3-pydantic
%description
<p align="center">
@@ -60,13 +62,14 @@ Each Cloud Controller version maps to a specific ACA-Py version, which is outlin
| 0.5.1-0.5.2 | 0.7.3 |
| 0.6.0-0.6.3 | 0.7.4 |
| 0.7.0 | 0.7.5 |
+| 0.8.0 | 0.8.0 |
## Features
Aries Cloud Controller Python is a fully featured client for interacting with ACA-Py.
- Fully Typed wrapper around Aries Cloud Agent Python
-- Supports latest ACA-Py version (0.7.5)
+- Supports latest ACA-Py version (0.8.0)
- Client is auto generated based on OpenAPI definitions, allowing us to keep up to date with new releases.
- Supports multi-tenant APIs and authentication
- Async API
@@ -222,13 +225,14 @@ Each Cloud Controller version maps to a specific ACA-Py version, which is outlin
| 0.5.1-0.5.2 | 0.7.3 |
| 0.6.0-0.6.3 | 0.7.4 |
| 0.7.0 | 0.7.5 |
+| 0.8.0 | 0.8.0 |
## Features
Aries Cloud Controller Python is a fully featured client for interacting with ACA-Py.
- Fully Typed wrapper around Aries Cloud Agent Python
-- Supports latest ACA-Py version (0.7.5)
+- Supports latest ACA-Py version (0.8.0)
- Client is auto generated based on OpenAPI definitions, allowing us to keep up to date with new releases.
- Supports multi-tenant APIs and authentication
- Async API
@@ -381,13 +385,14 @@ Each Cloud Controller version maps to a specific ACA-Py version, which is outlin
| 0.5.1-0.5.2 | 0.7.3 |
| 0.6.0-0.6.3 | 0.7.4 |
| 0.7.0 | 0.7.5 |
+| 0.8.0 | 0.8.0 |
## Features
Aries Cloud Controller Python is a fully featured client for interacting with ACA-Py.
- Fully Typed wrapper around Aries Cloud Agent Python
-- Supports latest ACA-Py version (0.7.5)
+- Supports latest ACA-Py version (0.8.0)
- Client is auto generated based on OpenAPI definitions, allowing us to keep up to date with new releases.
- Supports multi-tenant APIs and authentication
- Async API
@@ -489,7 +494,7 @@ Aries Cloud Controller Python is licensed under the [Apache License Version 2.0
%prep
-%autosetup -n aries-cloudcontroller-0.7.0
+%autosetup -n aries_cloudcontroller-0.8.0
%build
%py3_build
@@ -503,20 +508,20 @@ if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
- find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+ find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
- find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+ find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
- find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+ find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
- find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+ find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
- find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+ find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
@@ -529,5 +534,5 @@ mv %{buildroot}/doclist.lst .
%{_docdir}/*
%changelog
-* Thu May 18 2023 Python_Bot <Python_Bot@openeuler.org> - 0.7.0-1
+* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 0.8.0-1
- Package Spec generated