summaryrefslogtreecommitdiff
path: root/python-arpeggio.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-arpeggio.spec')
-rw-r--r--python-arpeggio.spec131
1 files changed, 131 insertions, 0 deletions
diff --git a/python-arpeggio.spec b/python-arpeggio.spec
new file mode 100644
index 0000000..1ae29af
--- /dev/null
+++ b/python-arpeggio.spec
@@ -0,0 +1,131 @@
+%global _empty_manifest_terminate_build 0
+Name: python-Arpeggio
+Version: 2.0.0
+Release: 1
+Summary: Packrat parser interpreter
+License: MIT
+URL: https://github.com/textX/Arpeggio
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/3d/ed/53c315e680fdf58818c0938f6c132df4342c95fc68977001244403fee476/Arpeggio-2.0.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-wheel
+Requires: python3-mkdocs
+Requires: python3-mike
+Requires: python3-twine
+Requires: python3-flake8
+Requires: python3-coverage
+Requires: python3-coveralls
+Requires: python3-pytest
+
+%description
+![](https://raw.githubusercontent.com/textX/Arpeggio/master/art/arpeggio-logo.png)
+
+[![PyPI Version](https://img.shields.io/pypi/v/Arpeggio.svg)](https://pypi.python.org/pypi/Arpeggio)
+![](https://img.shields.io/pypi/l/Arpeggio.svg)
+[![Build status](https://github.com/textx/Arpeggio/actions/workflows/ci-linux-ubuntu.yml/badge.svg)](https://github.com/textx/Arpeggio/actions)
+[![Coverage Status](https://coveralls.io/repos/github/textX/Arpeggio/badge.svg)](https://coveralls.io/github/textX/Arpeggio)
+[![Documentation](https://img.shields.io/badge/docs-latest-green.svg)](http://textx.github.io/Arpeggio/latest/)
+
+Arpeggio is a recursive descent parser with memoization based on PEG grammars
+(aka Packrat parser).
+
+Documentation with tutorials is available [here](http://textx.github.io/Arpeggio/).
+
+**Note:** for a higher level parsing/language tool (i.e., a nicer interface to
+Arpeggio) see [textX](https://github.com/textX/textX).
+
+
+
+
+%package -n python3-Arpeggio
+Summary: Packrat parser interpreter
+Provides: python-Arpeggio
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-Arpeggio
+![](https://raw.githubusercontent.com/textX/Arpeggio/master/art/arpeggio-logo.png)
+
+[![PyPI Version](https://img.shields.io/pypi/v/Arpeggio.svg)](https://pypi.python.org/pypi/Arpeggio)
+![](https://img.shields.io/pypi/l/Arpeggio.svg)
+[![Build status](https://github.com/textx/Arpeggio/actions/workflows/ci-linux-ubuntu.yml/badge.svg)](https://github.com/textx/Arpeggio/actions)
+[![Coverage Status](https://coveralls.io/repos/github/textX/Arpeggio/badge.svg)](https://coveralls.io/github/textX/Arpeggio)
+[![Documentation](https://img.shields.io/badge/docs-latest-green.svg)](http://textx.github.io/Arpeggio/latest/)
+
+Arpeggio is a recursive descent parser with memoization based on PEG grammars
+(aka Packrat parser).
+
+Documentation with tutorials is available [here](http://textx.github.io/Arpeggio/).
+
+**Note:** for a higher level parsing/language tool (i.e., a nicer interface to
+Arpeggio) see [textX](https://github.com/textX/textX).
+
+
+
+
+%package help
+Summary: Development documents and examples for Arpeggio
+Provides: python3-Arpeggio-doc
+%description help
+![](https://raw.githubusercontent.com/textX/Arpeggio/master/art/arpeggio-logo.png)
+
+[![PyPI Version](https://img.shields.io/pypi/v/Arpeggio.svg)](https://pypi.python.org/pypi/Arpeggio)
+![](https://img.shields.io/pypi/l/Arpeggio.svg)
+[![Build status](https://github.com/textx/Arpeggio/actions/workflows/ci-linux-ubuntu.yml/badge.svg)](https://github.com/textx/Arpeggio/actions)
+[![Coverage Status](https://coveralls.io/repos/github/textX/Arpeggio/badge.svg)](https://coveralls.io/github/textX/Arpeggio)
+[![Documentation](https://img.shields.io/badge/docs-latest-green.svg)](http://textx.github.io/Arpeggio/latest/)
+
+Arpeggio is a recursive descent parser with memoization based on PEG grammars
+(aka Packrat parser).
+
+Documentation with tutorials is available [here](http://textx.github.io/Arpeggio/).
+
+**Note:** for a higher level parsing/language tool (i.e., a nicer interface to
+Arpeggio) see [textX](https://github.com/textX/textX).
+
+
+
+
+%prep
+%autosetup -n Arpeggio-2.0.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-Arpeggio -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed Mar 08 2023 Python_Bot <Python_Bot@openeuler.org> - 2.0.0-1
+- Package Spec generated