summaryrefslogtreecommitdiff
path: root/python-astroplan.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-astroplan.spec')
-rw-r--r--python-astroplan.spec144
1 files changed, 144 insertions, 0 deletions
diff --git a/python-astroplan.spec b/python-astroplan.spec
new file mode 100644
index 0000000..5d3c010
--- /dev/null
+++ b/python-astroplan.spec
@@ -0,0 +1,144 @@
+%global _empty_manifest_terminate_build 0
+Name: python-astroplan
+Version: 0.8
+Release: 1
+Summary: Observation planning package for astronomers
+License: BSD
+URL: https://github.com/astropy/astroplan
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/49/23/15a8bcc0902c8073857995d0db933c5b86937e0a758152c2ea9b46e70a74/astroplan-0.8.tar.gz
+BuildArch: noarch
+
+
+%description
+Observation planning package for astronomers
+* Code: https://github.com/astropy/astroplan
+* Docs: https://astroplan.readthedocs.io/
+* License: BSD-3
+Attribution
++++++++++++
+If you use astroplan in your work, please cite `Morris et al. 2018 <https://ui.adsabs.harvard.edu/abs/2018AJ....155..128M/abstract>`_:
+ @ARTICLE{2018AJ....155..128M,
+ author = {{Morris}, Brett M. and {Tollerud}, Erik and {Sip{\H{o}}cz}, Brigitta and {Deil}, Christoph and {Douglas}, Stephanie T. and {Berlanga Medina}, Jazmin and {Vyhmeister}, Karl and {Smith}, Toby R. and {Littlefair}, Stuart and {Price-Whelan}, Adrian M. and {Gee}, Wilfred T. and {Jeschke}, Eric},
+ title = "{astroplan: An Open Source Observation Planning Package in Python}",
+ journal = {\aj},
+ keywords = {methods: numerical, methods: observational, Astrophysics - Instrumentation and Methods for Astrophysics},
+ year = 2018,
+ month = mar,
+ volume = {155},
+ number = {3},
+ eid = {128},
+ pages = {128},
+ doi = {10.3847/1538-3881/aaa47e},
+ archivePrefix = {arXiv},
+ eprint = {1712.09631},
+ primaryClass = {astro-ph.IM},
+ adsurl = {https://ui.adsabs.harvard.edu/abs/2018AJ....155..128M},
+ adsnote = {Provided by the SAO/NASA Astrophysics Data System}
+ }
+
+%package -n python3-astroplan
+Summary: Observation planning package for astronomers
+Provides: python-astroplan
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-astroplan
+Observation planning package for astronomers
+* Code: https://github.com/astropy/astroplan
+* Docs: https://astroplan.readthedocs.io/
+* License: BSD-3
+Attribution
++++++++++++
+If you use astroplan in your work, please cite `Morris et al. 2018 <https://ui.adsabs.harvard.edu/abs/2018AJ....155..128M/abstract>`_:
+ @ARTICLE{2018AJ....155..128M,
+ author = {{Morris}, Brett M. and {Tollerud}, Erik and {Sip{\H{o}}cz}, Brigitta and {Deil}, Christoph and {Douglas}, Stephanie T. and {Berlanga Medina}, Jazmin and {Vyhmeister}, Karl and {Smith}, Toby R. and {Littlefair}, Stuart and {Price-Whelan}, Adrian M. and {Gee}, Wilfred T. and {Jeschke}, Eric},
+ title = "{astroplan: An Open Source Observation Planning Package in Python}",
+ journal = {\aj},
+ keywords = {methods: numerical, methods: observational, Astrophysics - Instrumentation and Methods for Astrophysics},
+ year = 2018,
+ month = mar,
+ volume = {155},
+ number = {3},
+ eid = {128},
+ pages = {128},
+ doi = {10.3847/1538-3881/aaa47e},
+ archivePrefix = {arXiv},
+ eprint = {1712.09631},
+ primaryClass = {astro-ph.IM},
+ adsurl = {https://ui.adsabs.harvard.edu/abs/2018AJ....155..128M},
+ adsnote = {Provided by the SAO/NASA Astrophysics Data System}
+ }
+
+%package help
+Summary: Development documents and examples for astroplan
+Provides: python3-astroplan-doc
+%description help
+Observation planning package for astronomers
+* Code: https://github.com/astropy/astroplan
+* Docs: https://astroplan.readthedocs.io/
+* License: BSD-3
+Attribution
++++++++++++
+If you use astroplan in your work, please cite `Morris et al. 2018 <https://ui.adsabs.harvard.edu/abs/2018AJ....155..128M/abstract>`_:
+ @ARTICLE{2018AJ....155..128M,
+ author = {{Morris}, Brett M. and {Tollerud}, Erik and {Sip{\H{o}}cz}, Brigitta and {Deil}, Christoph and {Douglas}, Stephanie T. and {Berlanga Medina}, Jazmin and {Vyhmeister}, Karl and {Smith}, Toby R. and {Littlefair}, Stuart and {Price-Whelan}, Adrian M. and {Gee}, Wilfred T. and {Jeschke}, Eric},
+ title = "{astroplan: An Open Source Observation Planning Package in Python}",
+ journal = {\aj},
+ keywords = {methods: numerical, methods: observational, Astrophysics - Instrumentation and Methods for Astrophysics},
+ year = 2018,
+ month = mar,
+ volume = {155},
+ number = {3},
+ eid = {128},
+ pages = {128},
+ doi = {10.3847/1538-3881/aaa47e},
+ archivePrefix = {arXiv},
+ eprint = {1712.09631},
+ primaryClass = {astro-ph.IM},
+ adsurl = {https://ui.adsabs.harvard.edu/abs/2018AJ....155..128M},
+ adsnote = {Provided by the SAO/NASA Astrophysics Data System}
+ }
+
+%prep
+%autosetup -n astroplan-0.8
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-astroplan -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed Mar 08 2023 Python_Bot <Python_Bot@openeuler.org> - 0.8-1
+- Package Spec generated