summaryrefslogtreecommitdiff
path: root/python-asyncio-extras.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-asyncio-extras.spec')
-rw-r--r--python-asyncio-extras.spec137
1 files changed, 137 insertions, 0 deletions
diff --git a/python-asyncio-extras.spec b/python-asyncio-extras.spec
new file mode 100644
index 0000000..3f410b0
--- /dev/null
+++ b/python-asyncio-extras.spec
@@ -0,0 +1,137 @@
+%global _empty_manifest_terminate_build 0
+Name: python-asyncio_extras
+Version: 1.3.2
+Release: 1
+Summary: Asynchronous generators, context managers and more for asyncio
+License: MIT
+URL: https://github.com/agronholm/asyncio_extras
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/9b/4b/1ddcad1fb15e3e415993cf05c9d18b0a1bd66beb8172958b377ee7d09b85/asyncio_extras-1.3.2.tar.gz
+BuildArch: noarch
+
+Requires: python3-async-generator
+Requires: python3-sphinx-autodoc-typehints
+Requires: python3-pytest
+Requires: python3-pytest-asyncio
+Requires: python3-pytest-cov
+
+%description
+.. image:: https://travis-ci.org/agronholm/asyncio_extras.svg?branch=master
+ :target: https://travis-ci.org/agronholm/asyncio_extras
+ :alt: Build Status
+.. image:: https://coveralls.io/repos/agronholm/asyncio_extras/badge.svg?branch=master&service=github
+ :target: https://coveralls.io/github/agronholm/asyncio_extras?branch=master
+ :alt: Code Coverage
+.. image:: https://readthedocs.org/projects/asyncio-extras/badge/?version=latest
+ :target: https://asyncio-extras.readthedocs.io/en/latest/?badge=latest
+ :alt: Documentation Status
+
+This library provides several conveniences to users of asyncio_:
+
+* decorator for making asynchronous context managers (like ``contextlib.contextmanager``)
+* decorator and context manager for running a function or parts of a function in a thread pool
+* helpers for calling functions in the event loop from worker threads and vice versa
+* helpers for doing non-blocking file i/o
+
+.. _asyncio: https://docs.python.org/3/library/asyncio.html
+
+
+
+
+%package -n python3-asyncio_extras
+Summary: Asynchronous generators, context managers and more for asyncio
+Provides: python-asyncio_extras
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-asyncio_extras
+.. image:: https://travis-ci.org/agronholm/asyncio_extras.svg?branch=master
+ :target: https://travis-ci.org/agronholm/asyncio_extras
+ :alt: Build Status
+.. image:: https://coveralls.io/repos/agronholm/asyncio_extras/badge.svg?branch=master&service=github
+ :target: https://coveralls.io/github/agronholm/asyncio_extras?branch=master
+ :alt: Code Coverage
+.. image:: https://readthedocs.org/projects/asyncio-extras/badge/?version=latest
+ :target: https://asyncio-extras.readthedocs.io/en/latest/?badge=latest
+ :alt: Documentation Status
+
+This library provides several conveniences to users of asyncio_:
+
+* decorator for making asynchronous context managers (like ``contextlib.contextmanager``)
+* decorator and context manager for running a function or parts of a function in a thread pool
+* helpers for calling functions in the event loop from worker threads and vice versa
+* helpers for doing non-blocking file i/o
+
+.. _asyncio: https://docs.python.org/3/library/asyncio.html
+
+
+
+
+%package help
+Summary: Development documents and examples for asyncio_extras
+Provides: python3-asyncio_extras-doc
+%description help
+.. image:: https://travis-ci.org/agronholm/asyncio_extras.svg?branch=master
+ :target: https://travis-ci.org/agronholm/asyncio_extras
+ :alt: Build Status
+.. image:: https://coveralls.io/repos/agronholm/asyncio_extras/badge.svg?branch=master&service=github
+ :target: https://coveralls.io/github/agronholm/asyncio_extras?branch=master
+ :alt: Code Coverage
+.. image:: https://readthedocs.org/projects/asyncio-extras/badge/?version=latest
+ :target: https://asyncio-extras.readthedocs.io/en/latest/?badge=latest
+ :alt: Documentation Status
+
+This library provides several conveniences to users of asyncio_:
+
+* decorator for making asynchronous context managers (like ``contextlib.contextmanager``)
+* decorator and context manager for running a function or parts of a function in a thread pool
+* helpers for calling functions in the event loop from worker threads and vice versa
+* helpers for doing non-blocking file i/o
+
+.. _asyncio: https://docs.python.org/3/library/asyncio.html
+
+
+
+
+%prep
+%autosetup -n asyncio_extras-1.3.2
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-asyncio_extras -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 1.3.2-1
+- Package Spec generated