summaryrefslogtreecommitdiff
path: root/python-asyncio-rpc.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-asyncio-rpc.spec')
-rw-r--r--python-asyncio-rpc.spec82
1 files changed, 82 insertions, 0 deletions
diff --git a/python-asyncio-rpc.spec b/python-asyncio-rpc.spec
new file mode 100644
index 0000000..75eecf0
--- /dev/null
+++ b/python-asyncio-rpc.spec
@@ -0,0 +1,82 @@
+%global _empty_manifest_terminate_build 0
+Name: python-asyncio-rpc
+Version: 0.1.10
+Release: 1
+Summary: Asyncio RPC client/server with redis/msgpack/dataclasses
+License: BSD license
+URL: https://github.com/nens/asyncio_rpc
+Source0: https://mirrors.aliyun.com/pypi/web/packages/b9/87/d24d8e39bf0aad490e2c9dfcbbf7495398a2951885deaeddec0c65b3254f/asyncio_rpc-0.1.10.tar.gz
+BuildArch: noarch
+
+Requires: python3-numpy
+Requires: python3-msgpack
+Requires: python3-lz4
+Requires: python3-aioredis
+
+%description
+The Python package for the asyncio remote procedure calling
+* Free software: BSD license
+* Documentation: https://asyncio-rpc.readthedocs.io.
+
+%package -n python3-asyncio-rpc
+Summary: Asyncio RPC client/server with redis/msgpack/dataclasses
+Provides: python-asyncio-rpc
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-asyncio-rpc
+The Python package for the asyncio remote procedure calling
+* Free software: BSD license
+* Documentation: https://asyncio-rpc.readthedocs.io.
+
+%package help
+Summary: Development documents and examples for asyncio-rpc
+Provides: python3-asyncio-rpc-doc
+%description help
+The Python package for the asyncio remote procedure calling
+* Free software: BSD license
+* Documentation: https://asyncio-rpc.readthedocs.io.
+
+%prep
+%autosetup -n asyncio_rpc-0.1.10
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-asyncio-rpc -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Jun 20 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1.10-1
+- Package Spec generated