summaryrefslogtreecommitdiff
path: root/python-asyncstdlib.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-asyncstdlib.spec')
-rw-r--r--python-asyncstdlib.spec83
1 files changed, 83 insertions, 0 deletions
diff --git a/python-asyncstdlib.spec b/python-asyncstdlib.spec
new file mode 100644
index 0000000..e866883
--- /dev/null
+++ b/python-asyncstdlib.spec
@@ -0,0 +1,83 @@
+%global _empty_manifest_terminate_build 0
+Name: python-asyncstdlib
+Version: 3.10.6
+Release: 1
+Summary: The missing async toolbox
+License: MIT License
+URL: https://pypi.org/project/asyncstdlib/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/67/0e/015fa46ffbadd9f431783bd263b1a9cc137de103b6fe597b29149eff86d8/asyncstdlib-3.10.6.tar.gz
+BuildArch: noarch
+
+Requires: python3-typing_extensions
+Requires: python3-sphinx
+Requires: python3-sphinxcontrib-trio
+Requires: python3-pytest
+Requires: python3-flake8
+Requires: python3-flake8-bugbear
+Requires: python3-black
+Requires: python3-coverage
+Requires: python3-pytest-cov
+Requires: python3-flake8-2020
+Requires: python3-mypy
+
+%description
+
+
+%package -n python3-asyncstdlib
+Summary: The missing async toolbox
+Provides: python-asyncstdlib
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-asyncstdlib
+
+
+%package help
+Summary: Development documents and examples for asyncstdlib
+Provides: python3-asyncstdlib-doc
+%description help
+
+
+%prep
+%autosetup -n asyncstdlib-3.10.6
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-asyncstdlib -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 3.10.6-1
+- Package Spec generated