summaryrefslogtreecommitdiff
path: root/python-atc-dataplatform.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-11 06:22:50 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-11 06:22:50 +0000
commitcbadc5928ccae8d0314a784bcd043da345a973b5 (patch)
treefc5b6feaf15258f14691329f243f1d74049a8606 /python-atc-dataplatform.spec
parentadf1d9ff99c1c385ff583788284ed7a29c2a3947 (diff)
automatic import of python-atc-dataplatform
Diffstat (limited to 'python-atc-dataplatform.spec')
-rw-r--r--python-atc-dataplatform.spec237
1 files changed, 237 insertions, 0 deletions
diff --git a/python-atc-dataplatform.spec b/python-atc-dataplatform.spec
new file mode 100644
index 0000000..9ab7b10
--- /dev/null
+++ b/python-atc-dataplatform.spec
@@ -0,0 +1,237 @@
+%global _empty_manifest_terminate_build 0
+Name: python-atc-dataplatform
+Version: 1.1.69
+Release: 1
+Summary: A common set of python libraries for DataBricks
+License: MIT License
+URL: https://github.com/atc-net/atc-dataplatform
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/1e/06/782e4acc25297d86ed5388fa67aa5360c37c6e9208905eaf9775f4868a3e/atc-dataplatform-1.1.69.tar.gz
+BuildArch: noarch
+
+Requires: python3-pyyaml
+Requires: python3-sqlparse
+Requires: python3-Deprecated
+Requires: python3-pyodbc
+Requires: python3-databricks-api
+Requires: python3-importlib-metadata
+Requires: python3-azure-cosmos
+Requires: python3-timezonefinder
+Requires: python3-more-itertools
+
+%description
+# atc-dataplatform
+A common set of python libraries for DataBricks.
+
+## Important Notes
+
+This package can not be run or tested without access to pyspark.
+However, installing pyspark as part of our installer gave issues when
+other versions of pyspark were needed. Hence we took out the dependency
+from our installer.
+
+## Installation
+
+Get it from PyPi
+[![PyPI version](https://badge.fury.io/py/atc-dataplatform.svg)](https://pypi.org/project/atc-dataplatform/)
+[![PyPI](https://img.shields.io/pypi/dm/atc-dataplatform)](https://pypi.org/project/atc-dataplatform/)
+```
+pip install atc-dataplatform
+```
+
+## Development Notes
+
+To prepare for development please install these additional requirements:
+ - Java 8
+ - `pip install -r test_requirements.txt`
+
+Then install the package locally
+
+ python setup.py develop
+
+
+### Testing
+
+After installing the dev-requirements, execute tests by running
+
+ pytest tests
+
+If these tests don't pass, PRs will not be accepted. If you add features,
+please include tests for these features.
+
+
+### General Project Info
+[![Github top language](https://img.shields.io/github/languages/top/atc-net/atc-dataplatform)](https://github.com/atc-net/atc-dataplatform)
+[![Github stars](https://img.shields.io/github/stars/atc-net/atc-dataplatform)](https://github.com/atc-net/atc-dataplatform)
+[![Github forks](https://img.shields.io/github/forks/atc-net/atc-dataplatform)](https://github.com/atc-net/atc-dataplatform)
+[![Github size](https://img.shields.io/github/repo-size/atc-net/atc-dataplatform)](https://github.com/atc-net/atc-dataplatform)
+[![Issues Open](https://img.shields.io/github/issues/atc-net/atc-dataplatform.svg?logo=github)](https://github.com/atc-net/atc-dataplatform/issues)
+
+### Packages
+
+### Build Status
+
+
+
+
+%package -n python3-atc-dataplatform
+Summary: A common set of python libraries for DataBricks
+Provides: python-atc-dataplatform
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-atc-dataplatform
+# atc-dataplatform
+A common set of python libraries for DataBricks.
+
+## Important Notes
+
+This package can not be run or tested without access to pyspark.
+However, installing pyspark as part of our installer gave issues when
+other versions of pyspark were needed. Hence we took out the dependency
+from our installer.
+
+## Installation
+
+Get it from PyPi
+[![PyPI version](https://badge.fury.io/py/atc-dataplatform.svg)](https://pypi.org/project/atc-dataplatform/)
+[![PyPI](https://img.shields.io/pypi/dm/atc-dataplatform)](https://pypi.org/project/atc-dataplatform/)
+```
+pip install atc-dataplatform
+```
+
+## Development Notes
+
+To prepare for development please install these additional requirements:
+ - Java 8
+ - `pip install -r test_requirements.txt`
+
+Then install the package locally
+
+ python setup.py develop
+
+
+### Testing
+
+After installing the dev-requirements, execute tests by running
+
+ pytest tests
+
+If these tests don't pass, PRs will not be accepted. If you add features,
+please include tests for these features.
+
+
+### General Project Info
+[![Github top language](https://img.shields.io/github/languages/top/atc-net/atc-dataplatform)](https://github.com/atc-net/atc-dataplatform)
+[![Github stars](https://img.shields.io/github/stars/atc-net/atc-dataplatform)](https://github.com/atc-net/atc-dataplatform)
+[![Github forks](https://img.shields.io/github/forks/atc-net/atc-dataplatform)](https://github.com/atc-net/atc-dataplatform)
+[![Github size](https://img.shields.io/github/repo-size/atc-net/atc-dataplatform)](https://github.com/atc-net/atc-dataplatform)
+[![Issues Open](https://img.shields.io/github/issues/atc-net/atc-dataplatform.svg?logo=github)](https://github.com/atc-net/atc-dataplatform/issues)
+
+### Packages
+
+### Build Status
+
+
+
+
+%package help
+Summary: Development documents and examples for atc-dataplatform
+Provides: python3-atc-dataplatform-doc
+%description help
+# atc-dataplatform
+A common set of python libraries for DataBricks.
+
+## Important Notes
+
+This package can not be run or tested without access to pyspark.
+However, installing pyspark as part of our installer gave issues when
+other versions of pyspark were needed. Hence we took out the dependency
+from our installer.
+
+## Installation
+
+Get it from PyPi
+[![PyPI version](https://badge.fury.io/py/atc-dataplatform.svg)](https://pypi.org/project/atc-dataplatform/)
+[![PyPI](https://img.shields.io/pypi/dm/atc-dataplatform)](https://pypi.org/project/atc-dataplatform/)
+```
+pip install atc-dataplatform
+```
+
+## Development Notes
+
+To prepare for development please install these additional requirements:
+ - Java 8
+ - `pip install -r test_requirements.txt`
+
+Then install the package locally
+
+ python setup.py develop
+
+
+### Testing
+
+After installing the dev-requirements, execute tests by running
+
+ pytest tests
+
+If these tests don't pass, PRs will not be accepted. If you add features,
+please include tests for these features.
+
+
+### General Project Info
+[![Github top language](https://img.shields.io/github/languages/top/atc-net/atc-dataplatform)](https://github.com/atc-net/atc-dataplatform)
+[![Github stars](https://img.shields.io/github/stars/atc-net/atc-dataplatform)](https://github.com/atc-net/atc-dataplatform)
+[![Github forks](https://img.shields.io/github/forks/atc-net/atc-dataplatform)](https://github.com/atc-net/atc-dataplatform)
+[![Github size](https://img.shields.io/github/repo-size/atc-net/atc-dataplatform)](https://github.com/atc-net/atc-dataplatform)
+[![Issues Open](https://img.shields.io/github/issues/atc-net/atc-dataplatform.svg?logo=github)](https://github.com/atc-net/atc-dataplatform/issues)
+
+### Packages
+
+### Build Status
+
+
+
+
+%prep
+%autosetup -n atc-dataplatform-1.1.69
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-atc-dataplatform -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 1.1.69-1
+- Package Spec generated