summaryrefslogtreecommitdiff
path: root/python-atlassian-jwt-auth.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-atlassian-jwt-auth.spec')
-rw-r--r--python-atlassian-jwt-auth.spec76
1 files changed, 76 insertions, 0 deletions
diff --git a/python-atlassian-jwt-auth.spec b/python-atlassian-jwt-auth.spec
new file mode 100644
index 0000000..32027c7
--- /dev/null
+++ b/python-atlassian-jwt-auth.spec
@@ -0,0 +1,76 @@
+%global _empty_manifest_terminate_build 0
+Name: python-atlassian-jwt-auth
+Version: 17.0.0
+Release: 1
+Summary: Python implementation of the Atlassian Service to Service Authentication specification.
+License: MIT
+URL: https://github.com/atlassian/asap-authentication-python
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/27/8e/2702025496bcd8b457822463d4d1ef1a6d3e8947c28a8538fa103fda7a18/atlassian-jwt-auth-17.0.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-PyJWT
+Requires: python3-PyJWT[crypto]
+Requires: python3-requests
+Requires: python3-CacheControl
+
+%description
+
+
+%package -n python3-atlassian-jwt-auth
+Summary: Python implementation of the Atlassian Service to Service Authentication specification.
+Provides: python-atlassian-jwt-auth
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-atlassian-jwt-auth
+
+
+%package help
+Summary: Development documents and examples for atlassian-jwt-auth
+Provides: python3-atlassian-jwt-auth-doc
+%description help
+
+
+%prep
+%autosetup -n atlassian-jwt-auth-17.0.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-atlassian-jwt-auth -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 17.0.0-1
+- Package Spec generated