summaryrefslogtreecommitdiff
path: root/python-autobahntestsuite.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-17 03:22:26 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-17 03:22:26 +0000
commita4722a76f9ca7d0d07eb32ce985875659f3a58ca (patch)
tree5fabe1985f1ef65c0302a05967d65349fd8d7233 /python-autobahntestsuite.spec
parent64e79fdbf43f218cae53e7500c23404426806e1f (diff)
automatic import of python-autobahntestsuite
Diffstat (limited to 'python-autobahntestsuite.spec')
-rw-r--r--python-autobahntestsuite.spec202
1 files changed, 202 insertions, 0 deletions
diff --git a/python-autobahntestsuite.spec b/python-autobahntestsuite.spec
new file mode 100644
index 0000000..9f3ff69
--- /dev/null
+++ b/python-autobahntestsuite.spec
@@ -0,0 +1,202 @@
+%global _empty_manifest_terminate_build 0
+Name: python-autobahntestsuite
+Version: 0.8.2
+Release: 1
+Summary: AutobahnTestSuite - WebSocket/WAMP protocol implementation test suite.
+License: Apache License 2.0
+URL: http://autobahn.ws/testsuite
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/93/5b/8fdb10089cb11245a9709eef67d5a09940ec33e5b7182702e8a2cc4dee71/autobahntestsuite-0.8.2.tar.gz
+BuildArch: noarch
+
+Requires: python3-setuptools
+Requires: python3-txaio
+Requires: python3-autobahn[accelerate,twisted]
+Requires: python3-jinja2
+Requires: python3-markupsafe
+Requires: python3-Werkzeug
+Requires: python3-klein
+Requires: python3-pyopenssl
+Requires: python3-service-identity
+Requires: python3-unittest2
+
+%description
+
+Twisted-based WebSocket/WAMP protocol implementation test suite.
+
+Autobahn|Testsuite provides a fully automated test suite to verify client and
+server implementations of the WebSocket protocol.
+
+The test suite will check an implementation by doing basic WebSocket
+conversations, extensive protocol compliance verification and
+performance and limits testing.
+
+Contains over 500 test cases covering
+
+* Framing
+* Pings/Pongs
+* Reserved Bits
+* Opcodes
+* Fragmentation
+* UTF-8 Handling
+* Limits/Performance
+* Closing Handshake
+* Opening Handshake (under development)
+* WebSocket compression (permessage-deflate extension)
+
+Besides the automated test suite, wstest also includes a number
+of other handy developer tools:
+
+* WebSocket echo server and client
+* WebSocket broadcast server (and client driver)
+* Testee modes to test Autobahn itself against the test suite
+* wsperf controller and master (see http://www.zaphoyd.com/wsperf)
+* WAMP server and client, for developing WAMP implementations
+
+More information:
+
+* http://autobahn.ws/testsuite
+* https://github.com/crossbario/autobahn-testsuite
+* http://tools.ietf.org/html/rfc6455
+* http://wamp.ws
+
+
+
+
+%package -n python3-autobahntestsuite
+Summary: AutobahnTestSuite - WebSocket/WAMP protocol implementation test suite.
+Provides: python-autobahntestsuite
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-autobahntestsuite
+
+Twisted-based WebSocket/WAMP protocol implementation test suite.
+
+Autobahn|Testsuite provides a fully automated test suite to verify client and
+server implementations of the WebSocket protocol.
+
+The test suite will check an implementation by doing basic WebSocket
+conversations, extensive protocol compliance verification and
+performance and limits testing.
+
+Contains over 500 test cases covering
+
+* Framing
+* Pings/Pongs
+* Reserved Bits
+* Opcodes
+* Fragmentation
+* UTF-8 Handling
+* Limits/Performance
+* Closing Handshake
+* Opening Handshake (under development)
+* WebSocket compression (permessage-deflate extension)
+
+Besides the automated test suite, wstest also includes a number
+of other handy developer tools:
+
+* WebSocket echo server and client
+* WebSocket broadcast server (and client driver)
+* Testee modes to test Autobahn itself against the test suite
+* wsperf controller and master (see http://www.zaphoyd.com/wsperf)
+* WAMP server and client, for developing WAMP implementations
+
+More information:
+
+* http://autobahn.ws/testsuite
+* https://github.com/crossbario/autobahn-testsuite
+* http://tools.ietf.org/html/rfc6455
+* http://wamp.ws
+
+
+
+
+%package help
+Summary: Development documents and examples for autobahntestsuite
+Provides: python3-autobahntestsuite-doc
+%description help
+
+Twisted-based WebSocket/WAMP protocol implementation test suite.
+
+Autobahn|Testsuite provides a fully automated test suite to verify client and
+server implementations of the WebSocket protocol.
+
+The test suite will check an implementation by doing basic WebSocket
+conversations, extensive protocol compliance verification and
+performance and limits testing.
+
+Contains over 500 test cases covering
+
+* Framing
+* Pings/Pongs
+* Reserved Bits
+* Opcodes
+* Fragmentation
+* UTF-8 Handling
+* Limits/Performance
+* Closing Handshake
+* Opening Handshake (under development)
+* WebSocket compression (permessage-deflate extension)
+
+Besides the automated test suite, wstest also includes a number
+of other handy developer tools:
+
+* WebSocket echo server and client
+* WebSocket broadcast server (and client driver)
+* Testee modes to test Autobahn itself against the test suite
+* wsperf controller and master (see http://www.zaphoyd.com/wsperf)
+* WAMP server and client, for developing WAMP implementations
+
+More information:
+
+* http://autobahn.ws/testsuite
+* https://github.com/crossbario/autobahn-testsuite
+* http://tools.ietf.org/html/rfc6455
+* http://wamp.ws
+
+
+
+
+%prep
+%autosetup -n autobahntestsuite-0.8.2
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-autobahntestsuite -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 17 2023 Python_Bot <Python_Bot@openeuler.org> - 0.8.2-1
+- Package Spec generated