summaryrefslogtreecommitdiff
path: root/python-autobotlib.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-autobotlib.spec')
-rw-r--r--python-autobotlib.spec90
1 files changed, 90 insertions, 0 deletions
diff --git a/python-autobotlib.spec b/python-autobotlib.spec
new file mode 100644
index 0000000..2c402dc
--- /dev/null
+++ b/python-autobotlib.spec
@@ -0,0 +1,90 @@
+%global _empty_manifest_terminate_build 0
+Name: python-autoBOTLib
+Version: 1.19
+Release: 1
+Summary: AutoBOT: Explainable AutoML for texts
+License: bsd-3-clause-clear
+URL: https://github.com/skblaz/autobot
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/be/69/7929a41779a44be1cc53d23d6f6eeb1ca78bcf4417e04f5d9dd523ed6d9b/autoBOTLib-1.19.tar.gz
+BuildArch: noarch
+
+
+%description
+
+autoBOT is an AutoML system for text classification with an emphasis on explainability.
+It implements the idea of *representation evolution*, learning to combine representations
+for a given task, automatically.
+
+
+
+
+%package -n python3-autoBOTLib
+Summary: AutoBOT: Explainable AutoML for texts
+Provides: python-autoBOTLib
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-autoBOTLib
+
+autoBOT is an AutoML system for text classification with an emphasis on explainability.
+It implements the idea of *representation evolution*, learning to combine representations
+for a given task, automatically.
+
+
+
+
+%package help
+Summary: Development documents and examples for autoBOTLib
+Provides: python3-autoBOTLib-doc
+%description help
+
+autoBOT is an AutoML system for text classification with an emphasis on explainability.
+It implements the idea of *representation evolution*, learning to combine representations
+for a given task, automatically.
+
+
+
+
+%prep
+%autosetup -n autoBOTLib-1.19
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-autoBOTLib -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed Apr 12 2023 Python_Bot <Python_Bot@openeuler.org> - 1.19-1
+- Package Spec generated