summaryrefslogtreecommitdiff
path: root/python-autograd-gamma.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-autograd-gamma.spec')
-rw-r--r--python-autograd-gamma.spec183
1 files changed, 183 insertions, 0 deletions
diff --git a/python-autograd-gamma.spec b/python-autograd-gamma.spec
new file mode 100644
index 0000000..cd05c7f
--- /dev/null
+++ b/python-autograd-gamma.spec
@@ -0,0 +1,183 @@
+%global _empty_manifest_terminate_build 0
+Name: python-autograd-gamma
+Version: 0.5.0
+Release: 1
+Summary: Autograd compatible approximations to the gamma family of functions
+License: MIT License
+URL: https://github.com/CamDavidsonPilon/autograd-gamma
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/85/ae/7f2031ea76140444b2453fa139041e5afd4a09fc5300cfefeb1103291f80/autograd-gamma-0.5.0.tar.gz
+BuildArch: noarch
+
+
+%description
+# autograd-gamma
+[![PyPI version](https://badge.fury.io/py/autograd-gamma.svg)](https://badge.fury.io/py/autograd-gamma)
+
+
+[autograd](https://github.com/HIPS/autograd) compatible approximations to the derivatives of the Gamma-family of functions.
+
+
+# Tutorial
+
+```python
+from autograd import grad
+from autograd_gamma import gammainc, gammaincc, gammaincln, gammainccln
+
+
+grad(gammainc, argnum=0)(1., 2.)
+grad(gammaincc, argnum=0)(1., 2.)
+
+# logarithmic functions too.
+grad(gammaincln, argnum=0)(1., 2.)
+grad(gammainccln, argnum=0)(1., 2.)
+
+
+
+from autograd_gamma import betainc, betaincln
+
+grad(betainc, argnum=0)(1., 2., 0.5)
+grad(betainc, argnum=1)(1., 2., 0.5)
+
+# logarithmic functions too.
+grad(betaincln, argnum=0)(1., 2., 0.5)
+grad(betaincln, argnum=1)(1., 2., 0.5)
+
+```
+
+
+# Long-term goal
+
+Build and improve upon the derivative of the upper and lower incomplete gamma functions. Eventually, if we have a fast analytical solution, we will merge into the autograd library.
+
+%package -n python3-autograd-gamma
+Summary: Autograd compatible approximations to the gamma family of functions
+Provides: python-autograd-gamma
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-autograd-gamma
+# autograd-gamma
+[![PyPI version](https://badge.fury.io/py/autograd-gamma.svg)](https://badge.fury.io/py/autograd-gamma)
+
+
+[autograd](https://github.com/HIPS/autograd) compatible approximations to the derivatives of the Gamma-family of functions.
+
+
+# Tutorial
+
+```python
+from autograd import grad
+from autograd_gamma import gammainc, gammaincc, gammaincln, gammainccln
+
+
+grad(gammainc, argnum=0)(1., 2.)
+grad(gammaincc, argnum=0)(1., 2.)
+
+# logarithmic functions too.
+grad(gammaincln, argnum=0)(1., 2.)
+grad(gammainccln, argnum=0)(1., 2.)
+
+
+
+from autograd_gamma import betainc, betaincln
+
+grad(betainc, argnum=0)(1., 2., 0.5)
+grad(betainc, argnum=1)(1., 2., 0.5)
+
+# logarithmic functions too.
+grad(betaincln, argnum=0)(1., 2., 0.5)
+grad(betaincln, argnum=1)(1., 2., 0.5)
+
+```
+
+
+# Long-term goal
+
+Build and improve upon the derivative of the upper and lower incomplete gamma functions. Eventually, if we have a fast analytical solution, we will merge into the autograd library.
+
+%package help
+Summary: Development documents and examples for autograd-gamma
+Provides: python3-autograd-gamma-doc
+%description help
+# autograd-gamma
+[![PyPI version](https://badge.fury.io/py/autograd-gamma.svg)](https://badge.fury.io/py/autograd-gamma)
+
+
+[autograd](https://github.com/HIPS/autograd) compatible approximations to the derivatives of the Gamma-family of functions.
+
+
+# Tutorial
+
+```python
+from autograd import grad
+from autograd_gamma import gammainc, gammaincc, gammaincln, gammainccln
+
+
+grad(gammainc, argnum=0)(1., 2.)
+grad(gammaincc, argnum=0)(1., 2.)
+
+# logarithmic functions too.
+grad(gammaincln, argnum=0)(1., 2.)
+grad(gammainccln, argnum=0)(1., 2.)
+
+
+
+from autograd_gamma import betainc, betaincln
+
+grad(betainc, argnum=0)(1., 2., 0.5)
+grad(betainc, argnum=1)(1., 2., 0.5)
+
+# logarithmic functions too.
+grad(betaincln, argnum=0)(1., 2., 0.5)
+grad(betaincln, argnum=1)(1., 2., 0.5)
+
+```
+
+
+# Long-term goal
+
+Build and improve upon the derivative of the upper and lower incomplete gamma functions. Eventually, if we have a fast analytical solution, we will merge into the autograd library.
+
+%prep
+%autosetup -n autograd-gamma-0.5.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-autograd-gamma -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 0.5.0-1
+- Package Spec generated