summaryrefslogtreecommitdiff
path: root/python-automaton.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-automaton.spec')
-rw-r--r--python-automaton.spec74
1 files changed, 74 insertions, 0 deletions
diff --git a/python-automaton.spec b/python-automaton.spec
new file mode 100644
index 0000000..69ab4e0
--- /dev/null
+++ b/python-automaton.spec
@@ -0,0 +1,74 @@
+%global _empty_manifest_terminate_build 0
+Name: python-automaton
+Version: 3.1.0
+Release: 1
+Summary: Friendly state machines for python.
+License: Apache Software License
+URL: https://docs.openstack.org/automaton/latest/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/50/9d/3ab2fe5fc210dd78eea3f84bb56b5a9f5e73fa91bd7029203e1b2a1bb946/automaton-3.1.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-PrettyTable
+Requires: python3-pbr
+
+%description
+
+
+%package -n python3-automaton
+Summary: Friendly state machines for python.
+Provides: python-automaton
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-automaton
+
+
+%package help
+Summary: Development documents and examples for automaton
+Provides: python3-automaton-doc
+%description help
+
+
+%prep
+%autosetup -n automaton-3.1.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-automaton -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed Mar 08 2023 Python_Bot <Python_Bot@openeuler.org> - 3.1.0-1
+- Package Spec generated