summaryrefslogtreecommitdiff
path: root/python-automl-alex.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-18 03:35:25 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-18 03:35:25 +0000
commitd19addaad9efc3454ef2808632529668e15db0d6 (patch)
tree0dcc767a1d9e87cfdd35fd1769137a4c1c3f6525 /python-automl-alex.spec
parentf60a6d62efc6211ca50b8f1353c7ebd8bf05e301 (diff)
automatic import of python-automl-alex
Diffstat (limited to 'python-automl-alex.spec')
-rw-r--r--python-automl-alex.spec398
1 files changed, 398 insertions, 0 deletions
diff --git a/python-automl-alex.spec b/python-automl-alex.spec
new file mode 100644
index 0000000..7ddf7dc
--- /dev/null
+++ b/python-automl-alex.spec
@@ -0,0 +1,398 @@
+%global _empty_manifest_terminate_build 0
+Name: python-automl-alex
+Version: 2023.3.11
+Release: 1
+Summary: State-of-the art Automated Machine Learning python library for Tabular Data
+License: MIT
+URL: https://pypi.org/project/automl-alex/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/4e/be/345d3d0a44e7ee8e9432c049a1b7663ecf84923f4babc4465b37d5a0f24c/automl-alex-2023.3.11.tar.gz
+BuildArch: noarch
+
+Requires: python3-numpy
+Requires: python3-pandas
+Requires: python3-scikit-learn
+Requires: python3-seaborn
+Requires: python3-lightgbm
+Requires: python3-catboost
+Requires: python3-xgboost
+Requires: python3-tqdm
+Requires: python3-optuna
+Requires: python3-category-encoders
+Requires: python3-optuna-dashboard
+Requires: python3-loguru
+Requires: python3-psutil
+Requires: python3-nbformat
+
+%description
+<p align="center"> State-of-the art Automated Machine Learning python library for Tabular Data</p>
+## Works with Tasks:
+- [x] Binary Classification
+- [x] Regression
+- [ ] Multiclass Classification (in progress...)
+### Benchmark Results
+<img width=800 src="https://github.com/Alex-Lekov/AutoML-Benchmark/blob/master/img/Total_SUM.png" alt="bench">
+The bigger, the better
+From [AutoML-Benchmark](https://github.com/Alex-Lekov/AutoML-Benchmark/)
+### Scheme
+<img width=800 src="https://github.com/Alex-Lekov/AutoML_Alex/blob/develop/examples/img/shema.png" alt="scheme">
+# Features
+- Automated Data Clean (Auto Clean)
+- Automated **Feature Engineering** (Auto FE)
+- Smart Hyperparameter Optimization (HPO)
+- Feature Generation
+- Feature Selection
+- Models Selection
+- Cross Validation
+- Optimization Timelimit and EarlyStoping
+- Save and Load (Predict new data)
+# Installation
+```python
+pip install automl-alex
+```
+# Docs
+[DocPage](https://alex-lekov.github.io/AutoML_Alex/)
+# 🚀 Examples
+Classifier:
+```python
+from automl_alex import AutoMLClassifier
+model = AutoMLClassifier()
+model.fit(X_train, y_train, timeout=600)
+predicts = model.predict(X_test)
+```
+Regression:
+```python
+from automl_alex import AutoMLRegressor
+model = AutoMLRegressor()
+model.fit(X_train, y_train, timeout=600)
+predicts = model.predict(X_test)
+```
+DataPrepare:
+```python
+from automl_alex import DataPrepare
+de = DataPrepare()
+X_train = de.fit_transform(X_train)
+X_test = de.transform(X_test)
+```
+Simple Models Wrapper:
+```python
+from automl_alex import LightGBMClassifier
+model = LightGBMClassifier()
+model.fit(X_train, y_train)
+predicts = model.predict_proba(X_test)
+model.opt(X_train, y_train,
+ timeout=600, # optimization time in seconds,
+ )
+predicts = model.predict_proba(X_test)
+```
+More examples in the folder ./examples:
+- [01_Quick_Start.ipynb](https://github.com/Alex-Lekov/AutoML_Alex/blob/master/examples/01_Quick_Start.ipynb) [![Open in Colab](https://colab.research.google.com/assets/colab-badge.svg)](http://colab.research.google.com/github/Alex-Lekov/AutoML_Alex/blob/master/examples/01_Quick_Start.ipynb)
+- [02_Data_Cleaning_and_Encoding_(DataPrepare).ipynb](https://github.com/Alex-Lekov/AutoML_Alex/blob/master/examples/02_Data_Cleaning_and_Encoding_(DataPrepare).ipynb) [![Open in Colab](https://colab.research.google.com/assets/colab-badge.svg)](http://colab.research.google.com/github/Alex-Lekov/AutoML_Alex/blob/master/examples/02_Data_Cleaning_and_Encoding_(DataPrepare).ipynb)
+- [03_Models.ipynb](https://github.com/Alex-Lekov/AutoML_Alex/blob/master/examples/03_Models.ipynb) [![Open in Colab](https://colab.research.google.com/assets/colab-badge.svg)](http://colab.research.google.com/github/Alex-Lekov/AutoML_Alex/blob/master/examples/03_Models.ipynb)
+- [04_ModelsReview.ipynb](https://github.com/Alex-Lekov/AutoML_Alex/blob/master/examples/04_ModelsReview.ipynb) [![Open in Colab](https://colab.research.google.com/assets/colab-badge.svg)](http://colab.research.google.com/github/Alex-Lekov/AutoML_Alex/blob/master/examples/04_ModelsReview.ipynb)
+- [05_BestSingleModel.ipynb](https://github.com/Alex-Lekov/AutoML_Alex/blob/master/examples/05_BestSingleModel.ipynb) [![Open in Colab](https://colab.research.google.com/assets/colab-badge.svg)](http://colab.research.google.com/github/Alex-Lekov/AutoML_Alex/blob/master/examples/05_BestSingleModel.ipynb)
+- [Production Docker template](https://github.com/Alex-Lekov/AutoML_Alex/blob/master/examples/prod_sample)
+# What's inside
+It integrates many popular frameworks:
+- scikit-learn
+- XGBoost
+- LightGBM
+- CatBoost
+- Optuna
+- ...
+# Works with Features
+- [x] Categorical Features
+- [x] Numerical Features
+- [x] Binary Features
+- [ ] Text
+- [ ] Datetime
+- [ ] Timeseries
+- [ ] Image
+# Note
+- **With a large dataset, a lot of memory is required!**
+Library creates many new features. If you have a large dataset with a large number of features (more than 100), you may need a lot of memory.
+# Realtime Dashboard
+Works with [optuna-dashboard](https://github.com/optuna/optuna-dashboard)
+<img width=800 src="https://github.com/Alex-Lekov/AutoML_Alex/blob/develop/examples/img/dashboard.gif" alt="Dashboard">
+Run
+```console
+$ optuna-dashboard sqlite:///db.sqlite3
+```
+# Road Map
+- [x] Feature Generation
+- [x] Save/Load and Predict on New Samples
+- [x] Advanced Logging
+- [x] Add opt Pruners
+- [ ] Docs Site
+- [ ] DL Encoders
+- [ ] Add More libs (NNs)
+- [ ] Multiclass Classification
+- [ ] Build pipelines
+# Contact
+[Telegram Group](https://t.me/automlalex)
+
+%package -n python3-automl-alex
+Summary: State-of-the art Automated Machine Learning python library for Tabular Data
+Provides: python-automl-alex
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-automl-alex
+<p align="center"> State-of-the art Automated Machine Learning python library for Tabular Data</p>
+## Works with Tasks:
+- [x] Binary Classification
+- [x] Regression
+- [ ] Multiclass Classification (in progress...)
+### Benchmark Results
+<img width=800 src="https://github.com/Alex-Lekov/AutoML-Benchmark/blob/master/img/Total_SUM.png" alt="bench">
+The bigger, the better
+From [AutoML-Benchmark](https://github.com/Alex-Lekov/AutoML-Benchmark/)
+### Scheme
+<img width=800 src="https://github.com/Alex-Lekov/AutoML_Alex/blob/develop/examples/img/shema.png" alt="scheme">
+# Features
+- Automated Data Clean (Auto Clean)
+- Automated **Feature Engineering** (Auto FE)
+- Smart Hyperparameter Optimization (HPO)
+- Feature Generation
+- Feature Selection
+- Models Selection
+- Cross Validation
+- Optimization Timelimit and EarlyStoping
+- Save and Load (Predict new data)
+# Installation
+```python
+pip install automl-alex
+```
+# Docs
+[DocPage](https://alex-lekov.github.io/AutoML_Alex/)
+# 🚀 Examples
+Classifier:
+```python
+from automl_alex import AutoMLClassifier
+model = AutoMLClassifier()
+model.fit(X_train, y_train, timeout=600)
+predicts = model.predict(X_test)
+```
+Regression:
+```python
+from automl_alex import AutoMLRegressor
+model = AutoMLRegressor()
+model.fit(X_train, y_train, timeout=600)
+predicts = model.predict(X_test)
+```
+DataPrepare:
+```python
+from automl_alex import DataPrepare
+de = DataPrepare()
+X_train = de.fit_transform(X_train)
+X_test = de.transform(X_test)
+```
+Simple Models Wrapper:
+```python
+from automl_alex import LightGBMClassifier
+model = LightGBMClassifier()
+model.fit(X_train, y_train)
+predicts = model.predict_proba(X_test)
+model.opt(X_train, y_train,
+ timeout=600, # optimization time in seconds,
+ )
+predicts = model.predict_proba(X_test)
+```
+More examples in the folder ./examples:
+- [01_Quick_Start.ipynb](https://github.com/Alex-Lekov/AutoML_Alex/blob/master/examples/01_Quick_Start.ipynb) [![Open in Colab](https://colab.research.google.com/assets/colab-badge.svg)](http://colab.research.google.com/github/Alex-Lekov/AutoML_Alex/blob/master/examples/01_Quick_Start.ipynb)
+- [02_Data_Cleaning_and_Encoding_(DataPrepare).ipynb](https://github.com/Alex-Lekov/AutoML_Alex/blob/master/examples/02_Data_Cleaning_and_Encoding_(DataPrepare).ipynb) [![Open in Colab](https://colab.research.google.com/assets/colab-badge.svg)](http://colab.research.google.com/github/Alex-Lekov/AutoML_Alex/blob/master/examples/02_Data_Cleaning_and_Encoding_(DataPrepare).ipynb)
+- [03_Models.ipynb](https://github.com/Alex-Lekov/AutoML_Alex/blob/master/examples/03_Models.ipynb) [![Open in Colab](https://colab.research.google.com/assets/colab-badge.svg)](http://colab.research.google.com/github/Alex-Lekov/AutoML_Alex/blob/master/examples/03_Models.ipynb)
+- [04_ModelsReview.ipynb](https://github.com/Alex-Lekov/AutoML_Alex/blob/master/examples/04_ModelsReview.ipynb) [![Open in Colab](https://colab.research.google.com/assets/colab-badge.svg)](http://colab.research.google.com/github/Alex-Lekov/AutoML_Alex/blob/master/examples/04_ModelsReview.ipynb)
+- [05_BestSingleModel.ipynb](https://github.com/Alex-Lekov/AutoML_Alex/blob/master/examples/05_BestSingleModel.ipynb) [![Open in Colab](https://colab.research.google.com/assets/colab-badge.svg)](http://colab.research.google.com/github/Alex-Lekov/AutoML_Alex/blob/master/examples/05_BestSingleModel.ipynb)
+- [Production Docker template](https://github.com/Alex-Lekov/AutoML_Alex/blob/master/examples/prod_sample)
+# What's inside
+It integrates many popular frameworks:
+- scikit-learn
+- XGBoost
+- LightGBM
+- CatBoost
+- Optuna
+- ...
+# Works with Features
+- [x] Categorical Features
+- [x] Numerical Features
+- [x] Binary Features
+- [ ] Text
+- [ ] Datetime
+- [ ] Timeseries
+- [ ] Image
+# Note
+- **With a large dataset, a lot of memory is required!**
+Library creates many new features. If you have a large dataset with a large number of features (more than 100), you may need a lot of memory.
+# Realtime Dashboard
+Works with [optuna-dashboard](https://github.com/optuna/optuna-dashboard)
+<img width=800 src="https://github.com/Alex-Lekov/AutoML_Alex/blob/develop/examples/img/dashboard.gif" alt="Dashboard">
+Run
+```console
+$ optuna-dashboard sqlite:///db.sqlite3
+```
+# Road Map
+- [x] Feature Generation
+- [x] Save/Load and Predict on New Samples
+- [x] Advanced Logging
+- [x] Add opt Pruners
+- [ ] Docs Site
+- [ ] DL Encoders
+- [ ] Add More libs (NNs)
+- [ ] Multiclass Classification
+- [ ] Build pipelines
+# Contact
+[Telegram Group](https://t.me/automlalex)
+
+%package help
+Summary: Development documents and examples for automl-alex
+Provides: python3-automl-alex-doc
+%description help
+<p align="center"> State-of-the art Automated Machine Learning python library for Tabular Data</p>
+## Works with Tasks:
+- [x] Binary Classification
+- [x] Regression
+- [ ] Multiclass Classification (in progress...)
+### Benchmark Results
+<img width=800 src="https://github.com/Alex-Lekov/AutoML-Benchmark/blob/master/img/Total_SUM.png" alt="bench">
+The bigger, the better
+From [AutoML-Benchmark](https://github.com/Alex-Lekov/AutoML-Benchmark/)
+### Scheme
+<img width=800 src="https://github.com/Alex-Lekov/AutoML_Alex/blob/develop/examples/img/shema.png" alt="scheme">
+# Features
+- Automated Data Clean (Auto Clean)
+- Automated **Feature Engineering** (Auto FE)
+- Smart Hyperparameter Optimization (HPO)
+- Feature Generation
+- Feature Selection
+- Models Selection
+- Cross Validation
+- Optimization Timelimit and EarlyStoping
+- Save and Load (Predict new data)
+# Installation
+```python
+pip install automl-alex
+```
+# Docs
+[DocPage](https://alex-lekov.github.io/AutoML_Alex/)
+# 🚀 Examples
+Classifier:
+```python
+from automl_alex import AutoMLClassifier
+model = AutoMLClassifier()
+model.fit(X_train, y_train, timeout=600)
+predicts = model.predict(X_test)
+```
+Regression:
+```python
+from automl_alex import AutoMLRegressor
+model = AutoMLRegressor()
+model.fit(X_train, y_train, timeout=600)
+predicts = model.predict(X_test)
+```
+DataPrepare:
+```python
+from automl_alex import DataPrepare
+de = DataPrepare()
+X_train = de.fit_transform(X_train)
+X_test = de.transform(X_test)
+```
+Simple Models Wrapper:
+```python
+from automl_alex import LightGBMClassifier
+model = LightGBMClassifier()
+model.fit(X_train, y_train)
+predicts = model.predict_proba(X_test)
+model.opt(X_train, y_train,
+ timeout=600, # optimization time in seconds,
+ )
+predicts = model.predict_proba(X_test)
+```
+More examples in the folder ./examples:
+- [01_Quick_Start.ipynb](https://github.com/Alex-Lekov/AutoML_Alex/blob/master/examples/01_Quick_Start.ipynb) [![Open in Colab](https://colab.research.google.com/assets/colab-badge.svg)](http://colab.research.google.com/github/Alex-Lekov/AutoML_Alex/blob/master/examples/01_Quick_Start.ipynb)
+- [02_Data_Cleaning_and_Encoding_(DataPrepare).ipynb](https://github.com/Alex-Lekov/AutoML_Alex/blob/master/examples/02_Data_Cleaning_and_Encoding_(DataPrepare).ipynb) [![Open in Colab](https://colab.research.google.com/assets/colab-badge.svg)](http://colab.research.google.com/github/Alex-Lekov/AutoML_Alex/blob/master/examples/02_Data_Cleaning_and_Encoding_(DataPrepare).ipynb)
+- [03_Models.ipynb](https://github.com/Alex-Lekov/AutoML_Alex/blob/master/examples/03_Models.ipynb) [![Open in Colab](https://colab.research.google.com/assets/colab-badge.svg)](http://colab.research.google.com/github/Alex-Lekov/AutoML_Alex/blob/master/examples/03_Models.ipynb)
+- [04_ModelsReview.ipynb](https://github.com/Alex-Lekov/AutoML_Alex/blob/master/examples/04_ModelsReview.ipynb) [![Open in Colab](https://colab.research.google.com/assets/colab-badge.svg)](http://colab.research.google.com/github/Alex-Lekov/AutoML_Alex/blob/master/examples/04_ModelsReview.ipynb)
+- [05_BestSingleModel.ipynb](https://github.com/Alex-Lekov/AutoML_Alex/blob/master/examples/05_BestSingleModel.ipynb) [![Open in Colab](https://colab.research.google.com/assets/colab-badge.svg)](http://colab.research.google.com/github/Alex-Lekov/AutoML_Alex/blob/master/examples/05_BestSingleModel.ipynb)
+- [Production Docker template](https://github.com/Alex-Lekov/AutoML_Alex/blob/master/examples/prod_sample)
+# What's inside
+It integrates many popular frameworks:
+- scikit-learn
+- XGBoost
+- LightGBM
+- CatBoost
+- Optuna
+- ...
+# Works with Features
+- [x] Categorical Features
+- [x] Numerical Features
+- [x] Binary Features
+- [ ] Text
+- [ ] Datetime
+- [ ] Timeseries
+- [ ] Image
+# Note
+- **With a large dataset, a lot of memory is required!**
+Library creates many new features. If you have a large dataset with a large number of features (more than 100), you may need a lot of memory.
+# Realtime Dashboard
+Works with [optuna-dashboard](https://github.com/optuna/optuna-dashboard)
+<img width=800 src="https://github.com/Alex-Lekov/AutoML_Alex/blob/develop/examples/img/dashboard.gif" alt="Dashboard">
+Run
+```console
+$ optuna-dashboard sqlite:///db.sqlite3
+```
+# Road Map
+- [x] Feature Generation
+- [x] Save/Load and Predict on New Samples
+- [x] Advanced Logging
+- [x] Add opt Pruners
+- [ ] Docs Site
+- [ ] DL Encoders
+- [ ] Add More libs (NNs)
+- [ ] Multiclass Classification
+- [ ] Build pipelines
+# Contact
+[Telegram Group](https://t.me/automlalex)
+
+%prep
+%autosetup -n automl-alex-2023.3.11
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-automl-alex -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Thu May 18 2023 Python_Bot <Python_Bot@openeuler.org> - 2023.3.11-1
+- Package Spec generated