summaryrefslogtreecommitdiff
path: root/python-azure-cli-iot.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-azure-cli-iot.spec')
-rw-r--r--python-azure-cli-iot.spec80
1 files changed, 80 insertions, 0 deletions
diff --git a/python-azure-cli-iot.spec b/python-azure-cli-iot.spec
new file mode 100644
index 0000000..e364502
--- /dev/null
+++ b/python-azure-cli-iot.spec
@@ -0,0 +1,80 @@
+%global _empty_manifest_terminate_build 0
+Name: python-azure-cli-iot
+Version: 0.3.11
+Release: 1
+Summary: Microsoft Azure Command-Line Tools IoT Command Module
+License: MIT
+URL: https://github.com/Azure/azure-cli
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/2d/86/4742a7b97bdabfaf18adae9588cbf35be31d738fafb7bf105c75ede93416/azure-cli-iot-0.3.11.tar.gz
+BuildArch: noarch
+
+Requires: python3-azure-mgmt-iothub
+Requires: python3-azure-mgmt-iothubprovisioningservices
+Requires: python3-pyOpenSSL
+Requires: python3-azure-cli-core
+Requires: python3-azure-cli-command-modules-nspkg
+
+%description
+This package is for the 'iot' module.
+i.e. 'az iot'
+
+%package -n python3-azure-cli-iot
+Summary: Microsoft Azure Command-Line Tools IoT Command Module
+Provides: python-azure-cli-iot
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-azure-cli-iot
+This package is for the 'iot' module.
+i.e. 'az iot'
+
+%package help
+Summary: Development documents and examples for azure-cli-iot
+Provides: python3-azure-cli-iot-doc
+%description help
+This package is for the 'iot' module.
+i.e. 'az iot'
+
+%prep
+%autosetup -n azure-cli-iot-0.3.11
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-azure-cli-iot -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed Apr 12 2023 Python_Bot <Python_Bot@openeuler.org> - 0.3.11-1
+- Package Spec generated