summaryrefslogtreecommitdiff
path: root/python-azure-cli-network.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-12 06:41:33 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-12 06:41:33 +0000
commit9c0af3b5a3bf09d71b50830e21de3cd294235919 (patch)
tree3c1d55bc22e3142a5721bd56ee5f97b7a6d5cd5c /python-azure-cli-network.spec
parent99f3caa2a990aba8655b254de71aed0c6a746a5b (diff)
automatic import of python-azure-cli-networkopeneuler20.03
Diffstat (limited to 'python-azure-cli-network.spec')
-rw-r--r--python-azure-cli-network.spec80
1 files changed, 80 insertions, 0 deletions
diff --git a/python-azure-cli-network.spec b/python-azure-cli-network.spec
new file mode 100644
index 0000000..8f75d90
--- /dev/null
+++ b/python-azure-cli-network.spec
@@ -0,0 +1,80 @@
+%global _empty_manifest_terminate_build 0
+Name: python-azure-cli-network
+Version: 2.5.2
+Release: 1
+Summary: Microsoft Azure Command-Line Tools Network Command Module
+License: MIT
+URL: https://github.com/Azure/azure-cli
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/9f/89/53ffd4fd64798c8176ae92bd58c66cd4bfcf9b969fb746312fc291a9d65a/azure-cli-network-2.5.2.tar.gz
+BuildArch: noarch
+
+Requires: python3-azure-mgmt-network
+Requires: python3-azure-mgmt-trafficmanager
+Requires: python3-azure-mgmt-dns
+Requires: python3-azure-cli-core
+Requires: python3-azure-cli-command-modules-nspkg
+
+%description
+This package is for the 'network' module.
+i.e. 'az network'
+
+%package -n python3-azure-cli-network
+Summary: Microsoft Azure Command-Line Tools Network Command Module
+Provides: python-azure-cli-network
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-azure-cli-network
+This package is for the 'network' module.
+i.e. 'az network'
+
+%package help
+Summary: Development documents and examples for azure-cli-network
+Provides: python3-azure-cli-network-doc
+%description help
+This package is for the 'network' module.
+i.e. 'az network'
+
+%prep
+%autosetup -n azure-cli-network-2.5.2
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-azure-cli-network -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed Apr 12 2023 Python_Bot <Python_Bot@openeuler.org> - 2.5.2-1
+- Package Spec generated