summaryrefslogtreecommitdiff
path: root/python-azure-databricks-api.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-10 06:30:17 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-10 06:30:17 +0000
commit86ef0ace5ccc51d89c9aa7058906bcd74d163ae5 (patch)
tree7a7d58ba2fdc9d7cd8a7dcfafbcbcb12943bf2ab /python-azure-databricks-api.spec
parent5c510f4d03574f992314d311b09e84c75103b7b4 (diff)
automatic import of python-azure-databricks-api
Diffstat (limited to 'python-azure-databricks-api.spec')
-rw-r--r--python-azure-databricks-api.spec229
1 files changed, 229 insertions, 0 deletions
diff --git a/python-azure-databricks-api.spec b/python-azure-databricks-api.spec
new file mode 100644
index 0000000..cab1b71
--- /dev/null
+++ b/python-azure-databricks-api.spec
@@ -0,0 +1,229 @@
+%global _empty_manifest_terminate_build 0
+Name: python-azure-databricks-api
+Version: 0.6.2
+Release: 1
+Summary: A wrapper for the Azure Databricks REST API
+License: MIT
+URL: http://github.com/ezwiefel/azure-databricks-api
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/58/0c/27ec7e19163133e146373b960e2a1507800f88bf1e013a6c392a6d688a53/azure-databricks-api-0.6.2.tar.gz
+BuildArch: noarch
+
+Requires: python3-requests
+
+%description
+# Azure Databricks API Wrapper
+A Python, object-oriented wrapper for the [Azure Databricks REST API 2.0](https://docs.azuredatabricks.net/api/latest/index.html)
+
+[![GitHub Workflow Status (branch)](https://img.shields.io/github/workflow/status/ezwiefel/azure-databricks-api/Unit%20Tests/main?style=for-the-badge)](https://github.com/ezwiefel/azure-databricks-api/actions?query=workflow%3A%22Unit+Tests%22)
+[![Coveralls github](https://img.shields.io/coveralls/github/ezwiefel/azure-databricks-api?style=for-the-badge)](https://coveralls.io/github/ezwiefel/azure-databricks-api)
+[![PyPI](https://img.shields.io/pypi/v/azure-databricks-api?style=for-the-badge)](https://pypi.org/project/azure-databricks-api/)
+[![PyPI - Downloads](https://img.shields.io/pypi/dm/azure-databricks-api?label=PIP%20DOWNLOADS&style=for-the-badge)](https://pypi.org/project/azure-databricks-api/)
+[![GitHub](https://img.shields.io/github/license/ezwiefel/azure-databricks-api?style=for-the-badge)](https://github.com/ezwiefel/azure-databricks-api/blob/main/LICENSE)
+
+### Installation
+This package is pip installable.
+```bash
+pip install azure-databricks-api
+```
+
+### Implemented APIs
+As of June 25th, 2020 there are 12 different services available in the Azure Databricks API. Currently, the following services are supported by the Azure Databricks API Wrapper.
+* [x] Clusters
+* [ ] Cluster Policies _(Preview)_
+* [x] DBFS
+* [x] Groups _(Must be Databricks admin)_
+* [ ] Instance Pools
+* [ ] Jobs
+* [X] Libraries
+* [ ] MLflow
+* [ ] SCIM _(Preview)_
+* [ ] Secrets
+* [x] Token
+* [x] Workspace
+
+
+### Client Instantiation
+To create the client object, you pass the Azure region your workspace is located in and the [generated Personal Access Token](https://docs.databricks.com/api/latest/authentication.html#generate-a-token)
+```python
+from azure_databricks_api import AzureDatabricksRESTClient
+
+azure_region = '[INSERT YOUR AZURE REGION HERE]'
+token = '[INSERT YOUR PERSONAL ACCESS TOKEN]'
+
+client = AzureDatabricksRESTClient(region=azure_region, token=token)
+```
+
+### Clusters Client Usage
+The services above are implemented as children objects of the client. For example, to pin a cluster, you can either pass the `cluster_name` or `cluster_id` to the `pin()` method:
+```python
+client.clusters.pin(cluster_name='test_cluster_name')
+```
+
+The other services are implemented similarly. (e.g. `client.tokens` or `client.groups`)
+
+
+
+
+
+%package -n python3-azure-databricks-api
+Summary: A wrapper for the Azure Databricks REST API
+Provides: python-azure-databricks-api
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-azure-databricks-api
+# Azure Databricks API Wrapper
+A Python, object-oriented wrapper for the [Azure Databricks REST API 2.0](https://docs.azuredatabricks.net/api/latest/index.html)
+
+[![GitHub Workflow Status (branch)](https://img.shields.io/github/workflow/status/ezwiefel/azure-databricks-api/Unit%20Tests/main?style=for-the-badge)](https://github.com/ezwiefel/azure-databricks-api/actions?query=workflow%3A%22Unit+Tests%22)
+[![Coveralls github](https://img.shields.io/coveralls/github/ezwiefel/azure-databricks-api?style=for-the-badge)](https://coveralls.io/github/ezwiefel/azure-databricks-api)
+[![PyPI](https://img.shields.io/pypi/v/azure-databricks-api?style=for-the-badge)](https://pypi.org/project/azure-databricks-api/)
+[![PyPI - Downloads](https://img.shields.io/pypi/dm/azure-databricks-api?label=PIP%20DOWNLOADS&style=for-the-badge)](https://pypi.org/project/azure-databricks-api/)
+[![GitHub](https://img.shields.io/github/license/ezwiefel/azure-databricks-api?style=for-the-badge)](https://github.com/ezwiefel/azure-databricks-api/blob/main/LICENSE)
+
+### Installation
+This package is pip installable.
+```bash
+pip install azure-databricks-api
+```
+
+### Implemented APIs
+As of June 25th, 2020 there are 12 different services available in the Azure Databricks API. Currently, the following services are supported by the Azure Databricks API Wrapper.
+* [x] Clusters
+* [ ] Cluster Policies _(Preview)_
+* [x] DBFS
+* [x] Groups _(Must be Databricks admin)_
+* [ ] Instance Pools
+* [ ] Jobs
+* [X] Libraries
+* [ ] MLflow
+* [ ] SCIM _(Preview)_
+* [ ] Secrets
+* [x] Token
+* [x] Workspace
+
+
+### Client Instantiation
+To create the client object, you pass the Azure region your workspace is located in and the [generated Personal Access Token](https://docs.databricks.com/api/latest/authentication.html#generate-a-token)
+```python
+from azure_databricks_api import AzureDatabricksRESTClient
+
+azure_region = '[INSERT YOUR AZURE REGION HERE]'
+token = '[INSERT YOUR PERSONAL ACCESS TOKEN]'
+
+client = AzureDatabricksRESTClient(region=azure_region, token=token)
+```
+
+### Clusters Client Usage
+The services above are implemented as children objects of the client. For example, to pin a cluster, you can either pass the `cluster_name` or `cluster_id` to the `pin()` method:
+```python
+client.clusters.pin(cluster_name='test_cluster_name')
+```
+
+The other services are implemented similarly. (e.g. `client.tokens` or `client.groups`)
+
+
+
+
+
+%package help
+Summary: Development documents and examples for azure-databricks-api
+Provides: python3-azure-databricks-api-doc
+%description help
+# Azure Databricks API Wrapper
+A Python, object-oriented wrapper for the [Azure Databricks REST API 2.0](https://docs.azuredatabricks.net/api/latest/index.html)
+
+[![GitHub Workflow Status (branch)](https://img.shields.io/github/workflow/status/ezwiefel/azure-databricks-api/Unit%20Tests/main?style=for-the-badge)](https://github.com/ezwiefel/azure-databricks-api/actions?query=workflow%3A%22Unit+Tests%22)
+[![Coveralls github](https://img.shields.io/coveralls/github/ezwiefel/azure-databricks-api?style=for-the-badge)](https://coveralls.io/github/ezwiefel/azure-databricks-api)
+[![PyPI](https://img.shields.io/pypi/v/azure-databricks-api?style=for-the-badge)](https://pypi.org/project/azure-databricks-api/)
+[![PyPI - Downloads](https://img.shields.io/pypi/dm/azure-databricks-api?label=PIP%20DOWNLOADS&style=for-the-badge)](https://pypi.org/project/azure-databricks-api/)
+[![GitHub](https://img.shields.io/github/license/ezwiefel/azure-databricks-api?style=for-the-badge)](https://github.com/ezwiefel/azure-databricks-api/blob/main/LICENSE)
+
+### Installation
+This package is pip installable.
+```bash
+pip install azure-databricks-api
+```
+
+### Implemented APIs
+As of June 25th, 2020 there are 12 different services available in the Azure Databricks API. Currently, the following services are supported by the Azure Databricks API Wrapper.
+* [x] Clusters
+* [ ] Cluster Policies _(Preview)_
+* [x] DBFS
+* [x] Groups _(Must be Databricks admin)_
+* [ ] Instance Pools
+* [ ] Jobs
+* [X] Libraries
+* [ ] MLflow
+* [ ] SCIM _(Preview)_
+* [ ] Secrets
+* [x] Token
+* [x] Workspace
+
+
+### Client Instantiation
+To create the client object, you pass the Azure region your workspace is located in and the [generated Personal Access Token](https://docs.databricks.com/api/latest/authentication.html#generate-a-token)
+```python
+from azure_databricks_api import AzureDatabricksRESTClient
+
+azure_region = '[INSERT YOUR AZURE REGION HERE]'
+token = '[INSERT YOUR PERSONAL ACCESS TOKEN]'
+
+client = AzureDatabricksRESTClient(region=azure_region, token=token)
+```
+
+### Clusters Client Usage
+The services above are implemented as children objects of the client. For example, to pin a cluster, you can either pass the `cluster_name` or `cluster_id` to the `pin()` method:
+```python
+client.clusters.pin(cluster_name='test_cluster_name')
+```
+
+The other services are implemented similarly. (e.g. `client.tokens` or `client.groups`)
+
+
+
+
+
+%prep
+%autosetup -n azure-databricks-api-0.6.2
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-azure-databricks-api -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 0.6.2-1
+- Package Spec generated