summaryrefslogtreecommitdiff
path: root/python-azure-iot-hub.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-azure-iot-hub.spec')
-rw-r--r--python-azure-iot-hub.spec177
1 files changed, 177 insertions, 0 deletions
diff --git a/python-azure-iot-hub.spec b/python-azure-iot-hub.spec
new file mode 100644
index 0000000..a21fda6
--- /dev/null
+++ b/python-azure-iot-hub.spec
@@ -0,0 +1,177 @@
+%global _empty_manifest_terminate_build 0
+Name: python-azure-iot-hub
+Version: 2.6.1
+Release: 1
+Summary: Microsoft Azure IoTHub Service Library
+License: MIT License
+URL: https://github.com/Azure/azure-iot-hub-python/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/47/77/df28c97d666a7eaf6f041047843de1ba2730af8de85e0e308643ddef5fdf/azure-iot-hub-2.6.1.tar.gz
+BuildArch: noarch
+
+Requires: python3-msrest
+Requires: python3-uamqp
+Requires: python3-azure-core
+
+%description
+# Azure IoTHub Service SDK
+
+The Azure IoTHub Service SDK for Python provides functionality for communicating with the Azure IoT Hub.
+
+## Features
+
+The SDK provides the following clients:
+
+* ### IoT Hub Registry Manager
+
+ * Provides CRUD operations for device on IoTHub
+ * Get statistics about the IoTHub service and devices
+
+## Installation
+
+```python
+pip install azure-iot-hub
+```
+
+## IoTHub Samples
+
+Check out the [samples repository](https://github.com/Azure/azure-iot-hub-python/tree/main/samples) for more detailed samples
+
+## Getting help and finding API docs
+
+
+API documentation for this package is available via [Microsoft Docs](https://docs.microsoft.com/python/api/azure-iot-hub/azure.iot.hub?view=azure-python)
+
+Additionally, the SDK makes use of docstrings which means you can find API documentation directly through Python with use of the [help](https://docs.python.org/3/library/functions.html#help) command:
+
+```python
+>>> from azure.iot.hub import IoTHubRegistryManager
+>>> help(IoTHubRegistryManager)
+```
+
+
+%package -n python3-azure-iot-hub
+Summary: Microsoft Azure IoTHub Service Library
+Provides: python-azure-iot-hub
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-azure-iot-hub
+# Azure IoTHub Service SDK
+
+The Azure IoTHub Service SDK for Python provides functionality for communicating with the Azure IoT Hub.
+
+## Features
+
+The SDK provides the following clients:
+
+* ### IoT Hub Registry Manager
+
+ * Provides CRUD operations for device on IoTHub
+ * Get statistics about the IoTHub service and devices
+
+## Installation
+
+```python
+pip install azure-iot-hub
+```
+
+## IoTHub Samples
+
+Check out the [samples repository](https://github.com/Azure/azure-iot-hub-python/tree/main/samples) for more detailed samples
+
+## Getting help and finding API docs
+
+
+API documentation for this package is available via [Microsoft Docs](https://docs.microsoft.com/python/api/azure-iot-hub/azure.iot.hub?view=azure-python)
+
+Additionally, the SDK makes use of docstrings which means you can find API documentation directly through Python with use of the [help](https://docs.python.org/3/library/functions.html#help) command:
+
+```python
+>>> from azure.iot.hub import IoTHubRegistryManager
+>>> help(IoTHubRegistryManager)
+```
+
+
+%package help
+Summary: Development documents and examples for azure-iot-hub
+Provides: python3-azure-iot-hub-doc
+%description help
+# Azure IoTHub Service SDK
+
+The Azure IoTHub Service SDK for Python provides functionality for communicating with the Azure IoT Hub.
+
+## Features
+
+The SDK provides the following clients:
+
+* ### IoT Hub Registry Manager
+
+ * Provides CRUD operations for device on IoTHub
+ * Get statistics about the IoTHub service and devices
+
+## Installation
+
+```python
+pip install azure-iot-hub
+```
+
+## IoTHub Samples
+
+Check out the [samples repository](https://github.com/Azure/azure-iot-hub-python/tree/main/samples) for more detailed samples
+
+## Getting help and finding API docs
+
+
+API documentation for this package is available via [Microsoft Docs](https://docs.microsoft.com/python/api/azure-iot-hub/azure.iot.hub?view=azure-python)
+
+Additionally, the SDK makes use of docstrings which means you can find API documentation directly through Python with use of the [help](https://docs.python.org/3/library/functions.html#help) command:
+
+```python
+>>> from azure.iot.hub import IoTHubRegistryManager
+>>> help(IoTHubRegistryManager)
+```
+
+
+%prep
+%autosetup -n azure-iot-hub-2.6.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-azure-iot-hub -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 2.6.1-1
+- Package Spec generated