summaryrefslogtreecommitdiff
path: root/python-azure-mgmt-managementpartner.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-10 09:52:23 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-10 09:52:23 +0000
commit4e92a1fb7582d00f6d54df35baf95fedd64065dc (patch)
treecfc9c39bd1367ce6e1d81d8d0662639c137ede2b /python-azure-mgmt-managementpartner.spec
parent4c35c1bf383b9b74b212bc0e696ff6324178a104 (diff)
automatic import of python-azure-mgmt-managementpartner
Diffstat (limited to 'python-azure-mgmt-managementpartner.spec')
-rw-r--r--python-azure-mgmt-managementpartner.spec331
1 files changed, 331 insertions, 0 deletions
diff --git a/python-azure-mgmt-managementpartner.spec b/python-azure-mgmt-managementpartner.spec
new file mode 100644
index 0000000..949b005
--- /dev/null
+++ b/python-azure-mgmt-managementpartner.spec
@@ -0,0 +1,331 @@
+%global _empty_manifest_terminate_build 0
+Name: python-azure-mgmt-managementpartner
+Version: 1.0.0
+Release: 1
+Summary: Microsoft Azure ManagementPartner Management Client Library for Python
+License: MIT License
+URL: https://github.com/Azure/azure-sdk-for-python
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/f8/93/92d7843ce177c43cee392913a484ab21409dcadf66eabcef0a5aa8debafe/azure-mgmt-managementpartner-1.0.0.zip
+BuildArch: noarch
+
+Requires: python3-msrest
+Requires: python3-azure-common
+Requires: python3-azure-mgmt-core
+Requires: python3-azure-mgmt-nspkg
+
+%description
+## Microsoft Azure SDK for Python
+
+This is the Microsoft Azure ManagementPartner Management Client Library.
+
+Azure Resource Manager (ARM) is the next generation of management APIs
+that replace the old Azure Service Management (ASM).
+
+This package has been tested with Python 2.7, 3.4, 3.5, 3.6 and 3.7.
+
+For the older Azure Service Management (ASM) libraries, see
+[azure-servicemanagement-legacy](https://pypi.python.org/pypi/azure-servicemanagement-legacy)
+library.
+
+For a more complete set of Azure libraries, see the
+[azure sdk python release](https://aka.ms/azsdk/python/all).
+
+## Usage
+
+
+To learn how to use this package, see the [quickstart guide](https://aka.ms/azsdk/python/mgmt)
+
+
+
+For docs and references, see [Python SDK References](https://docs.microsoft.com/python/api/overview/azure/)
+Code samples for this package can be found at [Management Partner Management](https://docs.microsoft.com/samples/browse/?languages=python&term=Getting%20started%20-%20Managing&terms=Getting%20started%20-%20Managing) on docs.microsoft.com.
+Additional code samples for different Azure services are available at [Samples Repo](https://aka.ms/azsdk/python/mgmt/samples)
+
+
+## Provide Feedback
+
+If you encounter any bugs or have suggestions, please file an issue in
+the [Issues](https://github.com/Azure/azure-sdk-for-python/issues)
+section of the project.
+
+![image](https://azure-sdk-impressions.azurewebsites.net/api/impressions/azure-sdk-for-python%2Fazure-mgmt-managementpartner%2FREADME.png)
+
+
+# Release History
+
+## 1.0.0 (2021-05-21)
+
+- GA release
+
+## 1.0.0b1 (2020-12-10)
+
+This is beta preview version.
+
+This version uses a next-generation code generator that introduces important breaking changes, but also important new features (like unified authentication and async programming).
+
+**General breaking changes**
+
+- Credential system has been completly revamped:
+
+ - `azure.common.credentials` or `msrestazure.azure_active_directory` instances are no longer supported, use the `azure-identity` classes instead: https://pypi.org/project/azure-identity/
+ - `credentials` parameter has been renamed `credential`
+
+- The `config` attribute no longer exists on a client, configuration should be passed as kwarg. Example: `MyClient(credential, subscription_id, enable_logging=True)`. For a complete set of
+ supported options, see the [parameters accept in init documentation of azure-core](https://github.com/Azure/azure-sdk-for-python/blob/master/sdk/core/azure-core/CLIENT_LIBRARY_DEVELOPER.md#available-policies)
+- You can't import a `version` module anymore, use `__version__` instead
+- Operations that used to return a `msrest.polling.LROPoller` now returns a `azure.core.polling.LROPoller` and are prefixed with `begin_`.
+- Exceptions tree have been simplified and most exceptions are now `azure.core.exceptions.HttpResponseError` (`CloudError` has been removed).
+- Most of the operation kwarg have changed. Some of the most noticeable:
+
+ - `raw` has been removed. Equivalent feature can be found using `cls`, a callback that will give access to internal HTTP response for advanced user
+ - For a complete set of
+ supported options, see the [parameters accept in Request documentation of azure-core](https://github.com/Azure/azure-sdk-for-python/blob/master/sdk/core/azure-core/CLIENT_LIBRARY_DEVELOPER.md#available-policies)
+
+**General new features**
+
+- Type annotations support using `typing`. SDKs are mypy ready.
+- This client has now stable and official support for async. Check the `aio` namespace of your package to find the async client.
+- This client now support natively tracing library like OpenCensus or OpenTelemetry. See this [tracing quickstart](https://github.com/Azure/azure-sdk-for-python/tree/master/sdk/core/azure-core-tracing-opentelemetry) for an overview.
+
+## 0.1.1 (2019-05-17)
+
+**Features**
+
+ - Model PartnerResponse has a new parameter partner_name
+ - Added operation group PartnersOperations
+
+## 0.1.0 (2018-02-06)
+
+ - Initial Release
+
+
+
+
+%package -n python3-azure-mgmt-managementpartner
+Summary: Microsoft Azure ManagementPartner Management Client Library for Python
+Provides: python-azure-mgmt-managementpartner
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-azure-mgmt-managementpartner
+## Microsoft Azure SDK for Python
+
+This is the Microsoft Azure ManagementPartner Management Client Library.
+
+Azure Resource Manager (ARM) is the next generation of management APIs
+that replace the old Azure Service Management (ASM).
+
+This package has been tested with Python 2.7, 3.4, 3.5, 3.6 and 3.7.
+
+For the older Azure Service Management (ASM) libraries, see
+[azure-servicemanagement-legacy](https://pypi.python.org/pypi/azure-servicemanagement-legacy)
+library.
+
+For a more complete set of Azure libraries, see the
+[azure sdk python release](https://aka.ms/azsdk/python/all).
+
+## Usage
+
+
+To learn how to use this package, see the [quickstart guide](https://aka.ms/azsdk/python/mgmt)
+
+
+
+For docs and references, see [Python SDK References](https://docs.microsoft.com/python/api/overview/azure/)
+Code samples for this package can be found at [Management Partner Management](https://docs.microsoft.com/samples/browse/?languages=python&term=Getting%20started%20-%20Managing&terms=Getting%20started%20-%20Managing) on docs.microsoft.com.
+Additional code samples for different Azure services are available at [Samples Repo](https://aka.ms/azsdk/python/mgmt/samples)
+
+
+## Provide Feedback
+
+If you encounter any bugs or have suggestions, please file an issue in
+the [Issues](https://github.com/Azure/azure-sdk-for-python/issues)
+section of the project.
+
+![image](https://azure-sdk-impressions.azurewebsites.net/api/impressions/azure-sdk-for-python%2Fazure-mgmt-managementpartner%2FREADME.png)
+
+
+# Release History
+
+## 1.0.0 (2021-05-21)
+
+- GA release
+
+## 1.0.0b1 (2020-12-10)
+
+This is beta preview version.
+
+This version uses a next-generation code generator that introduces important breaking changes, but also important new features (like unified authentication and async programming).
+
+**General breaking changes**
+
+- Credential system has been completly revamped:
+
+ - `azure.common.credentials` or `msrestazure.azure_active_directory` instances are no longer supported, use the `azure-identity` classes instead: https://pypi.org/project/azure-identity/
+ - `credentials` parameter has been renamed `credential`
+
+- The `config` attribute no longer exists on a client, configuration should be passed as kwarg. Example: `MyClient(credential, subscription_id, enable_logging=True)`. For a complete set of
+ supported options, see the [parameters accept in init documentation of azure-core](https://github.com/Azure/azure-sdk-for-python/blob/master/sdk/core/azure-core/CLIENT_LIBRARY_DEVELOPER.md#available-policies)
+- You can't import a `version` module anymore, use `__version__` instead
+- Operations that used to return a `msrest.polling.LROPoller` now returns a `azure.core.polling.LROPoller` and are prefixed with `begin_`.
+- Exceptions tree have been simplified and most exceptions are now `azure.core.exceptions.HttpResponseError` (`CloudError` has been removed).
+- Most of the operation kwarg have changed. Some of the most noticeable:
+
+ - `raw` has been removed. Equivalent feature can be found using `cls`, a callback that will give access to internal HTTP response for advanced user
+ - For a complete set of
+ supported options, see the [parameters accept in Request documentation of azure-core](https://github.com/Azure/azure-sdk-for-python/blob/master/sdk/core/azure-core/CLIENT_LIBRARY_DEVELOPER.md#available-policies)
+
+**General new features**
+
+- Type annotations support using `typing`. SDKs are mypy ready.
+- This client has now stable and official support for async. Check the `aio` namespace of your package to find the async client.
+- This client now support natively tracing library like OpenCensus or OpenTelemetry. See this [tracing quickstart](https://github.com/Azure/azure-sdk-for-python/tree/master/sdk/core/azure-core-tracing-opentelemetry) for an overview.
+
+## 0.1.1 (2019-05-17)
+
+**Features**
+
+ - Model PartnerResponse has a new parameter partner_name
+ - Added operation group PartnersOperations
+
+## 0.1.0 (2018-02-06)
+
+ - Initial Release
+
+
+
+
+%package help
+Summary: Development documents and examples for azure-mgmt-managementpartner
+Provides: python3-azure-mgmt-managementpartner-doc
+%description help
+## Microsoft Azure SDK for Python
+
+This is the Microsoft Azure ManagementPartner Management Client Library.
+
+Azure Resource Manager (ARM) is the next generation of management APIs
+that replace the old Azure Service Management (ASM).
+
+This package has been tested with Python 2.7, 3.4, 3.5, 3.6 and 3.7.
+
+For the older Azure Service Management (ASM) libraries, see
+[azure-servicemanagement-legacy](https://pypi.python.org/pypi/azure-servicemanagement-legacy)
+library.
+
+For a more complete set of Azure libraries, see the
+[azure sdk python release](https://aka.ms/azsdk/python/all).
+
+## Usage
+
+
+To learn how to use this package, see the [quickstart guide](https://aka.ms/azsdk/python/mgmt)
+
+
+
+For docs and references, see [Python SDK References](https://docs.microsoft.com/python/api/overview/azure/)
+Code samples for this package can be found at [Management Partner Management](https://docs.microsoft.com/samples/browse/?languages=python&term=Getting%20started%20-%20Managing&terms=Getting%20started%20-%20Managing) on docs.microsoft.com.
+Additional code samples for different Azure services are available at [Samples Repo](https://aka.ms/azsdk/python/mgmt/samples)
+
+
+## Provide Feedback
+
+If you encounter any bugs or have suggestions, please file an issue in
+the [Issues](https://github.com/Azure/azure-sdk-for-python/issues)
+section of the project.
+
+![image](https://azure-sdk-impressions.azurewebsites.net/api/impressions/azure-sdk-for-python%2Fazure-mgmt-managementpartner%2FREADME.png)
+
+
+# Release History
+
+## 1.0.0 (2021-05-21)
+
+- GA release
+
+## 1.0.0b1 (2020-12-10)
+
+This is beta preview version.
+
+This version uses a next-generation code generator that introduces important breaking changes, but also important new features (like unified authentication and async programming).
+
+**General breaking changes**
+
+- Credential system has been completly revamped:
+
+ - `azure.common.credentials` or `msrestazure.azure_active_directory` instances are no longer supported, use the `azure-identity` classes instead: https://pypi.org/project/azure-identity/
+ - `credentials` parameter has been renamed `credential`
+
+- The `config` attribute no longer exists on a client, configuration should be passed as kwarg. Example: `MyClient(credential, subscription_id, enable_logging=True)`. For a complete set of
+ supported options, see the [parameters accept in init documentation of azure-core](https://github.com/Azure/azure-sdk-for-python/blob/master/sdk/core/azure-core/CLIENT_LIBRARY_DEVELOPER.md#available-policies)
+- You can't import a `version` module anymore, use `__version__` instead
+- Operations that used to return a `msrest.polling.LROPoller` now returns a `azure.core.polling.LROPoller` and are prefixed with `begin_`.
+- Exceptions tree have been simplified and most exceptions are now `azure.core.exceptions.HttpResponseError` (`CloudError` has been removed).
+- Most of the operation kwarg have changed. Some of the most noticeable:
+
+ - `raw` has been removed. Equivalent feature can be found using `cls`, a callback that will give access to internal HTTP response for advanced user
+ - For a complete set of
+ supported options, see the [parameters accept in Request documentation of azure-core](https://github.com/Azure/azure-sdk-for-python/blob/master/sdk/core/azure-core/CLIENT_LIBRARY_DEVELOPER.md#available-policies)
+
+**General new features**
+
+- Type annotations support using `typing`. SDKs are mypy ready.
+- This client has now stable and official support for async. Check the `aio` namespace of your package to find the async client.
+- This client now support natively tracing library like OpenCensus or OpenTelemetry. See this [tracing quickstart](https://github.com/Azure/azure-sdk-for-python/tree/master/sdk/core/azure-core-tracing-opentelemetry) for an overview.
+
+## 0.1.1 (2019-05-17)
+
+**Features**
+
+ - Model PartnerResponse has a new parameter partner_name
+ - Added operation group PartnersOperations
+
+## 0.1.0 (2018-02-06)
+
+ - Initial Release
+
+
+
+
+%prep
+%autosetup -n azure-mgmt-managementpartner-1.0.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-azure-mgmt-managementpartner -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.0-1
+- Package Spec generated