summaryrefslogtreecommitdiff
path: root/python-bitcoin-utils.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-bitcoin-utils.spec')
-rw-r--r--python-bitcoin-utils.spec24
1 files changed, 12 insertions, 12 deletions
diff --git a/python-bitcoin-utils.spec b/python-bitcoin-utils.spec
index 49b1c8a..82355e3 100644
--- a/python-bitcoin-utils.spec
+++ b/python-bitcoin-utils.spec
@@ -1,17 +1,17 @@
%global _empty_manifest_terminate_build 0
Name: python-bitcoin-utils
-Version: 0.5.9
+Version: 0.6.1
Release: 1
Summary: Bitcoin utility functions
License: MIT
URL: https://github.com/karask/python-bitcoin-utils
-Source0: https://mirrors.nju.edu.cn/pypi/web/packages/e5/e6/eb21df365b2eeb3f29e39b3e69f3d7919ec10101e5de00649b1433b2386f/bitcoin-utils-0.5.9.tar.gz
+Source0: https://mirrors.aliyun.com/pypi/web/packages/92/de/d789bc10f87db19a03a7534acdcc53a42b97d65a6b7a1560be856707173d/bitcoin-utils-0.6.1.tar.gz
BuildArch: noarch
%description
This is a bitcoin library that provides tools/utilities to interact with the Bitcoin network. One of the primary goals of the library is to explain the low-level details of Bitcoin. The code is easy to read and properly documented explaining in detail all the thorny aspects of the implementation. It is a low-level library which assumes some high-level understanding of how Bitcoin works. In the future this might change.
-This is an early version of the library (v0.5.9) and currently, it supports private/public keys, all type of addresses and creation of any transaction (incl. segwit) with all SIGHASH types. All script op codes are included. Timelock and non-standard transactions are supported. Currently, a simple node proxy exists to enable easy calls to a Bitcoin core node. Extra functionality will be added continuously and the documentation will be improved as the work progresses.
+This is an early version of the library (v0.6.1) and currently, it supports private/public keys, all type of addresses and creation of any transaction, incl. segwit and taproot default key path, with all SIGHASH types. All script op codes are included. Timelocks and non-standard transactions are supported. Extra functionality will be added continuously and the documentation will be improved as the work progresses.
The API documentation can be build with Sphinx but is also available as a PDF for convenience. One can currently use the library for experimenting and learning the inner workings of Bitcoin. It is not meant for production yet and parts of the API might be updated with new versions.
Complementary to this library is a CC BY-SA 4.0 licensed `Bitcoin programming book <https://github.com/karask/bitcoin-textbook>`_.
@@ -23,7 +23,7 @@ BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-bitcoin-utils
This is a bitcoin library that provides tools/utilities to interact with the Bitcoin network. One of the primary goals of the library is to explain the low-level details of Bitcoin. The code is easy to read and properly documented explaining in detail all the thorny aspects of the implementation. It is a low-level library which assumes some high-level understanding of how Bitcoin works. In the future this might change.
-This is an early version of the library (v0.5.9) and currently, it supports private/public keys, all type of addresses and creation of any transaction (incl. segwit) with all SIGHASH types. All script op codes are included. Timelock and non-standard transactions are supported. Currently, a simple node proxy exists to enable easy calls to a Bitcoin core node. Extra functionality will be added continuously and the documentation will be improved as the work progresses.
+This is an early version of the library (v0.6.1) and currently, it supports private/public keys, all type of addresses and creation of any transaction, incl. segwit and taproot default key path, with all SIGHASH types. All script op codes are included. Timelocks and non-standard transactions are supported. Extra functionality will be added continuously and the documentation will be improved as the work progresses.
The API documentation can be build with Sphinx but is also available as a PDF for convenience. One can currently use the library for experimenting and learning the inner workings of Bitcoin. It is not meant for production yet and parts of the API might be updated with new versions.
Complementary to this library is a CC BY-SA 4.0 licensed `Bitcoin programming book <https://github.com/karask/bitcoin-textbook>`_.
@@ -32,12 +32,12 @@ Summary: Development documents and examples for bitcoin-utils
Provides: python3-bitcoin-utils-doc
%description help
This is a bitcoin library that provides tools/utilities to interact with the Bitcoin network. One of the primary goals of the library is to explain the low-level details of Bitcoin. The code is easy to read and properly documented explaining in detail all the thorny aspects of the implementation. It is a low-level library which assumes some high-level understanding of how Bitcoin works. In the future this might change.
-This is an early version of the library (v0.5.9) and currently, it supports private/public keys, all type of addresses and creation of any transaction (incl. segwit) with all SIGHASH types. All script op codes are included. Timelock and non-standard transactions are supported. Currently, a simple node proxy exists to enable easy calls to a Bitcoin core node. Extra functionality will be added continuously and the documentation will be improved as the work progresses.
+This is an early version of the library (v0.6.1) and currently, it supports private/public keys, all type of addresses and creation of any transaction, incl. segwit and taproot default key path, with all SIGHASH types. All script op codes are included. Timelocks and non-standard transactions are supported. Extra functionality will be added continuously and the documentation will be improved as the work progresses.
The API documentation can be build with Sphinx but is also available as a PDF for convenience. One can currently use the library for experimenting and learning the inner workings of Bitcoin. It is not meant for production yet and parts of the API might be updated with new versions.
Complementary to this library is a CC BY-SA 4.0 licensed `Bitcoin programming book <https://github.com/karask/bitcoin-textbook>`_.
%prep
-%autosetup -n bitcoin-utils-0.5.9
+%autosetup -n bitcoin-utils-0.6.1
%build
%py3_build
@@ -51,20 +51,20 @@ if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
- find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+ find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
- find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+ find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
- find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+ find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
- find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+ find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
- find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+ find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
@@ -77,5 +77,5 @@ mv %{buildroot}/doclist.lst .
%{_docdir}/*
%changelog
-* Tue May 30 2023 Python_Bot <Python_Bot@openeuler.org> - 0.5.9-1
+* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 0.6.1-1
- Package Spec generated