summaryrefslogtreecommitdiff
path: root/python-bitly-api.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-10 06:11:05 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-10 06:11:05 +0000
commite324888c7c056684394e80683327e13e34b156dd (patch)
treec7f825cea3db24ed45b535cb9e88d953956d3f02 /python-bitly-api.spec
parent6938e5c9da450ec67ddc87b1267c658613f860c6 (diff)
automatic import of python-bitly-api
Diffstat (limited to 'python-bitly-api.spec')
-rw-r--r--python-bitly-api.spec96
1 files changed, 96 insertions, 0 deletions
diff --git a/python-bitly-api.spec b/python-bitly-api.spec
new file mode 100644
index 0000000..1074883
--- /dev/null
+++ b/python-bitly-api.spec
@@ -0,0 +1,96 @@
+%global _empty_manifest_terminate_build 0
+Name: python-bitly_api
+Version: 0.3
+Release: 1
+Summary: An API for bit.ly
+License: Apache Software License
+URL: https://github.com/bitly/bitly-api-python
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/2e/5d/6060b798ae345c1c7499ff88a15dd06001e8ac9d4945c370faf181d4076b/bitly_api-0.3.tar.gz
+BuildArch: noarch
+
+
+%description
+## Installation
+ pip install bitly_api
+## Run tests
+Your username is the lowercase name shown when you login to bitly, your access token can be fetched using the following ( http://dev.bitly.com/authentication.html ):
+ curl -u "username:password" -X POST "https://api-ssl.bitly.com/oauth/access_token"
+To run the tests either export the environment variable or set it up inline before calling `nosetests`:
+ bitly-api-python $ BITLY_ACCESS_TOKEN=<accesstoken> nosetests
+## API Documentation
+http://dev.bitly.com/
+
+%package -n python3-bitly_api
+Summary: An API for bit.ly
+Provides: python-bitly_api
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-bitly_api
+## Installation
+ pip install bitly_api
+## Run tests
+Your username is the lowercase name shown when you login to bitly, your access token can be fetched using the following ( http://dev.bitly.com/authentication.html ):
+ curl -u "username:password" -X POST "https://api-ssl.bitly.com/oauth/access_token"
+To run the tests either export the environment variable or set it up inline before calling `nosetests`:
+ bitly-api-python $ BITLY_ACCESS_TOKEN=<accesstoken> nosetests
+## API Documentation
+http://dev.bitly.com/
+
+%package help
+Summary: Development documents and examples for bitly_api
+Provides: python3-bitly_api-doc
+%description help
+## Installation
+ pip install bitly_api
+## Run tests
+Your username is the lowercase name shown when you login to bitly, your access token can be fetched using the following ( http://dev.bitly.com/authentication.html ):
+ curl -u "username:password" -X POST "https://api-ssl.bitly.com/oauth/access_token"
+To run the tests either export the environment variable or set it up inline before calling `nosetests`:
+ bitly-api-python $ BITLY_ACCESS_TOKEN=<accesstoken> nosetests
+## API Documentation
+http://dev.bitly.com/
+
+%prep
+%autosetup -n bitly_api-0.3
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-bitly_api -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 0.3-1
+- Package Spec generated