summaryrefslogtreecommitdiff
path: root/python-bitstring.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-bitstring.spec')
-rw-r--r--python-bitstring.spec128
1 files changed, 31 insertions, 97 deletions
diff --git a/python-bitstring.spec b/python-bitstring.spec
index 1b26482..d1b5cb4 100644
--- a/python-bitstring.spec
+++ b/python-bitstring.spec
@@ -1,46 +1,24 @@
%global _empty_manifest_terminate_build 0
Name: python-bitstring
-Version: 4.0.1
+Version: 4.0.2
Release: 1
Summary: Simple construction, analysis and modification of binary data.
License: MIT License
URL: https://pypi.org/project/bitstring/
-Source0: https://mirrors.nju.edu.cn/pypi/web/packages/d2/64/e733b18349be383a4b7859c865d6c9e5ccc5845e9b4258504055607ec1cb/bitstring-4.0.1.tar.gz
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/b5/f1/f55f568ef587fe7a74f46a9ae869dbbda10575b2a404c831d2bc0567b7de/bitstring-4.0.2.tar.gz
BuildArch: noarch
%description
-* New Python 3.7 minimum requirement. The code has been updated with type hints and legacy code removed.
-* Shorter and more versative properties are available.
- >>> a = BitArray('u8=20')
- >>> a += '0b0011, f16=5.52'
- >>> a[12:].f16
- 5.51953125
-* A useful new pretty printing method. Gives a formatted view of a singe or two interpretations of the
- binary data.
- >>> a = Bits(bytes=b'hello world!!')
- >>> a.pp('bin, hex', width=40)
- 0: 01101000 01100101 68 65
- 16: 01101100 01101100 6c 6c
- 32: 01101111 00100000 6f 20
- 48: 01110111 01101111 77 6f
- 64: 01110010 01101100 72 6c
- 80: 01100100 00100001 64 21
- 96: 00100001 21
-* LSB0 option (beta). This indexes the bits with the least significant bit being bit zero. This is the
- opposite way to the standard Python containers but is usual in some relevant fields.
- >>> bitstring.lsb0 = True
- >>> s = BitArray('0b00000')
- >>> s[0] = 1
- >>> s.bin
- '00001'
- This feature is still considered a beta as there may be issues with edge cases, especially around the
- interaction with the 'stream' features of the `BitStream` and `ConstBitStream` classes. For most usage
- cases it should be solid though, so please report any bugs in the issue tracker.
-* Command line usage. Useful for quick interpretations of binary data.
- $ python -m bitstring int:16=-400
- 0xfe70
-* Support for 16 bit floating point types (both IEEE and bfloat).
+* Create bitstrings from hex, octal, binary, files, formatted strings, bytes, integers and floats of different endiannesses.
+* Powerful binary packing and unpacking functions.
+* Bit-level slicing, joining, searching, replacing and more.
+* Read from and interpret bitstrings as streams of binary data.
+* Rich API - chances are that whatever you want to do there's a simple and elegant way of doing it.
+* Open source software, released under the MIT licence.
+> **Note** \
+> Version 4.0 of bitstring only supports Python 3.7 and later. \
+> Use bitstring version 3.1 if you're using Python 2.7 or 3.6 or earlier.
%package -n python3-bitstring
Summary: Simple construction, analysis and modification of binary data.
@@ -49,76 +27,32 @@ BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-bitstring
-* New Python 3.7 minimum requirement. The code has been updated with type hints and legacy code removed.
-* Shorter and more versative properties are available.
- >>> a = BitArray('u8=20')
- >>> a += '0b0011, f16=5.52'
- >>> a[12:].f16
- 5.51953125
-* A useful new pretty printing method. Gives a formatted view of a singe or two interpretations of the
- binary data.
- >>> a = Bits(bytes=b'hello world!!')
- >>> a.pp('bin, hex', width=40)
- 0: 01101000 01100101 68 65
- 16: 01101100 01101100 6c 6c
- 32: 01101111 00100000 6f 20
- 48: 01110111 01101111 77 6f
- 64: 01110010 01101100 72 6c
- 80: 01100100 00100001 64 21
- 96: 00100001 21
-* LSB0 option (beta). This indexes the bits with the least significant bit being bit zero. This is the
- opposite way to the standard Python containers but is usual in some relevant fields.
- >>> bitstring.lsb0 = True
- >>> s = BitArray('0b00000')
- >>> s[0] = 1
- >>> s.bin
- '00001'
- This feature is still considered a beta as there may be issues with edge cases, especially around the
- interaction with the 'stream' features of the `BitStream` and `ConstBitStream` classes. For most usage
- cases it should be solid though, so please report any bugs in the issue tracker.
-* Command line usage. Useful for quick interpretations of binary data.
- $ python -m bitstring int:16=-400
- 0xfe70
-* Support for 16 bit floating point types (both IEEE and bfloat).
+* Create bitstrings from hex, octal, binary, files, formatted strings, bytes, integers and floats of different endiannesses.
+* Powerful binary packing and unpacking functions.
+* Bit-level slicing, joining, searching, replacing and more.
+* Read from and interpret bitstrings as streams of binary data.
+* Rich API - chances are that whatever you want to do there's a simple and elegant way of doing it.
+* Open source software, released under the MIT licence.
+> **Note** \
+> Version 4.0 of bitstring only supports Python 3.7 and later. \
+> Use bitstring version 3.1 if you're using Python 2.7 or 3.6 or earlier.
%package help
Summary: Development documents and examples for bitstring
Provides: python3-bitstring-doc
%description help
-* New Python 3.7 minimum requirement. The code has been updated with type hints and legacy code removed.
-* Shorter and more versative properties are available.
- >>> a = BitArray('u8=20')
- >>> a += '0b0011, f16=5.52'
- >>> a[12:].f16
- 5.51953125
-* A useful new pretty printing method. Gives a formatted view of a singe or two interpretations of the
- binary data.
- >>> a = Bits(bytes=b'hello world!!')
- >>> a.pp('bin, hex', width=40)
- 0: 01101000 01100101 68 65
- 16: 01101100 01101100 6c 6c
- 32: 01101111 00100000 6f 20
- 48: 01110111 01101111 77 6f
- 64: 01110010 01101100 72 6c
- 80: 01100100 00100001 64 21
- 96: 00100001 21
-* LSB0 option (beta). This indexes the bits with the least significant bit being bit zero. This is the
- opposite way to the standard Python containers but is usual in some relevant fields.
- >>> bitstring.lsb0 = True
- >>> s = BitArray('0b00000')
- >>> s[0] = 1
- >>> s.bin
- '00001'
- This feature is still considered a beta as there may be issues with edge cases, especially around the
- interaction with the 'stream' features of the `BitStream` and `ConstBitStream` classes. For most usage
- cases it should be solid though, so please report any bugs in the issue tracker.
-* Command line usage. Useful for quick interpretations of binary data.
- $ python -m bitstring int:16=-400
- 0xfe70
-* Support for 16 bit floating point types (both IEEE and bfloat).
+* Create bitstrings from hex, octal, binary, files, formatted strings, bytes, integers and floats of different endiannesses.
+* Powerful binary packing and unpacking functions.
+* Bit-level slicing, joining, searching, replacing and more.
+* Read from and interpret bitstrings as streams of binary data.
+* Rich API - chances are that whatever you want to do there's a simple and elegant way of doing it.
+* Open source software, released under the MIT licence.
+> **Note** \
+> Version 4.0 of bitstring only supports Python 3.7 and later. \
+> Use bitstring version 3.1 if you're using Python 2.7 or 3.6 or earlier.
%prep
-%autosetup -n bitstring-4.0.1
+%autosetup -n bitstring-4.0.2
%build
%py3_build
@@ -158,5 +92,5 @@ mv %{buildroot}/doclist.lst .
%{_docdir}/*
%changelog
-* Fri Apr 07 2023 Python_Bot <Python_Bot@openeuler.org> - 4.0.1-1
+* Fri Apr 21 2023 Python_Bot <Python_Bot@openeuler.org> - 4.0.2-1
- Package Spec generated