summaryrefslogtreecommitdiff
path: root/python-bitstring.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-bitstring.spec')
-rw-r--r--python-bitstring.spec162
1 files changed, 162 insertions, 0 deletions
diff --git a/python-bitstring.spec b/python-bitstring.spec
new file mode 100644
index 0000000..120388a
--- /dev/null
+++ b/python-bitstring.spec
@@ -0,0 +1,162 @@
+%global _empty_manifest_terminate_build 0
+Name: python-bitstring
+Version: 4.0.1
+Release: 1
+Summary: Simple construction, analysis and modification of binary data.
+License: MIT License
+URL: https://pypi.org/project/bitstring/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/d2/64/e733b18349be383a4b7859c865d6c9e5ccc5845e9b4258504055607ec1cb/bitstring-4.0.1.tar.gz
+BuildArch: noarch
+
+
+%description
+* New Python 3.7 minimum requirement. The code has been updated with type hints and legacy code removed.
+* Shorter and more versative properties are available.
+ >>> a = BitArray('u8=20')
+ >>> a += '0b0011, f16=5.52'
+ >>> a[12:].f16
+ 5.51953125
+* A useful new pretty printing method. Gives a formatted view of a singe or two interpretations of the
+ binary data.
+ >>> a = Bits(bytes=b'hello world!!')
+ >>> a.pp('bin, hex', width=40)
+ 0: 01101000 01100101 68 65
+ 16: 01101100 01101100 6c 6c
+ 32: 01101111 00100000 6f 20
+ 48: 01110111 01101111 77 6f
+ 64: 01110010 01101100 72 6c
+ 80: 01100100 00100001 64 21
+ 96: 00100001 21
+* LSB0 option (beta). This indexes the bits with the least significant bit being bit zero. This is the
+ opposite way to the standard Python containers but is usual in some relevant fields.
+ >>> bitstring.lsb0 = True
+ >>> s = BitArray('0b00000')
+ >>> s[0] = 1
+ >>> s.bin
+ '00001'
+ This feature is still considered a beta as there may be issues with edge cases, especially around the
+ interaction with the 'stream' features of the `BitStream` and `ConstBitStream` classes. For most usage
+ cases it should be solid though, so please report any bugs in the issue tracker.
+* Command line usage. Useful for quick interpretations of binary data.
+ $ python -m bitstring int:16=-400
+ 0xfe70
+* Support for 16 bit floating point types (both IEEE and bfloat).
+
+%package -n python3-bitstring
+Summary: Simple construction, analysis and modification of binary data.
+Provides: python-bitstring
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-bitstring
+* New Python 3.7 minimum requirement. The code has been updated with type hints and legacy code removed.
+* Shorter and more versative properties are available.
+ >>> a = BitArray('u8=20')
+ >>> a += '0b0011, f16=5.52'
+ >>> a[12:].f16
+ 5.51953125
+* A useful new pretty printing method. Gives a formatted view of a singe or two interpretations of the
+ binary data.
+ >>> a = Bits(bytes=b'hello world!!')
+ >>> a.pp('bin, hex', width=40)
+ 0: 01101000 01100101 68 65
+ 16: 01101100 01101100 6c 6c
+ 32: 01101111 00100000 6f 20
+ 48: 01110111 01101111 77 6f
+ 64: 01110010 01101100 72 6c
+ 80: 01100100 00100001 64 21
+ 96: 00100001 21
+* LSB0 option (beta). This indexes the bits with the least significant bit being bit zero. This is the
+ opposite way to the standard Python containers but is usual in some relevant fields.
+ >>> bitstring.lsb0 = True
+ >>> s = BitArray('0b00000')
+ >>> s[0] = 1
+ >>> s.bin
+ '00001'
+ This feature is still considered a beta as there may be issues with edge cases, especially around the
+ interaction with the 'stream' features of the `BitStream` and `ConstBitStream` classes. For most usage
+ cases it should be solid though, so please report any bugs in the issue tracker.
+* Command line usage. Useful for quick interpretations of binary data.
+ $ python -m bitstring int:16=-400
+ 0xfe70
+* Support for 16 bit floating point types (both IEEE and bfloat).
+
+%package help
+Summary: Development documents and examples for bitstring
+Provides: python3-bitstring-doc
+%description help
+* New Python 3.7 minimum requirement. The code has been updated with type hints and legacy code removed.
+* Shorter and more versative properties are available.
+ >>> a = BitArray('u8=20')
+ >>> a += '0b0011, f16=5.52'
+ >>> a[12:].f16
+ 5.51953125
+* A useful new pretty printing method. Gives a formatted view of a singe or two interpretations of the
+ binary data.
+ >>> a = Bits(bytes=b'hello world!!')
+ >>> a.pp('bin, hex', width=40)
+ 0: 01101000 01100101 68 65
+ 16: 01101100 01101100 6c 6c
+ 32: 01101111 00100000 6f 20
+ 48: 01110111 01101111 77 6f
+ 64: 01110010 01101100 72 6c
+ 80: 01100100 00100001 64 21
+ 96: 00100001 21
+* LSB0 option (beta). This indexes the bits with the least significant bit being bit zero. This is the
+ opposite way to the standard Python containers but is usual in some relevant fields.
+ >>> bitstring.lsb0 = True
+ >>> s = BitArray('0b00000')
+ >>> s[0] = 1
+ >>> s.bin
+ '00001'
+ This feature is still considered a beta as there may be issues with edge cases, especially around the
+ interaction with the 'stream' features of the `BitStream` and `ConstBitStream` classes. For most usage
+ cases it should be solid though, so please report any bugs in the issue tracker.
+* Command line usage. Useful for quick interpretations of binary data.
+ $ python -m bitstring int:16=-400
+ 0xfe70
+* Support for 16 bit floating point types (both IEEE and bfloat).
+
+%prep
+%autosetup -n bitstring-4.0.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-bitstring -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed Mar 08 2023 Python_Bot <Python_Bot@openeuler.org> - 4.0.1-1
+- Package Spec generated