summaryrefslogtreecommitdiff
path: root/python-boost-histogram.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-11 04:58:18 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-11 04:58:18 +0000
commit0bcbee67afcb2b1d254d5267eab405fa46c819d4 (patch)
treeb6336e5d3d6ff823aa7911c752be5192a6b4a171 /python-boost-histogram.spec
parent1fc333cb6d153e0a1436d6703f961e2885dd3283 (diff)
automatic import of python-boost-histogram
Diffstat (limited to 'python-boost-histogram.spec')
-rw-r--r--python-boost-histogram.spec181
1 files changed, 181 insertions, 0 deletions
diff --git a/python-boost-histogram.spec b/python-boost-histogram.spec
new file mode 100644
index 0000000..ac8005b
--- /dev/null
+++ b/python-boost-histogram.spec
@@ -0,0 +1,181 @@
+%global _empty_manifest_terminate_build 0
+Name: python-boost-histogram
+Version: 1.3.2
+Release: 1
+Summary: The Boost::Histogram Python wrapper.
+License: BSD-3-Clause
+URL: https://github.com/scikit-hep/boost-histogram
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/de/1a/e55f7c104168e2c28ce52a3a68b06d8e26c7d3ae66cab87d6b559034e124/boost_histogram-1.3.2.tar.gz
+
+Requires: python3-numpy
+Requires: python3-dataclasses
+Requires: python3-typing-extensions
+Requires: python3-pytest
+Requires: python3-pytest-benchmark
+Requires: python3-cloudpickle
+Requires: python3-hypothesis
+Requires: python3-Sphinx
+Requires: python3-myst-parser
+Requires: python3-sphinx-book-theme
+Requires: python3-nbsphinx
+Requires: python3-sphinx-copybutton
+Requires: python3-matplotlib
+Requires: python3-xarray
+Requires: python3-xhistogram
+Requires: python3-netCDF4
+Requires: python3-numba
+Requires: python3-uproot3
+Requires: python3-ipykernel
+Requires: python3-typer
+Requires: python3-ipykernel
+Requires: python3-typer
+Requires: python3-pytest
+Requires: python3-pytest-benchmark
+Requires: python3-cloudpickle
+Requires: python3-hypothesis
+Requires: python3-Sphinx
+Requires: python3-myst-parser
+Requires: python3-sphinx-book-theme
+Requires: python3-nbsphinx
+Requires: python3-sphinx-copybutton
+Requires: python3-matplotlib
+Requires: python3-xarray
+Requires: python3-xhistogram
+Requires: python3-netCDF4
+Requires: python3-numba
+Requires: python3-uproot3
+Requires: python3-pytest
+Requires: python3-pytest-benchmark
+Requires: python3-cloudpickle
+Requires: python3-hypothesis
+
+%description
+## Acknowledgements
+This library was primarily developed by Henry Schreiner and Hans Dembinski.
+Support for this work was provided by the National Science Foundation cooperative agreement OAC-1836650 (IRIS-HEP) and OAC-1450377 (DIANA/HEP). Any opinions, findings, conclusions or recommendations expressed in this material are those of the authors and do not necessarily reflect the views of the National Science Foundation.
+[actions-badge]: https://github.com/scikit-hep/boost-histogram/workflows/Tests/badge.svg
+[actions-link]: https://github.com/scikit-hep/boost-histogram/actions
+[black-badge]: https://img.shields.io/badge/code%20style-black-000000.svg
+[black-link]: https://github.com/psf/black
+[conda-badge]: https://img.shields.io/conda/vn/conda-forge/boost-histogram
+[conda-link]: https://github.com/conda-forge/boost-histogram-feedstock
+[github-discussions-badge]: https://img.shields.io/static/v1?label=Discussions&message=Ask&color=blue&logo=github
+[github-discussions-link]: https://github.com/scikit-hep/boost-histogram/discussions
+[gitter-badge]: https://badges.gitter.im/HSF/PyHEP-histogramming.svg
+[gitter-link]: https://gitter.im/HSF/PyHEP-histogramming?utm_source=badge&utm_medium=badge&utm_campaign=pr-badge
+[pypi-link]: https://pypi.org/project/boost-histogram/
+[pypi-platforms]: https://img.shields.io/pypi/pyversions/boost-histogram
+[pypi-version]: https://badge.fury.io/py/boost-histogram.svg
+[rtd-badge]: https://readthedocs.org/projects/boost-histogram/badge/?version=latest
+[rtd-link]: https://boost-histogram.readthedocs.io/en/latest/?badge=latest
+[sk-badge]: https://scikit-hep.org/assets/images/Scikit--HEP-Project-blue.svg
+[Boost::Histogram]: https://www.boost.org/doc/libs/release/libs/histogram/doc/html/index.html
+[Boost::Histogram source]: https://github.com/boostorg/histogram
+[Hist]: https://github.com/scikit-hep/hist
+[fastest libraries]: https://iscinumpy.gitlab.io/post/histogram-speeds-in-python/
+
+%package -n python3-boost-histogram
+Summary: The Boost::Histogram Python wrapper.
+Provides: python-boost-histogram
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+BuildRequires: python3-cffi
+BuildRequires: gcc
+BuildRequires: gdb
+%description -n python3-boost-histogram
+## Acknowledgements
+This library was primarily developed by Henry Schreiner and Hans Dembinski.
+Support for this work was provided by the National Science Foundation cooperative agreement OAC-1836650 (IRIS-HEP) and OAC-1450377 (DIANA/HEP). Any opinions, findings, conclusions or recommendations expressed in this material are those of the authors and do not necessarily reflect the views of the National Science Foundation.
+[actions-badge]: https://github.com/scikit-hep/boost-histogram/workflows/Tests/badge.svg
+[actions-link]: https://github.com/scikit-hep/boost-histogram/actions
+[black-badge]: https://img.shields.io/badge/code%20style-black-000000.svg
+[black-link]: https://github.com/psf/black
+[conda-badge]: https://img.shields.io/conda/vn/conda-forge/boost-histogram
+[conda-link]: https://github.com/conda-forge/boost-histogram-feedstock
+[github-discussions-badge]: https://img.shields.io/static/v1?label=Discussions&message=Ask&color=blue&logo=github
+[github-discussions-link]: https://github.com/scikit-hep/boost-histogram/discussions
+[gitter-badge]: https://badges.gitter.im/HSF/PyHEP-histogramming.svg
+[gitter-link]: https://gitter.im/HSF/PyHEP-histogramming?utm_source=badge&utm_medium=badge&utm_campaign=pr-badge
+[pypi-link]: https://pypi.org/project/boost-histogram/
+[pypi-platforms]: https://img.shields.io/pypi/pyversions/boost-histogram
+[pypi-version]: https://badge.fury.io/py/boost-histogram.svg
+[rtd-badge]: https://readthedocs.org/projects/boost-histogram/badge/?version=latest
+[rtd-link]: https://boost-histogram.readthedocs.io/en/latest/?badge=latest
+[sk-badge]: https://scikit-hep.org/assets/images/Scikit--HEP-Project-blue.svg
+[Boost::Histogram]: https://www.boost.org/doc/libs/release/libs/histogram/doc/html/index.html
+[Boost::Histogram source]: https://github.com/boostorg/histogram
+[Hist]: https://github.com/scikit-hep/hist
+[fastest libraries]: https://iscinumpy.gitlab.io/post/histogram-speeds-in-python/
+
+%package help
+Summary: Development documents and examples for boost-histogram
+Provides: python3-boost-histogram-doc
+%description help
+## Acknowledgements
+This library was primarily developed by Henry Schreiner and Hans Dembinski.
+Support for this work was provided by the National Science Foundation cooperative agreement OAC-1836650 (IRIS-HEP) and OAC-1450377 (DIANA/HEP). Any opinions, findings, conclusions or recommendations expressed in this material are those of the authors and do not necessarily reflect the views of the National Science Foundation.
+[actions-badge]: https://github.com/scikit-hep/boost-histogram/workflows/Tests/badge.svg
+[actions-link]: https://github.com/scikit-hep/boost-histogram/actions
+[black-badge]: https://img.shields.io/badge/code%20style-black-000000.svg
+[black-link]: https://github.com/psf/black
+[conda-badge]: https://img.shields.io/conda/vn/conda-forge/boost-histogram
+[conda-link]: https://github.com/conda-forge/boost-histogram-feedstock
+[github-discussions-badge]: https://img.shields.io/static/v1?label=Discussions&message=Ask&color=blue&logo=github
+[github-discussions-link]: https://github.com/scikit-hep/boost-histogram/discussions
+[gitter-badge]: https://badges.gitter.im/HSF/PyHEP-histogramming.svg
+[gitter-link]: https://gitter.im/HSF/PyHEP-histogramming?utm_source=badge&utm_medium=badge&utm_campaign=pr-badge
+[pypi-link]: https://pypi.org/project/boost-histogram/
+[pypi-platforms]: https://img.shields.io/pypi/pyversions/boost-histogram
+[pypi-version]: https://badge.fury.io/py/boost-histogram.svg
+[rtd-badge]: https://readthedocs.org/projects/boost-histogram/badge/?version=latest
+[rtd-link]: https://boost-histogram.readthedocs.io/en/latest/?badge=latest
+[sk-badge]: https://scikit-hep.org/assets/images/Scikit--HEP-Project-blue.svg
+[Boost::Histogram]: https://www.boost.org/doc/libs/release/libs/histogram/doc/html/index.html
+[Boost::Histogram source]: https://github.com/boostorg/histogram
+[Hist]: https://github.com/scikit-hep/hist
+[fastest libraries]: https://iscinumpy.gitlab.io/post/histogram-speeds-in-python/
+
+%prep
+%autosetup -n boost-histogram-1.3.2
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-boost-histogram -f filelist.lst
+%dir %{python3_sitearch}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 1.3.2-1
+- Package Spec generated