summaryrefslogtreecommitdiff
path: root/python-bpyutils.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-15 06:40:26 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-15 06:40:26 +0000
commit0d348714a78b31c0d1ef3887bb914929a32890af (patch)
tree794028962b90803f4b743363d56242ec1d639b35 /python-bpyutils.spec
parent0d41594d3e38ebe0b6a0dc9a2dcf7fe0ecc9d865 (diff)
automatic import of python-bpyutils
Diffstat (limited to 'python-bpyutils.spec')
-rw-r--r--python-bpyutils.spec106
1 files changed, 106 insertions, 0 deletions
diff --git a/python-bpyutils.spec b/python-bpyutils.spec
new file mode 100644
index 0000000..b810f99
--- /dev/null
+++ b/python-bpyutils.spec
@@ -0,0 +1,106 @@
+%global _empty_manifest_terminate_build 0
+Name: python-bpyutils
+Version: 0.5.8
+Release: 1
+Summary: A collection of various common Python utilities.
+License: MIT License
+URL: https://github.com/achillesrasquinha/bpyutils
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/a9/0d/bb35ffd8b68fd12b96a55d404a388ccfdaf31da30ce829df4880f558c601/bpyutils-0.5.8.tar.gz
+BuildArch: noarch
+
+Requires: python3-sphinx
+Requires: python3-recommonmark
+Requires: python3-ipykernel
+Requires: python3-nbsphinx
+Requires: python3-renku-sphinx-theme
+Requires: python3-sphinx-autobuild
+Requires: python3-pylint
+Requires: python3-autopep8
+Requires: python3-pytest
+Requires: python3-pytest-cov
+Requires: python3-pytest-xdist
+Requires: python3-pytest-sugar
+Requires: python3-tox
+Requires: python3-coveralls
+Requires: python3-pluggy
+Requires: python3-docstr-coverage
+Requires: python3-pipenv
+Requires: python3-jedi
+Requires: python3-ipython
+Requires: python3-bumpversion
+Requires: python3-vulture
+Requires: python3-safety
+Requires: python3-pre-commit
+Requires: python3-twine
+Requires: python3-jupyter
+Requires: python3-Flask
+Requires: python3-cookiecutter
+Requires: python3-pytest-clarity
+
+%description
+<div align="center">
+ Made with ❤️ using <a href="https://git.io/boilpy">boilpy</a>.
+</div>
+
+%package -n python3-bpyutils
+Summary: A collection of various common Python utilities.
+Provides: python-bpyutils
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-bpyutils
+<div align="center">
+ Made with ❤️ using <a href="https://git.io/boilpy">boilpy</a>.
+</div>
+
+%package help
+Summary: Development documents and examples for bpyutils
+Provides: python3-bpyutils-doc
+%description help
+<div align="center">
+ Made with ❤️ using <a href="https://git.io/boilpy">boilpy</a>.
+</div>
+
+%prep
+%autosetup -n bpyutils-0.5.8
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-bpyutils -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon May 15 2023 Python_Bot <Python_Bot@openeuler.org> - 0.5.8-1
+- Package Spec generated