summaryrefslogtreecommitdiff
path: root/python-bthomehub5-devicelist.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-15 05:28:41 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-15 05:28:41 +0000
commit77314e36364bf016d063601aceedb8f1bd522e14 (patch)
treedb34e6ca9492804dbfcbb38ecbf8fba3d5748496 /python-bthomehub5-devicelist.spec
parent5054a1bff7a80843846fe0f6e2205afb23a73e6d (diff)
automatic import of python-bthomehub5-devicelist
Diffstat (limited to 'python-bthomehub5-devicelist.spec')
-rw-r--r--python-bthomehub5-devicelist.spec200
1 files changed, 200 insertions, 0 deletions
diff --git a/python-bthomehub5-devicelist.spec b/python-bthomehub5-devicelist.spec
new file mode 100644
index 0000000..bcedaf4
--- /dev/null
+++ b/python-bthomehub5-devicelist.spec
@@ -0,0 +1,200 @@
+%global _empty_manifest_terminate_build 0
+Name: python-bthomehub5-devicelist
+Version: 0.1.1
+Release: 1
+Summary: A library that returns a list of devices currently connected to a BT Home Hub 5
+License: MIT License
+URL: https://github.com/ahobsonsayers/bthomehub5-devicelist
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/eb/97/e67419b7653bd23a99b7c3255f3617496c6636d9f7032e72be4b4823b21f/bthomehub5-devicelist-0.1.1.tar.gz
+BuildArch: noarch
+
+Requires: python3-html-table-parser-python3
+Requires: python3-requests
+
+%description
+# bthomehub5-devicelist
+This library will return a dictionary containing information about the devices currently connected to a BT Home Hub 5 with a user specified IP Address.
+
+## Installation
+
+ pip install bthomhub5-devicelist
+
+## How to use
+
+Example Usage:
+
+ import bthomehub5_devicelist
+ from pprint import pprint
+
+
+ def main():
+
+ # If an IP Address is not specified, it will default as 192.169.1.254
+ devicelist = bthomehub5_devicelist.get_devicelist('192.168.1.254')
+
+ pprint(devicelist)
+
+
+ if __name__ == '__main__':
+ main()
+
+The library will return a dictionary with connected devices MAC addresses as keys and device names as values
+
+The console output from running the example code will look like this:
+
+```
+>>>
+{'4f:c9:32:04:d3:ec': 'Example-PC',
+ '3f:6a:66:49:d4:16': 'Example-IPhone',
+ '01:5d:e8:fb:c8:a9': 'Example-Smartlight',
+ '65:10:5c:6d:d0:2b': 'Example-Android'}
+```
+
+## License
+
+MIT - Feel free to go crazy with the code
+
+
+
+%package -n python3-bthomehub5-devicelist
+Summary: A library that returns a list of devices currently connected to a BT Home Hub 5
+Provides: python-bthomehub5-devicelist
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-bthomehub5-devicelist
+# bthomehub5-devicelist
+This library will return a dictionary containing information about the devices currently connected to a BT Home Hub 5 with a user specified IP Address.
+
+## Installation
+
+ pip install bthomhub5-devicelist
+
+## How to use
+
+Example Usage:
+
+ import bthomehub5_devicelist
+ from pprint import pprint
+
+
+ def main():
+
+ # If an IP Address is not specified, it will default as 192.169.1.254
+ devicelist = bthomehub5_devicelist.get_devicelist('192.168.1.254')
+
+ pprint(devicelist)
+
+
+ if __name__ == '__main__':
+ main()
+
+The library will return a dictionary with connected devices MAC addresses as keys and device names as values
+
+The console output from running the example code will look like this:
+
+```
+>>>
+{'4f:c9:32:04:d3:ec': 'Example-PC',
+ '3f:6a:66:49:d4:16': 'Example-IPhone',
+ '01:5d:e8:fb:c8:a9': 'Example-Smartlight',
+ '65:10:5c:6d:d0:2b': 'Example-Android'}
+```
+
+## License
+
+MIT - Feel free to go crazy with the code
+
+
+
+%package help
+Summary: Development documents and examples for bthomehub5-devicelist
+Provides: python3-bthomehub5-devicelist-doc
+%description help
+# bthomehub5-devicelist
+This library will return a dictionary containing information about the devices currently connected to a BT Home Hub 5 with a user specified IP Address.
+
+## Installation
+
+ pip install bthomhub5-devicelist
+
+## How to use
+
+Example Usage:
+
+ import bthomehub5_devicelist
+ from pprint import pprint
+
+
+ def main():
+
+ # If an IP Address is not specified, it will default as 192.169.1.254
+ devicelist = bthomehub5_devicelist.get_devicelist('192.168.1.254')
+
+ pprint(devicelist)
+
+
+ if __name__ == '__main__':
+ main()
+
+The library will return a dictionary with connected devices MAC addresses as keys and device names as values
+
+The console output from running the example code will look like this:
+
+```
+>>>
+{'4f:c9:32:04:d3:ec': 'Example-PC',
+ '3f:6a:66:49:d4:16': 'Example-IPhone',
+ '01:5d:e8:fb:c8:a9': 'Example-Smartlight',
+ '65:10:5c:6d:d0:2b': 'Example-Android'}
+```
+
+## License
+
+MIT - Feel free to go crazy with the code
+
+
+
+%prep
+%autosetup -n bthomehub5-devicelist-0.1.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-bthomehub5-devicelist -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon May 15 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1.1-1
+- Package Spec generated