summaryrefslogtreecommitdiff
path: root/python-c65beka.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-10 06:22:34 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-10 06:22:34 +0000
commitadace9ddd9ad0a41c950d6466b665e9adda8792d (patch)
tree3789103c49079cd87d4e35adec5705d595c1a180 /python-c65beka.spec
parent12e7886c07b774af9d254e12d6710c94709c29e3 (diff)
automatic import of python-c65beka
Diffstat (limited to 'python-c65beka.spec')
-rw-r--r--python-c65beka.spec96
1 files changed, 96 insertions, 0 deletions
diff --git a/python-c65beka.spec b/python-c65beka.spec
new file mode 100644
index 0000000..e234902
--- /dev/null
+++ b/python-c65beka.spec
@@ -0,0 +1,96 @@
+%global _empty_manifest_terminate_build 0
+Name: python-c65beka
+Version: 1.0.1
+Release: 1
+Summary: A bare-bones BGP speaker
+License: Apache-2
+URL: https://github.com/c65sdn/beka
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/21/95/df5b1b2481ac17b2fad2c69c024001b97e386cdca0af6edd877f9deed5d9/c65beka-1.0.1.tar.gz
+BuildArch: noarch
+
+
+%description
+Beka is a fairly basic BGP speaker. It can send
+and receive unicast route updates in IPv4 and IPv6,
+but not too much else. It is designed to be simple to use
+and to extend, without too much overhead.
+
+It uses eventlet for concurrency, but is easy enough to port to
+gevent if that takes your fancy.
+
+More information at https://github.com/c65sdn/beka
+
+%package -n python3-c65beka
+Summary: A bare-bones BGP speaker
+Provides: python-c65beka
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-c65beka
+Beka is a fairly basic BGP speaker. It can send
+and receive unicast route updates in IPv4 and IPv6,
+but not too much else. It is designed to be simple to use
+and to extend, without too much overhead.
+
+It uses eventlet for concurrency, but is easy enough to port to
+gevent if that takes your fancy.
+
+More information at https://github.com/c65sdn/beka
+
+%package help
+Summary: Development documents and examples for c65beka
+Provides: python3-c65beka-doc
+%description help
+Beka is a fairly basic BGP speaker. It can send
+and receive unicast route updates in IPv4 and IPv6,
+but not too much else. It is designed to be simple to use
+and to extend, without too much overhead.
+
+It uses eventlet for concurrency, but is easy enough to port to
+gevent if that takes your fancy.
+
+More information at https://github.com/c65sdn/beka
+
+%prep
+%autosetup -n c65beka-1.0.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-c65beka -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.1-1
+- Package Spec generated