summaryrefslogtreecommitdiff
path: root/python-cameo.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-15 03:21:09 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-15 03:21:09 +0000
commit09536e5a9a3445827a1656b0685a56ab72a80ab2 (patch)
tree24e3f293836df92d65f1a08ff5d00ad22d5908bb /python-cameo.spec
parent58e3db363d79bee1153e6a9438f7bd1b2b6d23f8 (diff)
automatic import of python-cameo
Diffstat (limited to 'python-cameo.spec')
-rw-r--r--python-cameo.spec297
1 files changed, 297 insertions, 0 deletions
diff --git a/python-cameo.spec b/python-cameo.spec
new file mode 100644
index 0000000..58387de
--- /dev/null
+++ b/python-cameo.spec
@@ -0,0 +1,297 @@
+%global _empty_manifest_terminate_build 0
+Name: python-cameo
+Version: 0.13.6
+Release: 1
+Summary: cameo - computer aided metabolic engineering & optimization
+License: Apache License Version 2.0
+URL: http://cameo.bio
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/ec/bf/1c15ef2236e6b15a838025dc135bffb02651b00723c68b740a9f664b7ebe/cameo-0.13.6.tar.gz
+BuildArch: noarch
+
+Requires: python3-numpy
+Requires: python3-scipy
+Requires: python3-blessings
+Requires: python3-pandas
+Requires: python3-ordered-set
+Requires: python3-cobra
+Requires: python3-future
+Requires: python3-optlang
+Requires: python3-numexpr
+Requires: python3-requests
+Requires: python3-networkx
+Requires: python3-escher
+Requires: python3-IProgress
+Requires: python3-inspyred
+Requires: python3-lazy-object-proxy
+Requires: python3-palettable
+Requires: python3-gnomic
+Requires: python3-openpyxl
+Requires: python3-click
+Requires: python3-bokeh
+Requires: python3-ipywidgets
+Requires: python3-pytest-benchmark
+Requires: python3-lxml
+Requires: python3-libsbml
+Requires: python3-redis
+Requires: python3-plotly
+Requires: python3-jupyter
+Requires: python3-numpydoc
+Requires: python3-Sphinx
+Requires: python3-pytest-cov
+Requires: python3-ipyparallel
+Requires: python3-pytest
+Requires: python3-bokeh
+Requires: python3-Sphinx
+Requires: python3-numpydoc
+Requires: python3-jupyter
+Requires: python3-ipywidgets
+Requires: python3-redis
+Requires: python3-ipyparallel
+Requires: python3-plotly
+Requires: python3-libsbml
+Requires: python3-lxml
+Requires: python3-pytest
+Requires: python3-pytest-cov
+Requires: python3-pytest-benchmark
+
+%description
+|Join the chat at https://gitter.im/biosustain/cameo| |PyPI| |License|
+|Build Status| |Coverage Status| |DOI| |zenhub| |binder|
+What is cameo?
+~~~~~~~~~~~~~~
+**Cameo** is a high-level python library developed to aid the strain
+design process in metabolic engineering projects. The library provides a
+modular framework of simulation and strain design methods that targets
+developers that want to develop new design algorithms and custom analysis workflows.
+Furthermore, it exposes a high-level API to users that just want to
+compute promising strain designs.
+Curious? Head over to `try.cameo.bio <http://try.cameo.bio>`__
+and give it a try.
+Please cite https://doi.org/10.1021/acssynbio.7b00423 if you've used cameo in a scientific publication.
+Installation
+~~~~~~~~~~~~
+Use pip to install cameo from `PyPI <https://pypi.python.org/pypi/cameo>`__.
+ $ pip install cameo
+In case you downloaded or cloned the source code from `GitHub <https://github.com/biosustain/cameo>`__
+or your own fork, you can run the following to install cameo for development.
+ $ pip install -e <path-to-cameo-repo> # recommended
+You might need to run these commands with administrative
+privileges if you're not using a virtual environment (using ``sudo`` for example).
+Please check the `documentation <http://cameo.bio/installation.html>`__
+for further details.
+Documentation and Examples
+~~~~~~~~~~~~~~~~~~~~~~~~~~
+Documentation is available on `cameo.bio <http://cameo.bio>`__. Numerous `Jupyter notebooks <http://nbviewer.ipython.org/github/biosustain/cameo-notebooks/tree/master/>`__
+provide examples and tutorials and also form part of the documentation. They are also availabe in executable form on (`try.cameo.bio <http://try.cameo.bio>`__).
+Furthermore, course materials for a two day cell factory engineering course are available `here <https://biosustain.github.io/cell-factory-design-course/>`__.
+High-level API (for users)
+^^^^^^^^^^^^^^^^^^^^^^^^^^
+Compute strain engineering strategies for a desired product in a number
+of host organisms using the high-level interface (runtime is on the order of hours).
+ from cameo.api import design
+ design(product='L-Serine')
+`Output <http://nbviewer.ipython.org/github/biosustain/cameo-notebooks/blob/master/08-high-level-API.ipynb>`__
+The high-level API can also be called from the command line.
+ $ cameo design vanillin
+For more information run
+ $ cameo --help
+Low-level API (for developers)
+^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
+Find gene knockout targets using evolutionary computation.
+ from cameo import models
+ from cameo.strain_design.heuristic import GeneKnockoutOptimization
+ from cameo.strain_design.heuristic.objective_functions import biomass_product_coupled_yield
+ model = models.bigg.e_coli_core
+ obj = biomass_product_coupled_yield(
+ model.reactions.Biomass_Ecoli_core_w_GAM,
+ model.reactions.EX_succ_e,
+ model.reactions.EX_glc_e)
+ ko = GeneKnockoutOptimization(model=model, objective_function=obj)
+ ko.run(max_evaluations=50000, n=1, mutation_rate=0.15, indel_rate=0.185)
+`Output <http://nbviewer.ipython.org/github/biosustain/cameo-notebooks/blob/master/05-predict-gene-knockout-strategies.ipynb>`__
+Predict heterologous pathways for a desired chemical.
+ from cameo.strain_design import pathway_prediction
+ predictor = pathway_prediction.PathwayPredictor(model)
+ pathways = predictor.run(product="vanillin")
+`Output <http://nbviewer.ipython.org/github/biosustain/cameo-notebooks/blob/master/07-predict-heterologous-pathways.ipynb>`__
+Contributions
+~~~~~~~~~~~~~
+
+%package -n python3-cameo
+Summary: cameo - computer aided metabolic engineering & optimization
+Provides: python-cameo
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-cameo
+|Join the chat at https://gitter.im/biosustain/cameo| |PyPI| |License|
+|Build Status| |Coverage Status| |DOI| |zenhub| |binder|
+What is cameo?
+~~~~~~~~~~~~~~
+**Cameo** is a high-level python library developed to aid the strain
+design process in metabolic engineering projects. The library provides a
+modular framework of simulation and strain design methods that targets
+developers that want to develop new design algorithms and custom analysis workflows.
+Furthermore, it exposes a high-level API to users that just want to
+compute promising strain designs.
+Curious? Head over to `try.cameo.bio <http://try.cameo.bio>`__
+and give it a try.
+Please cite https://doi.org/10.1021/acssynbio.7b00423 if you've used cameo in a scientific publication.
+Installation
+~~~~~~~~~~~~
+Use pip to install cameo from `PyPI <https://pypi.python.org/pypi/cameo>`__.
+ $ pip install cameo
+In case you downloaded or cloned the source code from `GitHub <https://github.com/biosustain/cameo>`__
+or your own fork, you can run the following to install cameo for development.
+ $ pip install -e <path-to-cameo-repo> # recommended
+You might need to run these commands with administrative
+privileges if you're not using a virtual environment (using ``sudo`` for example).
+Please check the `documentation <http://cameo.bio/installation.html>`__
+for further details.
+Documentation and Examples
+~~~~~~~~~~~~~~~~~~~~~~~~~~
+Documentation is available on `cameo.bio <http://cameo.bio>`__. Numerous `Jupyter notebooks <http://nbviewer.ipython.org/github/biosustain/cameo-notebooks/tree/master/>`__
+provide examples and tutorials and also form part of the documentation. They are also availabe in executable form on (`try.cameo.bio <http://try.cameo.bio>`__).
+Furthermore, course materials for a two day cell factory engineering course are available `here <https://biosustain.github.io/cell-factory-design-course/>`__.
+High-level API (for users)
+^^^^^^^^^^^^^^^^^^^^^^^^^^
+Compute strain engineering strategies for a desired product in a number
+of host organisms using the high-level interface (runtime is on the order of hours).
+ from cameo.api import design
+ design(product='L-Serine')
+`Output <http://nbviewer.ipython.org/github/biosustain/cameo-notebooks/blob/master/08-high-level-API.ipynb>`__
+The high-level API can also be called from the command line.
+ $ cameo design vanillin
+For more information run
+ $ cameo --help
+Low-level API (for developers)
+^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
+Find gene knockout targets using evolutionary computation.
+ from cameo import models
+ from cameo.strain_design.heuristic import GeneKnockoutOptimization
+ from cameo.strain_design.heuristic.objective_functions import biomass_product_coupled_yield
+ model = models.bigg.e_coli_core
+ obj = biomass_product_coupled_yield(
+ model.reactions.Biomass_Ecoli_core_w_GAM,
+ model.reactions.EX_succ_e,
+ model.reactions.EX_glc_e)
+ ko = GeneKnockoutOptimization(model=model, objective_function=obj)
+ ko.run(max_evaluations=50000, n=1, mutation_rate=0.15, indel_rate=0.185)
+`Output <http://nbviewer.ipython.org/github/biosustain/cameo-notebooks/blob/master/05-predict-gene-knockout-strategies.ipynb>`__
+Predict heterologous pathways for a desired chemical.
+ from cameo.strain_design import pathway_prediction
+ predictor = pathway_prediction.PathwayPredictor(model)
+ pathways = predictor.run(product="vanillin")
+`Output <http://nbviewer.ipython.org/github/biosustain/cameo-notebooks/blob/master/07-predict-heterologous-pathways.ipynb>`__
+Contributions
+~~~~~~~~~~~~~
+
+%package help
+Summary: Development documents and examples for cameo
+Provides: python3-cameo-doc
+%description help
+|Join the chat at https://gitter.im/biosustain/cameo| |PyPI| |License|
+|Build Status| |Coverage Status| |DOI| |zenhub| |binder|
+What is cameo?
+~~~~~~~~~~~~~~
+**Cameo** is a high-level python library developed to aid the strain
+design process in metabolic engineering projects. The library provides a
+modular framework of simulation and strain design methods that targets
+developers that want to develop new design algorithms and custom analysis workflows.
+Furthermore, it exposes a high-level API to users that just want to
+compute promising strain designs.
+Curious? Head over to `try.cameo.bio <http://try.cameo.bio>`__
+and give it a try.
+Please cite https://doi.org/10.1021/acssynbio.7b00423 if you've used cameo in a scientific publication.
+Installation
+~~~~~~~~~~~~
+Use pip to install cameo from `PyPI <https://pypi.python.org/pypi/cameo>`__.
+ $ pip install cameo
+In case you downloaded or cloned the source code from `GitHub <https://github.com/biosustain/cameo>`__
+or your own fork, you can run the following to install cameo for development.
+ $ pip install -e <path-to-cameo-repo> # recommended
+You might need to run these commands with administrative
+privileges if you're not using a virtual environment (using ``sudo`` for example).
+Please check the `documentation <http://cameo.bio/installation.html>`__
+for further details.
+Documentation and Examples
+~~~~~~~~~~~~~~~~~~~~~~~~~~
+Documentation is available on `cameo.bio <http://cameo.bio>`__. Numerous `Jupyter notebooks <http://nbviewer.ipython.org/github/biosustain/cameo-notebooks/tree/master/>`__
+provide examples and tutorials and also form part of the documentation. They are also availabe in executable form on (`try.cameo.bio <http://try.cameo.bio>`__).
+Furthermore, course materials for a two day cell factory engineering course are available `here <https://biosustain.github.io/cell-factory-design-course/>`__.
+High-level API (for users)
+^^^^^^^^^^^^^^^^^^^^^^^^^^
+Compute strain engineering strategies for a desired product in a number
+of host organisms using the high-level interface (runtime is on the order of hours).
+ from cameo.api import design
+ design(product='L-Serine')
+`Output <http://nbviewer.ipython.org/github/biosustain/cameo-notebooks/blob/master/08-high-level-API.ipynb>`__
+The high-level API can also be called from the command line.
+ $ cameo design vanillin
+For more information run
+ $ cameo --help
+Low-level API (for developers)
+^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
+Find gene knockout targets using evolutionary computation.
+ from cameo import models
+ from cameo.strain_design.heuristic import GeneKnockoutOptimization
+ from cameo.strain_design.heuristic.objective_functions import biomass_product_coupled_yield
+ model = models.bigg.e_coli_core
+ obj = biomass_product_coupled_yield(
+ model.reactions.Biomass_Ecoli_core_w_GAM,
+ model.reactions.EX_succ_e,
+ model.reactions.EX_glc_e)
+ ko = GeneKnockoutOptimization(model=model, objective_function=obj)
+ ko.run(max_evaluations=50000, n=1, mutation_rate=0.15, indel_rate=0.185)
+`Output <http://nbviewer.ipython.org/github/biosustain/cameo-notebooks/blob/master/05-predict-gene-knockout-strategies.ipynb>`__
+Predict heterologous pathways for a desired chemical.
+ from cameo.strain_design import pathway_prediction
+ predictor = pathway_prediction.PathwayPredictor(model)
+ pathways = predictor.run(product="vanillin")
+`Output <http://nbviewer.ipython.org/github/biosustain/cameo-notebooks/blob/master/07-predict-heterologous-pathways.ipynb>`__
+Contributions
+~~~~~~~~~~~~~
+
+%prep
+%autosetup -n cameo-0.13.6
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-cameo -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon May 15 2023 Python_Bot <Python_Bot@openeuler.org> - 0.13.6-1
+- Package Spec generated