summaryrefslogtreecommitdiff
path: root/python-canonicaljson.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-canonicaljson.spec')
-rw-r--r--python-canonicaljson.spec75
1 files changed, 75 insertions, 0 deletions
diff --git a/python-canonicaljson.spec b/python-canonicaljson.spec
new file mode 100644
index 0000000..3af1936
--- /dev/null
+++ b/python-canonicaljson.spec
@@ -0,0 +1,75 @@
+%global _empty_manifest_terminate_build 0
+Name: python-canonicaljson
+Version: 1.6.5
+Release: 1
+Summary: Canonical JSON
+License: Apache License, Version 2.0
+URL: https://github.com/matrix-org/python-canonicaljson
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/64/13/017c9bed81f7f5b72470fe5892b25cc212299bd3d79e2d30f2f99c22c517/canonicaljson-1.6.5.tar.gz
+BuildArch: noarch
+
+Requires: python3-simplejson
+Requires: python3-typing-extensions
+Requires: python3-frozendict
+
+%description
+
+
+%package -n python3-canonicaljson
+Summary: Canonical JSON
+Provides: python-canonicaljson
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-canonicaljson
+
+
+%package help
+Summary: Development documents and examples for canonicaljson
+Provides: python3-canonicaljson-doc
+%description help
+
+
+%prep
+%autosetup -n canonicaljson-1.6.5
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-canonicaljson -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed Mar 08 2023 Python_Bot <Python_Bot@openeuler.org> - 1.6.5-1
+- Package Spec generated