summaryrefslogtreecommitdiff
path: root/python-celery.spec
diff options
context:
space:
mode:
authorCoprDistGit <copr-devel@lists.fedorahosted.org>2023-03-08 07:09:50 +0000
committerCoprDistGit <copr-devel@lists.fedorahosted.org>2023-03-08 07:09:50 +0000
commit29ef8a76a42ed605b93f5b072adb5b41b6e37940 (patch)
tree627f2ee8cb72f132890bbf9423bbd604c8fdfcc0 /python-celery.spec
parent4ce3bfc9aeaba62ceb4b3e77b820ba6c8d009b55 (diff)
automatic import of python-celery
Diffstat (limited to 'python-celery.spec')
-rw-r--r--python-celery.spec117
1 files changed, 117 insertions, 0 deletions
diff --git a/python-celery.spec b/python-celery.spec
new file mode 100644
index 0000000..ef61e53
--- /dev/null
+++ b/python-celery.spec
@@ -0,0 +1,117 @@
+%global _empty_manifest_terminate_build 0
+Name: python-celery
+Version: 5.2.7
+Release: 1
+Summary: Distributed Task Queue.
+License: BSD
+URL: http://celeryproject.org
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/ce/21/41a0028f6d610987c0839250357c1a00f351790b8a448c2eb323caa719ac/celery-5.2.7.tar.gz
+BuildArch: noarch
+
+Requires: python3-pytz
+Requires: python3-billiard
+Requires: python3-kombu
+Requires: python3-vine
+Requires: python3-click
+Requires: python3-click-didyoumean
+Requires: python3-click-repl
+Requires: python3-click-plugins
+Requires: python3-importlib-metadata
+Requires: python3-pyArango
+Requires: python3-cryptography
+Requires: python3-azure-storage-blob
+Requires: python3-brotli
+Requires: python3-brotlipy
+Requires: python3-cassandra-driver
+Requires: python3-consul2
+Requires: python3-pydocumentdb
+Requires: python3-couchbase
+Requires: python3-pycouchdb
+Requires: python3-Django
+Requires: python3-boto3
+Requires: python3-elasticsearch
+Requires: python3-eventlet
+Requires: python3-gevent
+Requires: python3-librabbitmq
+Requires: python3-pylibmc
+Requires: python3-pymongo[srv]
+Requires: python3-msgpack
+Requires: python3-memcached
+Requires: python3-pyro4
+Requires: python3-pytest-celery
+Requires: python3-redis
+Requires: python3-boto3
+Requires: python3-softlayer-messaging
+Requires: python3-ephem
+Requires: python3-sqlalchemy
+Requires: python3-kombu[sqs]
+Requires: python3-tblib
+Requires: python3-tblib
+Requires: python3-PyYAML
+Requires: python3-kazoo
+Requires: python3-zstandard
+
+%description
+This project relies on your generous donations.
+If you are using Celery to create a commercial product, please consider becoming our `backer`_ or our `sponsor`_ to ensure Celery's future.
+
+%package -n python3-celery
+Summary: Distributed Task Queue.
+Provides: python-celery
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-celery
+This project relies on your generous donations.
+If you are using Celery to create a commercial product, please consider becoming our `backer`_ or our `sponsor`_ to ensure Celery's future.
+
+%package help
+Summary: Development documents and examples for celery
+Provides: python3-celery-doc
+%description help
+This project relies on your generous donations.
+If you are using Celery to create a commercial product, please consider becoming our `backer`_ or our `sponsor`_ to ensure Celery's future.
+
+%prep
+%autosetup -n celery-5.2.7
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-celery -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed Mar 08 2023 Python_Bot <Python_Bot@openeuler.org> - 5.2.7-1
+- Package Spec generated